PDA

View Full Version : Cannot read 650MB VCD's



KG4PEQ
10th August 2004, 08:42 AM
Hello world,

I have spent the last three hours or so pulling my hair out over a problem reading Video CD's. I tried every player under the sun and nothing worked, realized the discs couldn't be mounted, fought with all kinds of errors, slandered Linus's mother, and eventually figured out that I can read and play VCD's I've burned to 700MB CD-R's, but *not* 650MB CD-R's.

Attempting to work with VCD's on 650MB CD-R's will return any of a variety of errors, but it all comes down to the fact they cannot be mounted (bad filesystem type or bad superblock). VCD's on 700MB CD-R's work just fine. Also, I can read from 650MB CD-R's just fine so long as they are *not* VCD's (regular data and music are okay).

Does anyone know what might be going wrong? Perhaps any special tricks I can use? I really don't want to have to go to the Windows box (which, by the way, has no trouble with the 650MB VCD's) and copy each of these VCD's from 650MB to 700MB CD-R's.

For what it's worth, I'm running Fedora Core 2 (kernel 2.6.5-1.358) on an HP Pavilion ze5500 laptop. The CD-ROM drive is identified as an "HL-DT-ST RW/DVD GCC-4241N" and is a CD-RW/DVD-ROM combo drive. I have no idea who manufactures the darn thing, but that shouldn't be particularly relevent anyway, should it?

Thanks for your help!

Steve

debottam
28th August 2008, 09:12 AM
Fedora 9 VCD copy problem solved

After trying for so many days, I have succeeded to copy VCD files in fedora 9.

Actually in windows it is too much easy to copy the VCD files. Just open the VCD and you will get the folder “MPEGAV” which contains the VCD files (*.dat). Then you can select the files and copy to your hard disk as usual. Basically the VCD file's extension in the VCD becomes '.dat' i.e data file, but they are not simple data files. Therefore windows at first rip the VCD files at background, then copy them onto the hard disk. We can not visualize the ripping action from foreground.
In Fedora 9, when we try to copy a VCD file, it can not copy, because like windows it does not start the ripping action automatically in background. So to copy the VCD files you have to rip the VCD files manually. The software which helps to copy VCD files, is K3B burning software. K3B actually use 'vcdxrip' program to rip VCD files in background. Vcdxrip actually is included in the rpm package “vcdimager”. To copy VCD files following steps should be performed--------

step1: install the following rpm packages to update K3B using cammand--
# yum install rpmfile_name (to install rpm file)
# yum update rpmfile_name (to update rpm file)
If installation or update fails using yum then use following cammand----
# rpm -ivh rpmfile_name

Packages to be installed or updated:-
1) k3b-1.0.5-3.fc9.i386.rpm
2) emovix-0.8.0-1.rhfc3.nr.i386.rpm
3) kdelibs-devel-4.0.3-7.fc9.i386.rpm
4) kdebase-workspace-devel-4.0.3-20.fc9.i386.rpm
5) kdemultimedia-devel-4.0.3-3.fc9.i386.rpm
6) mpg123-1.4.2-1.fc9.i386.rpm
7) normalize-0.7.7-4.fc3.rf.i386.rpm
8) perl-Audio-Play-MPG123-0.63-1.1.fc3.rf.noarch.rpm
9) imlib2-1.4.0-5.fc9.i386.rpm
10) ffmpeg-0.4.9-0.10.20080510.fc9.i386.rpm
11) ffmpeg-libpostproc-0.4.9-0.10.20080510.fc9.i386.rpm
12) libquicktime-1.0.2-2.fc9.i386.rpm
13) SDL_gfx-2.0.16-5.fc9.i386.rpm
14) transcode-1.0.5-2.fc9.i386.rpm

step2: Insert the VCD into your cdrom.
Step3: Now start the application K3B.
Step4: You will get an option “Further actions..” at the bottom of the K3B wizard.
Step5: Click on the “Further actions..” and you will get various cd/dvd burning techniques, among which an option “Rip Video CD” at the bottom of the list. Click on it.
Step6: Now a message window appears in front of you. In the message window you will get 2 buttons
one is “MOUNT CD” and other is “SHOW VIDEO TRACKS”. Click on “SHOW VIDEO TRACKS”.
Step7: Ultimately click on the option “Start Ripping” on the top and select the destination folder to copy the VCD files. But in this case, the VCD files are saved into the hard disk in mpg form (*.mpg). Hence VCD dat files are converted to mpg files.

Dies
28th August 2008, 03:43 PM
4 years for the wrong answer...


That's pretty good response times. :D