PDA

View Full Version : A locale problem confused me.



hantsy
13th November 2008, 03:26 AM
my /etc/sysconfig/i18n file content is.



LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"



But after I loggined as a normal user.
I type locale command in gnome terminal . It is displayed.



[hantsy@localhost ~]$ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=



I do not know which application modify the "UTF8" to "utf8".
Some application run and cause problem due to the locale setting.

Anyone know the reason?

Thanks.

scottro
13th November 2008, 04:19 AM
This has become, in my limited experience, less of a problem as UTF-8 matures.

You can always doing something like export LC_ALL=en_US.UTF-8, or adding LC_ALL=en_US.UTF_8 to your .bash_profile.

(If the latter, you probably have to log out and log back in.)

I'm not sure if that will solve it, but it might help. I usually just worry about LC_CTYPE, but my needs are fairly unsophisticated.

hantsy
13th November 2008, 05:17 AM
For example , I found RealPlayer had a problem when the locale set to "en_US.utf8".
Today I launched RealPlayer from menu, I found it was too slow to display the UI.
I think there maybe is a problem .
Then I type realplay in Gnome Terminal and get the following message.


** (process:4421): WARNING **: Unsupported locale en_US.utf8! Please use a locale with .UTF-8 suffix! For example: export LANGUAGE=en_US.UTF-8


But before , the locale settings is correctly.
I do not know which application change the locale setting.