PDA

View Full Version : Rpm



edge87
10th August 2004, 01:50 AM
I reciently tried to install Pleask 7 and it failed alot of the rpms inside of it failed complaing that the os was missing sum rpms....this comes to a surprise to me bc it was build for fedura core, it also told me to do this:::::::::: Rpm -q <packagename> .

so i inputed package after package that it told me to check for b4 attemping to install ,and none of them existed on my system. i did a full install i installed EVERYTHING. it says im missing ...

bind-9.2.2.P3-9.i386.rpm
compat-libstdc++-7.3-2.96.118.i386.rpm
curl-7.10.6-7.i386.rpm
cyrus-sasl-2.1.15-6.i386.rpm
expat-1.95.5-3.i386.rpm
fam-2.6.8-12.i386.rpm
gdbm-1.8.0-21.i386.rpm
httpd-2.0.49-1.1.i386.rpm
libgcc-3.3.2-1.i386.rpm
libjpeg-6b-29.i386.rpm
libstdc++-3.3.2-1.i386.rpm
libxml2-2.6.6-3.i386.rpm
mod_perl-1.99_12-2.i386.rpm
mod_ssl-2.0.49-1.1.i386.rpm
mysql-3.23.58-4.i386.rpm
mysql-server-3.23.58-4.i386.rpm
ncurses-5.3-9.i386.rpm
netpbm-progs-9.24-12.1.1.i386.rpm
ntp-4.1.2-5.i386.rpm
openssl-0.9.7a-33.10.i686.rpm
perl-5.8.3-16.i386.rpm
perl-DBD-MySQL-2.9002-1.i386.rpm
perl-suidperl-5.8.3-16.1.i386.rpm
perl-HTML-Parser-3.26-18.i386.rpm
perl-HTML-Tagset-3.03-28.noarch.rpm
perl-libwww-perl-5.65-6.noarch.rpm
perl-URI-1.21-7.noarch.rpm
php-4.3.6-1.3.i386.rpm
php-imap-4.3.6-1.3.i386.rpm
php-mysql-4.3.6-1.3.i386.rpm
sharutils-4.2.1-17.i386.rpm
unzip-5.50-35.i386.rpm
webalizer-2.01_10-14.i386.rpm
xinetd-2.3.12-4.10.0.i386.rpm

im also a lil confused on how rpms work...also do i have to be in a specific directory to check for the rpms with the rpm -q , bc i just did it from my home folder :confused:

ogetbilo
10th August 2004, 02:29 AM
You can use the -q switch for rpm in any folder. Actually it does not do anything to your folders.
when u install an rpm using

rpm -ivh <filename>

the program files will usually be stored in /usr/share or /usr/lib
and the configuration files are usually kept at /etc

Can you tell us where u got your pleask rpm from?

edge87
10th August 2004, 02:35 AM
http://www.sw-soft.com/en/download

is the link...idk which one im supost to pick .im still a major noob.. but im willing to learn. Ne ways thats where i got my rpm of Plesk...i

ogetbilo
10th August 2004, 02:51 AM
can you please post the output of

rpm -ivh <plesk.rpm file>

where <plesk.rpm file> is the rpm file you downloaded from this website
execute this command there where you downloaded your rpm

edge87
10th August 2004, 02:53 AM
Theres more then ONE rpm within the rpm....theres like about 20 and about 15 of them go....the rest wont . when i read the install stuff..(which i should of done first ) it said i needed all those packages...i have NONE Of them acording to my RPM -q <list>

ogetbilo
10th August 2004, 02:57 AM
then you need to google around for those rpms you are missing (if you know the exact names of them)
or try sites like rpmfind.net

edge87
10th August 2004, 03:00 AM
Ok i found a auto install patch but its mad @ my new Os

psa-7.1.1-rh9.build71040802.18.i586.rpm.tar.gz
psa_installer_v1.0.0_build040714.11_os_RedHat_9_i6 86
services
Unreal3.2
[edge87@localhost edge87]$ ./psa_installer_v1.0.0_build040714.11_os_RedHat_9_i6 86
Red Hat 2 is detected, but this autoinstaller
build is made for Red Hat 9.
Exiting autoinstaller.
[edge87@localhost edge87]$

It said that about my os "fedora Core 2"....i downloaded .tar.gz for fedora core 1 , and then i tried redhatt 9's version. and it wont work...no way around that is there?