PDA

View Full Version : Booting the kernal takes a long time



digby
18th May 2004, 03:56 PM
Well, I just installed FC2 on my systerm. Let me give you my setup and some relevant information before I describe the problem:

When I first attempted the install, I used Anaconda to repartition some space that I had previously allocated to Mandrake 9.2 and FC1. I also have Win2k residing on my HD. I chose not to install grub during the installation since I already had Lilo going. I was just going to add the information myself. When I rebooted, Lilo didn't work... it printed about 1/2 a screen of "99" and halted. I used the Win2k recovery console to rewrite the MBR and decided to make the partitions from Windows. I made 3: "/", "swap", and "/home." I reattepmted to install FC2 and everything was fine until I had to reboot at the end. Grub came up just like it should (and boots Windows fine). When I boot FC2, I get this:

Booting `Fedora Core 2 (2.6.5-1.358)'

root (hd0,4)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.5-1.358.img
[Linux-initrd @ 0x37fc2000, 0x2d9c4 bytes}

Uncompressing Linux... Ok, booting the kernel
audit (108473155.360:0): initialized

At this point it just sits for about a minute. After that it will boot. (I'm posting from it now) But I would, of course, prefer a system that didn't sit so long before it was usable. If you can point me in the direction of a solution, I would appreciate it.

AMD XP2500+
Abit NF7-S v2
1 Gig PC3200
Geforce 4 Ti4600 8x AGP w/ 128 MB RAM
using nForce2 audio and NIC

Thanks,
Matt

If it matters, I'm using Grub 0.94

Bana
19th May 2004, 05:22 AM
Wow, that is really strange, my computer does this too (I have weird partitions setup as well). Not a minute (more like 5 secs or so) but it is awfully coincidental. Keep a watch on the fedora-list for reports of the same problem (also might want to search bugzilla).

radonsg
20th May 2004, 06:25 AM
I get the same long boot up time as u did. But think for my case it took me around 1 & a half minutes to boot. Wonder why? I also get a smartd failed to load up error. Wonder if it got anything to do with the harddisk?

AMD XP2600+
Asus A7N8x Deluxe ver 1.x
1 Sata Hitachi (HGST) 7K250 ~160GB
Silicon 3112A SataRaid
1 Gig PC3200 Ram
Geforce 4 MX
nForce2 audio and NIC

LordMorgul
20th May 2004, 07:11 AM
Hmm... I have a recompiled kernel 2.6.5-1.358 that hung at that point.. but I did not wait around for a minute. I will check whether it boots or not after awhile. The interesting thing is, the default FC2 -1.358 kernel does boot for me.. so if my own does that strange delayed boot it would be very interesting.

radonsg
20th May 2004, 07:51 AM
I know wat the problem lies for my case. Cos I only have a single sata harddisk connecting to my Silicon 3112A sataraid. When linux boot up, it is attempting to find the other harddisk which is not there. Thus taking up a long time.
Although I know the problem, I still do not know how to solve it. Can anyone help? Thanks.

ide1 at 0x170-0x177,0x376 on irq 15
SiI3112 Serial ATA: IDE controller at PCI slot 0000:01:0b.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 11
ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
ide3: MMIO-DMA , BIOS settings: hdg:pio, hdh:pio
hde: HDS722516VLSA80, ATA DISK drive
ide2 at 0x4284d080-0x4284d087,0x4284d08a on irq 11
hdg: no response (status = 0xfe)
hdg: no response (status = 0xfe), resetting drive
hdg: no response (status = 0xfe)
hde: max request size: 64KiB
hde: 321672960 sectors (164696 MB) w/7938KiB Cache, CHS=20023/255/63
hde: hde1 hde2 < hde5 hde6 hde7 hde8 hde9 hde10 hde11 >

digby
20th May 2004, 05:25 PM
I also got the smartd failure and the same problem with 1 SATA drive... I was going to tackle them next... I have no idea what to do about either one

Bana
21st May 2004, 02:53 AM
Yes I also have 1 SATA drive on a Sil Image 3114. Maybe this needs to go in bugzilla so it will go upstream.

LordMorgul
21st May 2004, 05:43 AM
I agree, that sounds like a hardware specific issue that should show up in bugzilla.

radonsg
21st May 2004, 06:45 AM
So has any file the hardware isssue to bugzilla yet?

LordMorgul
21st May 2004, 06:57 PM
This appears to be similar.
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122166

Try out the suggested fix (kernel parameters):
hde=noprobe hdg=noprobe

radonsg
22nd May 2004, 06:00 PM
LordMorgul:
Ye, I had already tried the method before. It work but the problem of "smartd" is still there. So I was hoping of more like a kernel patch to solve the whole thingy. Thanks a lot LordMorgul. :p

rth
24th May 2004, 05:45 PM
I have the same problem... I know that if in Grub you add to your kernel line "hdg=noprobe" (IIRC) then it won't probe for a 2nd SATA drive assuming you only have one.

However, I can't even get it to install on my SATA drive. I had to install a PATA in order for the install to complete.

See:
http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2051

Note that I have a Gigabyte 7NNXP mobo

radonsg
25th May 2004, 04:10 AM
rth, I have no prob installing the FC2 to my single Sata harddisk, just that the long booting problem only. Your prob seems much greater, can't even install on your sata harddisk. Did u try to be a console based installation instead of a GUI one?

rth
26th May 2004, 01:39 AM
I tried both installs. Neither was very informative (as the link shows). I was at enough of a loss I put in a PATA drive and am running it off there. I'd prefer just to use the SATA drive, but I have no choice.

The drive is also not defective as Windows and Gentoo both install on it without issue.

mobz
8th June 2004, 09:03 PM
Same problem here. Using Asus A7N8X Deluxe too. Has anyone solved this problem yet???

EDIT: Ahhh...one step closer to solution


Try out the suggested fix (kernel parameters):
hde=noprobe hdg=noprobe

Where should i put those lines???:rolleyes:

LordMorgul
9th June 2004, 10:59 PM
During the installer it should be:
linux hde=noprobe hdg=noprobe
when you get the option of what type of install to perform.. graphical, text, or rescue mode.

If the system is already installed then those parameters should be added to the end of the kernel line in the grub config:
kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ hde=noprobe hdg=noprobe

manub
10th June 2004, 05:41 AM
I hadn't this problem, using A7N8X Deluxe 2.0 and two SATA harddrives. For the smartd.conf failure, I used to change default values to /dev/hde and /dev/hdg. I hadn't problems installing FC2, the only problem is when I reboot my machine ... hard disk shut down and don't power up during restart (so I have to shut down PC and then power on).

radonsg
10th June 2004, 06:15 AM
u sld put the the line inside your grub.conf file or lilo if it wat u using

manub
10th June 2004, 06:23 AM
I was talking about the smartd.conf issue. As I have two SATA hard drives, my kernel booting doesn't take too much time.

radonsg
10th June 2004, 06:28 AM
edit your smartd.conf file. For my case, i change the hda to hde cos I using hde for my harddisk. So u just need to change to watever hdx/sdx device that u r using

manub
10th June 2004, 06:35 AM
already know about this. I've a question for you ... when you reboot your machine, do it restart properly ? no problems in shutting down hard drives ? my drives shut down but don't power up during reboot phase, so my machine hangs.

radonsg
10th June 2004, 06:45 AM
there is a bug on the kernel that makes the harddisk shutdown on reboot. U will have to patch your kernel on the update or wait to c if fedora release a update kernel on fixing this prob. Or u can use arjanv custom 2.6.6 kernel, it solve the prob

manub
10th June 2004, 06:54 AM
I'm not so experienced in kernel pathcing and similar things, so I think I'll wait to Fedora to release a patch. Do this bug is reported to BugZilla ?

radonsg
10th June 2004, 07:01 AM
check this out
http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2277&highlight=harddisk

manub
10th June 2004, 07:23 AM
thanks :D

CrystalCowboy
16th September 2004, 12:51 AM
May I join the club? My mobo is an ASUS A7N8X-E Deluxe, with the 3112A SATA RAID controller. I installed FC2 from the DVD iso, so it was kernel 2.6.5-1.358 and it gave me no problems installing to the single SATA disk as /dev/hde. Soon after, I did a yum update and brought it up to kernel 2.6.8-1.521. I get the long 'auditing" pause during bootup, and the disk finally shows up as SCSI /dev/sda instead of IDE /dev/hde (which means the swap didn't get mounted either). I'll try the noproble thing tomorrow.

I am also encountering the cdrecord failure discussed in other threads. I don't want to go back to the 2.6.5 kernel because in that one the IEEE1394 was busted. I thought 2.6.x was supposed to be a stable tree?

radonsg
16th September 2004, 02:18 AM
May I join the club? My mobo is an ASUS A7N8X-E Deluxe, with the 3112A SATA RAID controller. I installed FC2 from the DVD iso, so it was kernel 2.6.5-1.358 and it gave me no problems installing to the single SATA disk as /dev/hde. Soon after, I did a yum update and brought it up to kernel 2.6.8-1.521. I get the long 'auditing" pause during bootup, and the disk finally shows up as SCSI /dev/sda instead of IDE /dev/hde (which means the swap didn't get mounted either). I'll try the noproble thing tomorrow.

I am also encountering the cdrecord failure discussed in other threads. I don't want to go back to the 2.6.5 kernel because in that one the IEEE1394 was busted. I thought 2.6.x was supposed to be a stable tree?

Ahh yes. Cos using sata ide modules is deprecated from 2.6.8 onwards. Your sata drive will be using the SCSI modules from then onwards. All u need to do is to edit your /etc/fstab to change all the hdx to sdx. But be sure u change the drive accordingly. Do not mixed the drives up.

LordMorgul
25th September 2004, 10:21 AM
I thought 2.6.x was supposed to be a stable tree?
Not in the same manner that 2.2 and 2.4 were considered stable trees. 2.6 has so far assumed a very aggressive development and is changing alot... not a whole lot changed from the 2.5.x development, its still steaming ahead as if 2.6 was an odd number. ;) But good things are happening along with the little breakages.