PDA

View Full Version : mysqld won't start



Aardvark Freak
8th August 2004, 05:26 AM
i installed mysql with apt-get install mysql-server. it installed fine. but when i try to start the service, i get this error:

# /sbin/service mysqld start
Timeout error occurred trying to start MySQL Daemon.
Starting MySQL: [FAILED]
i've never installed mysql before, so is there something else i have to do before it will work correctly?

Aardvark Freak
11th August 2004, 07:59 PM
nobody knows? well, let me rephrase my question.

is there a guide somewhere on how to get mysql working on fc2? do you have to do anything after installing the rpm? have other people gotten it working? if so, what did you do?

ewdi
11th August 2004, 08:07 PM
Post your my.cnf and also the error log file

Aardvark Freak
11th August 2004, 08:27 PM
here is the my.cnf, i believe it's the default.

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock

[mysql.server]
user=mysql
basedir=/var/lib

[safe_mysqld]
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

error log:

040808 00:25:33 mysqld started
Cannot initialize InnoDB as 'innodb_data_file_path' is not set.
If you do not want to use transactional InnoDB tables, add a line
skip-innodb
to the [mysqld] section of init parameters in your my.cnf
or my.ini. If you want to use InnoDB tables, add to the [mysqld]
section, for example,
innodb_data_file_path = ibdata1:10M:autoextend
But to get good performance you should adjust for your hardware
the InnoDB startup options listed in section 2 at
http://www.innodb.com/ibman.html
040808 0:25:33 /usr/libexec/mysqld: Incorrect information in file: './mysql/host.frm'
040808 00:25:33 mysqld ended

Paul_Vandenberg
11th August 2004, 08:51 PM
I'ver always started the MYSQL service through the Services GUI tool under System Settings. The precise name of the tool escapes me at the momment and I can't check it because I'm on a Windows box at work. Anyway, it's always worked for me. Perhaps the script that the tool generates has a parm or something.

Paul

Aardvark Freak
11th August 2004, 08:53 PM
when i start it through the gui, it says "mysqld dead but subsys locked" and i get the same error in the error log.

ewdi
11th August 2004, 09:12 PM
okay, you should add skip-innodb under socket=/var/lib/mysql/mysql.sock and then try again

Aardvark Freak
11th August 2004, 11:24 PM
i did that, but it still won't work. now the log contains this this:

040811 18:22:30 mysqld started
040811 18:22:30 /usr/libexec/mysqld: Incorrect information in file: './mysql/host.frm'
040811 18:22:30 /usr/libexec/mysqld: Normal shutdown
i can't find any host.frm file on my system.

Aardvark Freak
14th August 2004, 06:37 PM
now i've found host.frm, it's in /var/lib/mysql/mysql/host.frm. for some reason the gnome search program couldn't find it though.

anyways, it appears that it's not a text file, so i don't know how to edit it if there's something wrong. can anyone help?

jbarendse
23rd August 2004, 11:03 AM
I have the same problem on FC1 with a clean installation and a clean RPM (yum) installation of mysql-server-3.23.58-4. It seams like a bug in FC1 in combination with MySQL. The most strange part is the "mysqld start" reports a time-out but the service seams to run with "ps -aux|grep mysql".

If you search google.com with this problems you get a lot of result but nobody knows an answer. Everybody is looking in the config but I think ther is same other problemen. Most likly a bug?

goe
24th August 2004, 03:03 PM
I have exactly the same problem with my fedora2 :(
I try to start mysql server and I get "mysqld dead but subsys locked" !!!
What can I do to make it work?

Please help!
goe

tommytomato
30th August 2004, 12:29 PM
what OS are you using.

TT

Paul_Vandenberg
30th August 2004, 01:20 PM
Last week, I tried MySQL on FC2 for the first time and I got the same error, i.e. "mysqld dead but subsys locked". I played around with the startup script and couldn't get it to work. I uninstalled MySQL and installed PostgreSQL instead. A couple of days later, I decided to try MySQL again, and it worked! I don't know what I did!

LLS
24th September 2004, 05:03 PM
when i start it through the gui, it says "mysqld dead but subsys locked" and i get the same error in the error log.
I found this posted on another forum--- try at own risk

If you run

killall -9 mysqld ---> may take a couple of attempts

then
/etc/rc.d/init.d/mysqld restart
mysql should turn over and run fine again.

pcranger
24th September 2004, 06:32 PM
try starting it up with....


/etc/init.d/mysqld start

jcolt45
9th January 2005, 01:48 AM
I found this post and it worked http://www.linuxquestions.org/questions/history/262262

linux_fed2
12th January 2005, 06:16 AM
i have the same problem when i install mysql in FC1 box. what i did is, i uninstalled mysql-server then install mysql using yum install mysql then yum install mysql-server. it work find after that..

fawazeer
31st May 2005, 03:14 AM
If I install from the CD "Fedora core 3" mysql works fine.
If I update to 3.23.58-13 I mysql would NOT start.
It seems like there is something wrong with that update !!!!!