View Full Version : Intel GMA 4500HD

28th October 2008, 12:33 AM
I have this graphics chip in a Sony Vaio VGN-FW140E laptop, and booting to the desktop with the intel driver results in a white screen. Even after installing all the latest updates. I can get to the desktop with the vesa driver, but 1024x768 doesn't look so hot on a screen designed for 1600x900. This happens across every distro I have tried, so I don't expect a magic fix here... but since Fedora tends to be (a) the most up to date distro, and (b) the last to ship, I was wondering if there was anything coming down the pipeline that might help (new versions of drivers/xorg/mesa/etc), and where I can report the bug for fedora. Thanks!

29th October 2008, 07:18 AM
Attached here is a screenshot of what I get. I just tried the 2.5.0 driver as well, but no luck. I'm going to try the UXA rendering method, and will post back the results, but I'm not super hopeful at this point. Anyone else getting this? I see a lot of posts about lines or video tearing with this driver, but nothing like this...

29th October 2008, 09:06 AM
Ok, for some reason this wont let me post an attachment.

Anyways, I have found an upstream bug in xorg (linked below) that seems to be the cause. It appears that some models of Sony Vaio laptops don't properly send the video output to the screen. Using a separate monitor in the VGA output has X load properly.