PDA

View Full Version : ATI driver 3.11.1



micha
5th August 2004, 10:27 PM
The new 3.11.1 ATI drivers are out !!!! Go get them :
http://www.ati.com/support/drivers/linux/radeon-linux.html?type=linux&prodType=graphic&prod=productsLINUXdriver&submit.x=11&submit.y=8&submit=GO%21

I've created a patch to make the new ATI driver compile with Fedora Core 2. You can find the patch in attached file.

If you already have installed a previous version of the ATI driver, you have to remove it completely. Here are the instructions to do that.

First you have to go in true console mode (e.g. CTRL+ALT+F1). Then log on as root and shutdown Xorg:

init 3

Then remove the previous ATI driver:

rpm -e fglrx
rm -rf /lib/modules/fglrx

After that you can install and configure the ATI driver following the classical method:
http://fedorafaq.org/#radeon
http://www.fedoraforum.org/forum/showthread.php?t=16690

... and don't forget to download the new driver and the new patch posted here.

Note that this patch was only tested with the official 2.6.7-1.494.2.2 Fedora kernel.
Note also that the vanilla kernels don't require any patch ;)

-- Micha

jwiz
6th August 2004, 09:23 PM
Just updated from fglrx-4.3.0-3.9.0 and your patch worked alright for me, though things went awry at first.
Had a brainlag and forgot to 'rmmod fglrx' first! :o

Nevertheless, I downgraded to the former 3.9.0 right afterwards, as glxgears gave me abot 400 frames less with the new driver.
Used to have about 3050 frames with my Radeon 9600XT and XP2800+ but ended up with about 700 with this new driver version! :mad:

jwiz

micha
6th August 2004, 10:01 PM
The new ATI driver is better, even if it gives less FPS in glxgear or fgl_glxgear. UT2004 is now playable :)

DaNe
7th August 2004, 05:14 AM
i keep i thinking and i dont see where i commit a mistake
glxgears oly gives me in normal size 14.6 fps :O

[
root@DaNebox root]# rpm -Uvh --force /home/dane/fglrx-4.3.0-3.11.1.i386.rpm
Preparing... ########################################### [100%]
1:fglrx ########################################### [100%]
*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===
[root@DaNebox root]# cd /lib/modules/fglrx/build_mod/
[root@DaNebox build_mod]# patch -p1 < /tmp/fglrx-fedora.patch
patching file 2.6.x/Makefile
patching file make.sh
[root@DaNebox build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
[root@DaNebox build_mod]# cd ..
[root@DaNebox fglrx]# sh make_install.sh
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.

i run fglrxconfig(use in 90% of the cases the defaults options)
then i edited the xorg.conf
how u said and edit the busid!
then start x again and then i checkout the perfomance of my brandnew drivers perfomance...and what i see is top fps is 21 =X

274 frames in 13.0 seconds = 21.077 FPS
120 frames in 8.0 seconds = 15.000 FPS
120 frames in 9.0 seconds = 13.333 FPS
120 frames in 9.0 seconds = 13.333 FPS
120 frames in 8.0 seconds = 15.000 FPS
120 frames in 9.0 seconds = 13.333 FPS

micha
8th August 2004, 01:50 AM
i keep i thinking and i dont see where i commit a mistake
glxgears oly gives me in normal size 14.6 fps :O
I guess you didn't remove completely the previous ATI driver. I've posted the steps to do that in the first post of this thread.
Remove any driver and restart the installation of the new driver. Don't forget to remove the /lib/modules/fglrx folder. This should work...

vuerro
8th August 2004, 06:37 PM
I posted my Xorg.0.log

when I complete the steps after a clean fc2 install and a kernel upgrade + sourcecode
I get a blank screen

i don't think i can find it..

SWEjuggalo
9th August 2004, 02:28 AM
I can even start X after doing everything the http://fedorafaq.org/#radeon says...first it said that /dev/mouse couldn't be found...fair enough...it didn't exist there. It's /dev/input/ all the "mouse" exist ...but what here? Only /dev/input/ ? Tried /dev/input/mouse ...

What should I set this to? :

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/mouse"

I'll try one more time but with /dev/input/ ...then I give up :/

SWEjuggalo
9th August 2004, 02:52 AM
I made it...but with a kind of error when seing my desktop...will try to repete the error tomorrow and let you know what it was. Can not find anything of value in the logs...well, probably to tired..

Anyway...fixed my previous problem with the path /dev/input/mouse1

Tux Racer seems to work ,yeha! :)

kmail
9th August 2004, 07:42 AM
ok i did my installation by this "classical method" http://www.fedoraforum.org/forum/showthread.php?t=16690
with the new drivers ofcourse, everything went fine, no errors were noticed, so i booted into X but the old MEsa is still right where it used to be and no direct rendering present :(.
Here is a quote from the x log:

(II) fglrx(0): [drm] register handle = 0xed000000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x22953000 at 0xf6e3b000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xe0000000 FBMappedSize: 0x04000000
(II) fglrx(0): FBMM initialized for area (0,0)-(1024,8191)
It says cannot init agp, how can i fix this problem?

astreyon
9th August 2004, 11:59 AM
new driver compile and install properly using vanilla kernel 2.6.7
and now i know what make my laptop slower when i use the ATI driver !!!!

i switch from metacity to enlightenment and everything is OK.
i roll back to metacity and display become slower than ever :-(

anyone has an idea how to fix ?
i use metacity because it has the greatest panther themes i've ever seen

vuerro
9th August 2004, 05:48 PM
I can even start X after doing everything the http://fedorafaq.org/#radeon says...first it said that /dev/mouse couldn't be found...fair enough...it didn't exist there. It's /dev/input/ all the "mouse" exist ...but what here? Only /dev/input/ ? Tried /dev/input/mouse ...

What should I set this to? :

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/mouse"

I'll try one more time but with /dev/input/ ...then I give up :/

/dev/input/mice

hope it helps

Bear Knuckle
9th August 2004, 08:41 PM
A big THANK YOU to micha for the patch.

Installation worked at first time, I even could use my old config-file and the overall-performance in-game became much better.

Anyone can explain to me, why the values in glxgears are lower than with 3.9.0, but the in-game fps became higher?

Arrummzen
10th August 2004, 03:25 AM
I get the following when I try to run sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.5-1.358smp/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.

EDIT: The reason my kernel version is 2.6.5 in the above post, is because I ran it a second time with the 2.6.5 kernel to get output to paste here. It says 2.6.7 when I run it using the 2.6.7 kernel and I get the same error.

What have I done wrong? As far as I can tell I followed your instructions to the letter. How do I fix this? Its probly something simple, but I have little to no experence in configuring 3d for X11 servers...

Thank you for your time,
Arrummen

Littlejia
10th August 2004, 05:49 AM
when i paths the kernel,it appears somes err.please help

[root@Deadforg build_mod]# patch -p1 < /down/fgl*.pat*
patching file 2.6.x/Makefile
Reversed (or previously applied) patch detected! Assume -R? [n] y
patching file firegl_public.c
Reversed (or previously applied) patch detected! Assume -R? [n] y
patching file firegl_public.h
Reversed (or previously applied) patch detected! Assume -R? [n] y
patching file make.sh
Reversed (or previously applied) patch detected! Assume -R? [n] y
Hunk #1 succeeded at 180 with fuzz 1 (offset 4 lines).
Hunk #2 succeeded at 989 (offset -3 lines).
patching file agpgart_be.c
Hunk #1 FAILED at 1402.
Hunk #2 FAILED at 4414.
2 out of 2 hunks FAILED -- saving rejects to file agpgart_be.c.rej
patching file firegl_public.c
Hunk #1 FAILED at 2066.
1 out of 1 hunk FAILED -- saving rejects to file firegl_public.c.rej
[root@Deadforg build_mod]#

sheino
10th August 2004, 06:31 AM
Micah,
You said the vanilla kernels do not require a patch. What are you considering a vanilla kernel?

I followed the steps with the new drivers and patch and still get MESA showing up and 3D is still very slow.

Running newly installed FC2 with latest yum updates installed.

Cheers,
Darin....

Bear Knuckle
10th August 2004, 07:26 AM
A vanilla-kernel is the kernel you can get at kernel.org. It's not patched with any patches or something, like the kernels from distributors normally are.

My "without problems" came to soon. I have the problem, that the monitor is "going to spleep" (power save mode) even if I am working at the station. It immediatly "wakes up" if I move the mouse or press a key, but it's very distrubing after a while, if every 5min the monitor gets black for 3s.

Where is the setting I can change this? In the KDE-controls the power-saving is set to "Never".

Littlejia
10th August 2004, 12:32 PM
what is mean vanilla-kernel.you mean kernel.org's kernel is can't pathing ? or kernel.org's kernel was not pathing yet

i use the yum update ,it only can download 2.67 kernel.
it can be use the 2.6.7 kernel ? thank you

where is download 2.66 kernel rpm packet?

krazibon3
10th August 2004, 04:08 PM
heyas i've just sort of successfully installed the ati driver (i think), but the only problem is that when i load x server and login i get this error window popping up saying:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

what does this mean and how do i fix it?

krazibon3
11th August 2004, 02:16 AM
never mind fixed the problem anyways

had to replace the "Xfree86" to "xorg" in the keyboard section of the xorg.conf file

sheino
11th August 2004, 03:18 PM
heyas i've just sort of successfully installed the ati driver (i think), but the only problem is that when i load x server and login i get this error window popping up saying:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

what does this mean and how do i fix it?
what steps did you take to get the ATI drivers to work? I have followed Micah's steps to the letter and could not get it to work. The ATI panel would always show the Mesa lib's as the 3D drivers and the GL performance is worse than before I tried the install.

Gunny2k2
11th August 2004, 07:36 PM
erm how come in ATI Control Panel its still saying i m using Mesa project drivers :( i ve tried old drivers and new wit patches on default fd2 kernel everything i try and do always mesa drivers yet i have a dam Mobility M10 and cant use it :(

SWEjuggalo
11th August 2004, 11:06 PM
Got everything going alright later...just copied and replaced the mouse and keyboard sections from my old x-org.conf. Also removed the previosly not used settings of the mouse and keyboard rows in XF86Config-4

Alfreed
12th August 2004, 10:52 AM
I get the following when I try to run sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.5-1.358smp/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.

EDIT: The reason my kernel version is 2.6.5 in the above post, is because I ran it a second time with the 2.6.5 kernel to get output to paste here. It says 2.6.7 when I run it using the 2.6.7 kernel and I get the same error.

What have I done wrong? As far as I can tell I followed your instructions to the letter. How do I fix this? Its probly something simple, but I have little to no experence in configuring 3d for X11 servers...

Thank you for your time,
Arrummen

I had same problem, same messages!!
I found a solutiion to this problem on one site, that I can't recall now. I'm using Fedora Core 2 with Ati radeon 9200 and I also got that problem- couldn't install any ati drivers. So here comes the solution!! :)

You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/.

Simple, and now I didn't need any patches (I found about 10 of them on the web:) , and I din't know which one is THE one)
Now just type rpm -i --force fglrx-4.3.0-3.11.1.i386.rpm and it all goes without any error, the modules compile instantly:) then just change XFree86.conf to xorg conf and thets all!!:) -thats of course im my case, but as I found most of you had this problem. So it's how it worked for me, hope it helps you also!!

Alfreed
12th August 2004, 11:54 AM
and of course run fglrxconfig!!! Sorry, forgotten that one!! :)

Obiwan
12th August 2004, 04:15 PM
Thanks Micha for this wonderfull How-To, it was working very well for me ! :) :)

vuerro
13th August 2004, 05:46 PM
You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/.

Simple, and now I didn't need any patches (I found about 10 of them on the web:) , and I din't know which one is THE one)
Now just type rpm -i --force fglrx-4.3.0-3.11.1.i386.rpm and it all goes without any error, the modules compile instantly:) then just change XFree86.conf to xorg conf and thets all!!:) -thats of course im my case, but as I found most of you had this problem. So it's how it worked for me, hope it helps you also!!

This is true, when copying those files the make and make_install don't give any errors

first I removed the previous drivers..
then installed the new ones.
make
make_install

edited the new xorg.conf to have the same elements as the original
init 5

blank/dark screen.. it seems to switch to x but I don't see anything
:(

I have posted the xorg.conf and log file
the Xorg.0.log say's


(WW) fglrx(0): could not detect XFree86 version (query_status=-3)
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
[drm] failed to load kernel module "agpgart"
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 6, (OK)
drmGetBusid returned ''

maybe some hardware details helps..
Sony HMD-220 17" screen
Ati radeon 9800 pro 256mb DDRII
via kt333 chipset
athlon 2400+

vuerro
15th August 2004, 01:04 AM
this is my current xconf (used from one created with fglrxconfig only that one didn't work)
the mayor change is in the screen server layout
from ATI Graphics adapter to Videocard0
(als switched UseInternalAGPGart -- made sure to /sbin/modprobe agpgart via-agp; no errors)

so it should load the radeon module
but.. lsmod does not list it.. :confused:
it also doesn't list agpgart or via-agp or even vga or something !?

I recompiled the kernel so; agpgart, via-agp and radeon are modules (also included ntfs.. :rolleyes: )
(fist time kernel compile and everything is still running..)

Installing the drivers doesn't seem to give any problems, so do the make and make install
trying to load fglrx driver gives me a blank screen

thanks for listning :ninja: (Y)

vuerro
15th August 2004, 04:08 PM
I'm curious how other people's lsmod looks like :rolleyes:
does it list radeon? agpgart? via-agp/intel-agp??

u must recompile the kernel to load them as modules to see them, so I did and I don't see them.. anyone?? :cry:

I admit I am a newb to this but I have gotten a long way
(and I followed a lot of how-to's, pretty much standard get-x-working stuff and it didn't help)

vuerro
16th August 2004, 01:27 PM
over on neowin http://www.neowin.net !! they suggested to remove xorg and replace with XFree86 4.3

and to make all the files in /usr/src/fglrx/ executable and write enabled

any thought about that over here?
(not able to try for a few hours)

micha
16th August 2004, 01:54 PM
over on neowin http://www.neowin.net !! they suggested to remove xorg and replace with XFree86 4.3

and to make all the files in /usr/src/fglrx/ executable and write enabled

any thought about that over here?
(not able to try for a few hours)Doesn't sound like a good idea. The ATI driver works great with Xorg at the moment (except for Xv).

vuerro
16th August 2004, 02:39 PM
:sarcasm: of course they work great..

as xorg is a XFree86 4.4 beta fork isn't it? and the driver was written for XFree86 4.3
that is the only reason why I would try it.


I'm curious how other people's lsmod >output looks like
does it list radeon? agpgart? via-agp/intel-agp??

and to make all the files in /usr/src/fglrx/ executable and write enabled

micha
16th August 2004, 02:50 PM
I'm curious how other people's lsmod >output looks like. does it list radeon? agpgart? via-agp/intel-agp??
Mine doesn't have any radeon or agp modules loaded.... only fglrx (and all the other stuff to make the system works).

philio
16th August 2004, 03:45 PM
Hi there, I followed the instructions and it all worked perfectly and I have a working config for single head. I backed up the config file and ran the configuration program again to create a dual head config (used custom h/v sync taken from my working customised xorg.conf file) and otherwise set everything the same as before. When I went to restart X both screens went blank and nothing else happened so I rebooted. Now when I choose to boot fedora from grub as soon as it trys to initialise the x server for the graphic boot everything goes blank and appears to stop, I tried using I for intereactive startup and same thing happened, can anyone help me please or I'm stuck in Windoze! :(

vuerro
16th August 2004, 04:06 PM
philio, could u post your xorg.conf file for me

and as getting x running again
during grub, edit the linux line (e) and add in the vmlinuz line "init 3"

is wil start up without x and u can replace the xorg.conf file in etc/X11

philio
16th August 2004, 04:17 PM
thanks, will try that now and get the configs :)

philio
16th August 2004, 04:47 PM
Back in Linux :D I restored my original dual head config for now.

I've added 3 configs to webspace:

Working original xorg.conf with dual head: http://www.pbayfield.pwp.blueyonder.co.uk/linux/xorg.conf.dual.working

Working single head config from ati: http://www.pbayfield.pwp.blueyonder.co.uk/linux/XF86Config-4.single.works

And finally the dual head config that crashes: http://www.pbayfield.pwp.blueyonder.co.uk/linux/XF86Config-4.dual.bad

Thanks in advance for any help :)

philio
16th August 2004, 06:54 PM
On further testing on the single head config, tried to run an OpenGL app and it crashed the X server, guess thats not right either... kinda wishing I'd stuck with NVidia never had these problems with my old card :/

Edit: Even more strange... with default driver glxgears gives aroung 400 fps, with ati driver only 96 fps!!!

mtritab
17th August 2004, 04:43 PM
Thanks Alfreed thi s solved my problem. You should see about getting this added to fedorafaq. I've seen at least 3 others with this same problem. I posted this on other threads now, but have given you credit.

Solution
"You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/."


Thanks,
Mike

micha
17th August 2004, 05:47 PM
Thanks Alfreed thi s solved my problem. You should see about getting this added to fedorafaq. I've seen at least 3 others with this same problem. I posted this on other threads now, but have given you credit.

Solution
"You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/."


Thanks,
Mike
That's weird because the patch (plus an additional symbolic link for SMP kernels) is made to correct this problem....

micha
17th August 2004, 05:49 PM
More information about dual head settings can be found in the ATI Linux Howto:
http://www.rage3d.com/content/articles/atilinuxhowto

RandyS
17th August 2004, 08:48 PM
I followed the instructions (everyone says that, right? :) found in this and other threads. I don't seem to have a problem compiling the module, rather I cannot insert it. It is as if the system doesn't recognize the ATI card.
FC2, no updates on a Soyo 845 MB with Radeon 9550 card.

[root@randys fglrx]# sh make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx:firegl_init] *ERROR* Device not found!
FATAL: Error inserting fglrx (/lib/modules/2.6.5-1.358/kernel/drivers/char/drm/fglrx.ko): No such device
failed.

If I try manually to insert it:
[root@randys ati]# /sbin/insmod /lib/modules/2.6.5-1.358/kernel/drivers/char/drm/fglrx.ko
insmod: error inserting '/lib/modules/2.6.5-1.358/kernel/drivers/char/drm/fglrx.ko': -1 No such device

Note the 'no such device' message.

Ideas?

Randy

joostruis
17th August 2004, 09:28 PM
Guys, i've done the patch 2 times begore, also with the 3.9 driver, they both worked perfectly, today i made a fresh install and also update the kernel.
When trying to install the driver i get this.....

root@amd2400 build_mod]# sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
[root@amd2400 build_mod]# cd ..
[root@amd2400 fglrx]# sh make_install.sh

[root@amd2400 fglrx]# sh make_install.sh
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

I've read more people got this problem, anyboy knows what causes this kernel check error ?
How do we solve it ?

//offtopic Why tha hell isn't ATI able to support Xorg anyway ? I DID expect Xorg support in 3.11

vuerro
18th August 2004, 09:47 AM
If I may ask joost, (why) are u using the 3.11 for Xfree 4.1.0 (the logs seems to point it out)


u need to have the kernel-source installed to (otherwise u can de the following)

*--> You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/ <--* works for me too

so now we don't need a patch (as a linux newb, this feels more comfortable than needing to run paches not noing what they do!)

vuerro
18th August 2004, 10:05 AM
Thanks Alfreed thi s solved my problem. You should see about getting this added to fedorafaq. I've seen at least 3 others with this same problem. I posted this on other threads now, but have given you credit.

Solution
"You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/."


Thanks,
Mike

u are right, he deserves credit and this should be added to the fedorafaq!
(for people who know what they are doing.../are able to learn)

the fedorafaq has the symlink part for the SMP kernel inluded (WHY?)

joostruis
18th August 2004, 11:26 AM
Oops !

Wrong kernel SOURCE installed, it still had the kernel-source 2.6.5-1.358.i386 installed, but in fact my kernel is allready at latest..

I knew something wasn' right, cuz it worked 2 times before !
I checked yum install kernel-source , but this didn' check version i think !

:D

Now we got the kernel AND kernel source 1 ON 1 (this WAS the problem, you dont need to copy stuff !!!)

Check /urs/src To see if the source matches your current kernel version, if NOT download the kernel-source rpm and install it.

micha
18th August 2004, 03:47 PM
*--> You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/ <--* works for me too

so now we don't need a patch (as a linux newb, this feels more comfortable than needing to run paches not noing what they do!)
This is a quick and very dirty hack. The patch corrects the same problem (DRM include path specific to Fedora) and is the good way. I'm not sure a newbie would understand your solution better than the patch.

Anyway, a RPM package of the ATI driver is in beta stage, and will be coming soon....

micha
18th August 2004, 03:52 PM
the fedorafaq has the symlink part for the SMP kernel inluded (WHY?)
Because the kernel source location doesn't include the SMP mention in its path, so it doesn't match the traditional /usr/src/linux-'uname -r' include path.

Prometheus
18th August 2004, 04:00 PM
I had the exact same problem, but i still dont get how to fix it. I have the latest kernel, downloaded the newst source, and it gives me the same error... How did u fix it, download an earlier source, or a earlier kernel? I just downloaded the newst one yum had, and assumed it would work... but it didn't. Now what's going on?

btw, does anybody know the ETA on the ATI rpm's, because that would solve sooooooo many problems.

micha
18th August 2004, 04:11 PM
I had the exact same problem, but i still dont get how to fix it. I have the latest kernel, downloaded the newst source, and it gives me the same error... How did u fix it, download an earlier source, or a earlier kernel? I just downloaded the newst one yum had, and assumed it would work... but it didn't. Now what's going on?I don't know what's going on with your system. Make sure your kernel-sourcecode package matches the current kernel, then patch the ATI driver source with the patch given at http://fedorafaq.org, and finally recompile the driver. This should work. Virusdoc has posted a little how-to, have a look at it, it may help you:
http://www.fedoraforum.org/forum/showthread.php?t=20783

Prometheus
19th August 2004, 01:04 AM
which way should i recompile kernel? And should it be from init 3 or 5? and what's the best way of making sure the driver worked other than opening Tux Racer and checking how the gfx look :) ?

micha
19th August 2004, 10:07 PM
which way should i recompile kernel? And should it be from init 3 or 5? and what's the best way of making sure the driver worked other than opening Tux Racer and checking how the gfx look :) ?
Sorry I was talking about the driver, not the kernel (I've edited my previous post). You have to install/patch/compile the ATI driver in init 3.
To know if the driver is installed and used, you can use the commands:

fglrxinfo
glxinfo
You should see something like Direct Rendering: yes.

jeromey
20th August 2004, 04:15 AM
greetings!

as a linux newb, i have tried vigorously to find the solution to my own problem; but i hereby admit i'm in way over my head... /me calls for help!

trying to set up a fc2 box to use as a mythTV pvr/dvr. i have managed so far to get everything working except my silly ATI Radeon 9500PRO drivers so that I can have TV Out. as a decent start, i just wanted to load the ati drivers and get 3d working on the monitor (not to worry about the tv-out) -- but i can't even seem to get that going.

am attaching the files that seem to be relevant for any help. the only thing i'm doing weird is using a custom 2.6.7 kernel that i got from http://atrpms.net/dist/fc2/kernel-testing/ this was suggested in the instructions i am using to set up mythtv using fc2 at http://wilsonet.com/mythtv/fcmyth.php beyond this difference, i cannot see what i might be doing wrong. i am using the latest drivers from ati and followed the instructions for installing / patching on this site and on fedorafaq.org.

the ati control keeps showing the MESA drivers loading instead of direct rendering - at the moment this is my main problem.

thanks to anyone who can save me!

btw, yes i do have the source installed for the kernel i downloaded

Antioch
20th August 2004, 08:16 PM
Does this new driver solve the issue of video playback using the patched ATI drivers?

Entity
21st August 2004, 12:31 AM
Hello,

Earlier today, I upgraded my Fedora Core 2 system with latest 2.6.8-1.512 kernels and kernel-sourcecode rpm from the a FC2 released updates repo :

$ sudo yum -y update

Then I simply downloaded the new ATI drivers (I had version 3.9.0 installed) :

$ wget -c http://www2.ati.com/drivers/linux/fglrx-4.3.0-3.11.1.i386.rpm

Switched to runlevel 3, removed previous ATI drivers from tty1 :

$ sudo init 3
$ sudo rpm -e fglrx
$ sudo rm -rf /lib/modules/fglrx

Installed new 3.11.1 ATI drivers, loaded fglrx module and switched to runlevel 5 :

$ sudo rpm -Uvh --replacefiles fglrx-4.3.0-3.11.1.i386.rpm
$ sudo /sbin/modprobe fglrx
$ sudo init 5

And voilą :

$ glxinfo |grep rendering
direct rendering: Yes

No patch was needed.

You should also take a look at the following link regarding setting up /etc/X11/xorg.conf as it seems that simply creating symlinks to XF86Config-4 and other X related files might not be the best idea :

http://www.redhat.com/archives/fedora-list/2004-May/msg06956.html

Happy direct rendering ;)

asun
21st August 2004, 04:45 PM
Okay, I've installed the latest 3.11.1 and get fglrx to load properly, but here are my problem:

[root@localhost root]# glxinfo |grep render
direct rendering: No
GLX_ATI_render_texture
OpenGL renderer string: Mesa GLX Indirect

From /var/log/Xorg.0.log:

(II) fglrx(0): [drm] register handle = 0xe5000000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0x22a8f000 at 0xf6f45000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x08000000

So it says no AGP, then I tried:

[root@localhost root]# modprobe agpgart
FATAL: Module agpgart not found.

What should I do to get AGP enabled? I'm using Radeon 9600 with NForce2 motherboard, btw. I've heard of nvidia-agp module, so I tried:

[root@localhost root]# modprobe nvidia-agp
FATAL: Module nvidia_agp not found.

No dice either. What should I do?
Thanks,
Asun

Entity
21st August 2004, 05:18 PM
Hello Asun,

I would try to recompile AGP_NVIDIA directly in kernel instead of module.

Device Drivers -> Character devices -> /dev/agpgart (AGP Support) = [Y]
Device Drivers -> Character devices -> /dev/agpgart (AGP Support) -> NVIDIA nForce/nForce2 chipset support = [Y]

NVIDIA nForce/nForce2 chipset support (AGP_NVIDIA)

This option gives you AGP support for the GLX component of
XFree86 4.x on the following NVIDIA chipsets. The supported chipsets
include nForce and nForce2
***

I had a similar problem with my Intel 875P chipset and my ATI Radeon 9600 PRO 256MB. I also disabled direct rendering in kernel and now everything works fine.

I hope it works for you too :)

asun
21st August 2004, 05:28 PM
Hello Asun,

I would try to recompile AGP_NVIDIA directly in kernel instead of module.

Device Drivers -> Character devices -> /dev/agpgart (AGP Support) = [Y]
Device Drivers -> Character devices -> /dev/agpgart (AGP Support) -> NVIDIA nForce/nForce2 chipset support = [Y]

NVIDIA nForce/nForce2 chipset support (AGP_NVIDIA)

This option gives you AGP support for the GLX component of
XFree86 4.x on the following NVIDIA chipsets. The supported chipsets
include nForce and nForce2
***

Ehm, although I'm not complete newbie but I haven't recompiled a kernel ever. Can you elaborate on :

Device Drivers -> Character devices -> /dev/agpgart (AGP Support) = [Y]
Device Drivers -> Character devices -> /dev/agpgart (AGP Support) -> NVIDIA nForce/nForce2 chipset support = [Y]

More info from dmesg:

fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
ACPI: PCI interrupt 0000:02:00.0[A] -> GSI 10 (level, low) -> IRQ 10
[fglrx] module loaded - fglrx 3.11.1 [Aug 4 2004] on minor 0
Fire GL built-in AGP-support
Based on agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected nVidia nForce2 chipset
agpgart: Bridge device is in AGP v1/v2 mode
agpgart: AGP aperture is 64M @ 0xe0000000
Power management callback for AGP chipset installed
[fglrx] AGP detected, AgpState = 0x00000000 (hardware caps of chipset)
[fglrx:firegl_unlock] *ERROR* Process 494 using kernel context 0


Thanks,
Asun

Entity
21st August 2004, 05:48 PM
Ehm, although I'm not complete newbie but I haven't recompiled a kernel ever. Can you elaborate on :

Device Drivers -> Character devices -> /dev/agpgart (AGP Support) = [Y]
Device Drivers -> Character devices -> /dev/agpgart (AGP Support) -> NVIDIA nForce/nForce2 chipset support = [Y]

Thanks,
Asun

Well... you need kernel-sourcecode rpm installed.

$ su -
$ cd /usr/src/linux-2.6.8-1.521/
$ make xconfig

- then go to File / Load
- select /boot/config-2.6.8-1.521 (or /boot/config-2.6.8-1.521smp if you use SMP) and press OK
- then go to Device Drivers -> Character devices -> /dev/agpgart (AGP Support)
- press Y on your keyboard to directly include it in kernel
- then go to NVIDIA nForce/nForce2 chipset support (just under)
- press Y on your keyboard to directly include it in kernel
- then go to Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)
- press N to disable it
- then SAVE (you can also save the config file to an alternate location) and exit

$ make bzImage modules modules_install install
$ shutdown -r now

after rebooting on your linux-2.6.8-1.521custom kernel, you will then need to recompile ATI drivers :

$ su -
$ cd /lib/modules/fglrx/build_mod/ && sh make.sh && cd .. && sh make_install.sh

And that's about it, I hope I didn't forget anything ;)

lactus1
23rd August 2004, 02:08 PM
Hello Asun,

I would try to recompile AGP_NVIDIA directly in kernel instead of module.

Device Drivers -> Character devices -> /dev/agpgart (AGP Support) = [Y]
Device Drivers -> Character devices -> /dev/agpgart (AGP Support) -> NVIDIA nForce/nForce2 chipset support = [Y]

NVIDIA nForce/nForce2 chipset support (AGP_NVIDIA)

This option gives you AGP support for the GLX component of
XFree86 4.x on the following NVIDIA chipsets. The supported chipsets
include nForce and nForce2
***


Finally it works! Thank's. After over week of recompiling/configuring/patching somebody found nice and working solution of nForce2 problem.

Don't forget to say 'y" in fglrxconfig when it ask's you to use external agp driver!
No patch is needed. :D

jwiz
23rd August 2004, 07:58 PM
Mind you, this only works with kernel.2.4.22.alpha or later.

jwiz

tjmax
24th August 2004, 07:14 PM
OK hi all, i am a like total noob at this, i have read everything tried many of the things listed here i don't know what i am doing wrong.

I installed the drivers , the patch and did all the steps and when i run a glxinfo this is what comes up.

[root@localhost fglrx]# glxinfo |grep rendering
direct rendering: No

A bit more information is:

The ATI driver controller iis installed and shows the driver as being 3.11.01 however open gl shows messa.


*edit* The issue may be that my kernel is 2.6.7-1.494.2.2 since I did not update from the dvd install? I am guessing here. 3 days ago was the first time i ever installed linux. I got my other machine up and running with no issues, but its a nvidia card.

tjmax
25th August 2004, 12:49 PM
YAY I got it.


OK now a true, nooobies noobie walk though on the steps.


Basicly, From a fresh install you have to make sure you get the latest and greatest kernel updates.

up2date if you can get it working or use Yum to update:
I used the instructions for yum here:

http://fedorafaq.org/#installsoftware

simply from a terminal window
# yum update


That will get your kernel up to date as well as all the other apps. This takes a long time. once its finished reboot your system into the new kernel.

NOW, follow micha's instructions at the start of this post and the drivers will install flawlessly.


One thing to ***NOTE*** while running the fglrxconfig IF you have a Nforce chipset motherboard (i don't know about any others) You MUST choose the external AGP option, If you are already running with the new driver but have direct rendering no, and the ATI tab is showing messa drivers edit your xorg.conf .

Around line 488 you will see

Option "UseInternalAGPGART" "yes"
change it to read
Option "UseInternalAGPGART" "no"

then reboot.

*information was found here,
http://www.rage3d.com/board/showthread.php?p=1333107684#post1333107684


when your system comes back up, wala no more messa driver issues and you have direct rendering.

I hope this helps people out!


If nothing else i am persistant... 8)

TylerD75
27th August 2004, 12:12 PM
Hi, I've got a little problem trying to compile the ATI driver. Every time I try (running ./make.sh in /lib/modules/fglrx/build_mod), I get this result:

initializing...
./make.sh: line 635: /proc/version: Permission denied
./make.sh: line 636: /proc/version: Permission denied
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.8-1smp/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make: *** /lib/modules/2.6.8-1smp/build: No such file or directory. Stop.
make: *** [kmod_build] Error 2
build succeeded with return value 0
ln: `./fglrx.ko': File exists
duplicating results into driver repository...
cp: cannot stat `fglrx.ko': No such file or directory
done.
==============================
You must change your working directory to /lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================

This is the result if I try to run fglrx]# ./make_install.sh after:
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.


I've had a look in the make.sh file, and tried running the commands manualy (the ones in line 635 and 636, and I get no error).
I've patched the files, installed the driver and the kernel-sourcecode. I've even made a symbolic link from /usr/src/linux to /usr/src/linux-2.6.8-1smp. And from /usr/src/linux-2.6.8-1 to /usr/src/linux-2.6.8-1smp. I really don't know what I'm doing wrong, so any help will be greatly appreciated!

Specs:
Fedora Core 2, with newly compiled 2.6.8-1.521smp (renamed it to 2.6.8-1smp).
Running on Asus P4C800-E Deluxe, w/P4 2,8Ghz HT-enabled (800fsb), 2GB DDR 400 (PC3200) RAM.
ATI Radeon 9600 (128mb) (RV350 AP - AGP 8x)

Thanks in advance!
--------------------
Cheers,
Tyler D

OxleyDave
10th September 2004, 07:23 PM
I have followed all the instructions and get no errors during installation. However when I start X my screen slowing starts to turn white from the bottom left hand corner. I have a Dell Inspiron Laptop 8600 which has a Radeon 9600 Pro.
I have the official kernel 2.6.7-1.494.2.2. I've tried with both 3.11.1 and the new 3.12.0 ATI drivers.

I've attached my xorg,conf and a Xorg.0.log.

Please could someone tell me what is wrong. This is driving me nuts.

El Jefe
11th September 2004, 03:04 PM
Has anybody got any input or experience yet with the new 2.6.8-1.521 kernel and the new 3.12.0 ATI drivers?

remi
11th September 2004, 04:04 PM
I'm using :
Fedora Core 2, kernel-2.6.8-1.521, ati-3.12.0 on a Asus-A7N8X with a RADEON 9200.

Tips :
- init 3
- rpm -e fglrx
- rm -rf /lib/modules/fglrx
- install the rpm and use the same patch than for 3.11.0 (first post of this thread) to build the module.

3D Ok (not more fast but OK)

Cordialy

dan_linder
11th September 2004, 08:42 PM
Hi, I've got a little problem trying to compile the ATI driver. Every time I try (running ./make.sh in /lib/modules/fglrx/build_mod), I get this result:

initializing...
./make.sh: line 635: /proc/version: Permission denied
./make.sh: line 636: /proc/version: Permission denied
cleaning...
patching 'highmem.h'...


The "Permission denied" could mean you are not running the setup as root -- is that the problem?

Dan

linuxxed
25th September 2004, 12:35 PM
I get the following when I try to run sh make.sh
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.5-1.358smp/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.

EDIT: The reason my kernel version is 2.6.5 in the above post, is because I ran it a second time with the 2.6.5 kernel to get output to paste here. It says 2.6.7 when I run it using the 2.6.7 kernel and I get the same error.

What have I done wrong? As far as I can tell I followed your instructions to the letter. How do I fix this? Its probly something simple, but I have little to no experence in configuring 3d for X11 servers...

Thank you for your time,
Arrummen


I'm getting the same error with FC2 and 2.6.8 kernel. I have a radeon 9100 and followed the instructions from http://fedorafaq.org/#radeon

Micha - please can you help?

micha
25th September 2004, 05:30 PM
Either you didn't apply the patch or you have made a symbolic link called /usr/src/linux (which you should remove).
Please have a look a the following thread for the new driver and a new patch:
http://www.fedoraforum.org/forum/showthread.php?t=22642

TylerD75
25th September 2004, 05:44 PM
The "Permission denied" could mean you are not running the setup as root -- is that the problem?

Dan

Sorry for the late reply, but that is not the problem... I've tried both running it as root and as a normal user. Still the same problem. But I've managed to "upgrade" my 2D display to 2048x1536, so allthough I'm unable to play any 3D games I'm fairly satisfied. But this (in addition to the fact that there are no drivers for Promise FastTrack 20378...yet) have forced me to, once more, having to rely on dual boot with XP... This makes me sad :-(

But at least my XP install is running like hell now. I've installed it on 2 striped 10000rpm SATA discs, and together with my 2GB RAM this makes for one hell of a monster (at least until XP becomes unstable again, which shouldn't take long)

Cheers,
Tyler Durden

jwiz
29th September 2004, 08:56 PM
Just in case someone's wondering:

fglrx-fedora.patch still valid here (Asus A7V8X & Radeaon 9600XT) for ATI driver 4.3.0-3.12.0 with kernel-2.6.8.1-521 and new xorg-x11-6.7.0-9-libs.

micha
30th September 2004, 02:56 PM
Yep, but this patch has a little problem when you have a custom kernel under /usr/src/linux.
I've corrected this problem in a new patch:
http://fedoraforum.org/forum/showpost.php?p=105470&postcount=5

jwiz
30th September 2004, 09:45 PM
Just compiled new ATI 4.3.0-3.14.1 driver for kernel-2.6.8-1.521 with your above mentioned fglrx-fedora.patch.
Worked! Even fgl_glxgears marginally improved this time! ;)
Thx!

P.S.:
The compiler did throw a warning, though.
.../2.6.x/firegl_public.c:2519: initialization of incompatible pointer type
It's not due to the patch.
Compiling it for vanilla kernel-2.6.8.1, gives the same.
Perhaps ATI should take a bit more care.

asun
2nd October 2004, 10:41 AM
What does the patch correct? I installed 3.14.1 without patching and it works. Should I recompile with patch?

micha
2nd October 2004, 04:18 PM
What does the patch correct? I installed 3.14.1 without patching and it works. Should I recompile with patch?The patch corrects the fact that official Fedora kernel sources don't have the same location as for the ''vanilla'' kernels.
So if it works for you, don't change anything !!!!

Kerghan
29th November 2004, 09:40 PM
hey, im gettin an error, when i try to apply the patch. it says " **** strip count l is not a number "

what am i doin wrong?

MaCMaNN
12th January 2005, 01:22 PM
Hi, I've tried the solution provided above, i.e:

You'll have to copy all of the drm*h files from /usr/src/linux-MYKERNELVERSION/drivers/char/drm/ to /lib/modules/MYKERNELVERSION/build/drivers/char/drm/.

Simple, and now I didn't need any patches (I found about 10 of them on the web , and I din't know which one is THE one)
Now just type rpm -i --force fglrx-4.3.0-3.11.1.i386.rpm and it all goes without any error, the modules compile instantly then just change XFree86.conf to xorg conf and thets all!! -thats of course im my case, but as I found most of you had this problem. So it's how it worked for me, hope it helps you also!!

But when I execute sh make_install.sh it fails with unresolved symbols errors:

/lib/modules/fglrx# sh make_install.sh
- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in lib/modules/2.4.27-1-386/kernel/drivers/char/drm/fglrx.o
- trying a sample load of the kernel module
/lib/modules/2.4.27-1-386/kernel/drivers/char/drm/fglrx.o: /lib/modules/2.4.27-1-386/kernel/drivers/char/drm/fglrx.o: unresolved symbol remove_wait_queue_R45b432d5
...
and so on...

I don't know wether it's a installation problem or a linux package dependency problem. Please help me!

thank you!.