View Full Version : Optical mouse and networking card conflict?

3rd August 2004, 11:51 PM

I installed Fedora version 2.4.22-1.2115 on my old Thinkpad A22m. I also use a Logitech optical mouse (USB, wired), everything worked fine for a while. I switched between an Orinoco wireless card and the IBM Ethernet card that comes with the laptop because my Linksys wireless router has been acting weird lately (due to interference I think), now I am just using the Ethernet card.

A weird thing happened when I shutdown the machine one day. When it restarted, I tried to browse a web page, I have to move the mouse constantly to get it to work, otherwise the browser just hang there. I pinged the machine and found that the RTT time is highly irregular.

I tried to change things around (disable the wireless access point, get rid of the router completely, etc), nothing worked. I even reinstalled the system.

Then according to another thread I added a line to /etc/modprobe.conf
alias usb-controller uhci-hcd
It worked like magic.

Now the weirdest thing just happened: I shutdown the machine again last night and when I restarted it this morning the problem came back. I tried to change /etc/modprobe.conf again, used
alias usb-controller uhci-hcd
alias usb-controller1 ohci-hcd
alias usb-controller usb-uhci (I found in another post Fedora version 2.4 uses this)
alias usb-controller1 usb-ohci
but nothing worked, I still have to constantly move my mouse to get a webpage to display. It's so weird.

Could someone help me out here? Thank you in advance.


13th April 2005, 04:16 AM
I got the same problem!

I just got a new laptop (Dell Inspiron 9300 (w00t!)) and installed the new Fedora Core 4 test 2 on it. Right after a fresh install I try to browse the web with Firefox. After typing in a URL such as www.google.com, the browser acts as if it's trying to connect and display the webpage as usual. It will then just hang there indefinetly until I move the mouse (Logitech USB Optical Mouse), then it will make some progress. If I stop moving the mouse it will suddenly hang again! I need to contantly keep the mouse moving in order to get anything to load. It will even hang in the middle of loading large images.

It will even hang when I'm trying to update yum in a terminal, with the same effect.

Now here's the fun part. I reasoned the it might have something to do with the USB in general so I turned off the machine, unplug the USB mouse and then restart planning to use the built in touchpad. Once the system is back up and running I load up Firefox and nothing appears. It acts like it's trying to but it's getting nowhere. I move the cursor with the touchpad with no effect.
After letting it sit there for about 2 minutes I plug back in the USB mouse while the system is on and *POOF* the Internet is back and loads right up!

Anyways, I'm just wondering if this is a common problem. Truthfully, this is pretty much my first exposure to Linux and such, so I'm a total noob. =)

17th June 2005, 11:53 PM
I'm having the same problem with FC4, as I had with FC3. I have used 1, 2 and 3 on several computers but the 9300 is the first computer to show this behaviour. On the 9300 Ubuntu Linux works fine in this regard.

- Ketil

17th October 2005, 04:22 AM
according to this:
just add acpi=noirq to your grub and it works, I will try it out myself as well.

19th April 2008, 02:59 AM
It's not Fedora.
I'm running XP on a 2002 custom built PC (intel mobo).
Just recently purchased a Microsoft gaming mouse.
It's USB and optical, but isn't any different then my last.
My internet is connected threw LAN cat5.

Now the funny thing is that I have the same issue.

When streaming a movie for example...
the loading bar moves showing the progress of the load process
then it stops......
and will not move an inch until my mouse is bumped.

Something is going on here for some of us that is not explained on the internet so far.
This topic is the only one I could find.

So if someone comes up a solution that would be great.

(I personally believe that it's a new governor in place to limit the use of the net.)