PDA

View Full Version : KDE Login background



KirkD
29th September 2008, 04:29 AM
I've been trying to change the login background image, which is currently the Fedora Rings background - blue/purple and looks like a series of expanding waves.

I've gone to System Settings (KDE 4.1) - Login Manager and changed the image or the theme and then the image, but I constantly get the same image. None of the changes to the Login Manager take effect - I always end up with the default login screen.

Where can I actually change this??

Demz
29th September 2008, 04:34 AM
its almost in the same way as KDE3.5.x release on where to change it,, . should be in Display or somewhere in SystemSettings im guessing.. you want the Normal KDE Login Background?

w5set
29th September 2008, 04:59 AM
You did do this as "root" didn't you?

KirkD
29th September 2008, 04:59 AM
Demz - we meet again. We seem to be getting together a lot here lately. 8^)

So what I have is this - Blue Waves login. My actual login window (not the background, but the login box) isn't quite as nice as what is shown, but the background is exactly the same:


http://img519.imageshack.us/img519/5672/wavesvo4.jpg (http://imageshack.us)

What I would like is this, but when I set the theme, nothing changes.

http://img529.imageshack.us/img529/2386/oxygendy8.jpg (http://imageshack.us)

I'm going through System Settings -> Login Manager. I don't see any other options.

http://img91.imageshack.us/img91/9624/loginmanageryd0.th.jpg (http://img91.imageshack.us/my.php?image=loginmanageryd0.jpg)http://img91.imageshack.us/images/thpix.gif (http://g.imageshack.us/thpix.php)


-Kirk

KirkD
29th September 2008, 05:01 AM
w5set - yes, I'm doing this as root. I cannot get to the Login Manager without specifying the root password.

Demz
29th September 2008, 05:33 AM
with the background. you want did you then Press APPLY an then OK ?

Hlingler
29th September 2008, 05:36 AM
I think that you have to turn off "themed login" to set a custom background, otherwise the theme's background will always be used. At least, this is so in KDE3.5.x/F8.

V

KirkD
29th September 2008, 05:38 AM
OH, yes. Apply, OK, etc. Regardless of what I try, none of the settings seem to take hold.

I'm having a similar problem with screensavers. The default is blank screen and random, so I only really have blank screen. I've tried to install new screensavers (http://dailypackage.fedorabook.com/index.php?/archives/117-Friday-Fun-Really-Slick-Screensavers.html), but they don't appear in my screensaver selection screen.

KirkD
29th September 2008, 05:40 AM
Hlingler, good guess, but in the first tab of the Login Manager dialog, I have Use themed greeter checked. If this box is unchecked then tab #4 (Theme - the one I posted a screenshot of above) is blank and states that the themed mode is disabled.

Even when enabled and a theme selected, Apply-ed, and OK-ed - no change.

-Kirk

Hlingler
29th September 2008, 05:48 AM
Um... there's probably a way to manually set the background image by editing file /etc/kde/kdm/backgroundrc. Try that: edit that file and place the PATH to desired image like so (this is mine, customized I think IIRC):
Wallpaper=/usr/share/backgrounds/waves/2-sulphuric-waves-day.1600.png

V

KirkD
29th September 2008, 05:54 AM
I just checked that file and it is set to a completely different file that appears to be the remnant of me trying to get the settings right. The end result is that the file that Wallpaper= points to in backgroundrc is not the waves picture that is displayed, and that which is displayed is not the pointed to file.

Bizarre, eh?

I'm heading to bed - it's getting late here. I'll check back in the AM.