PDA

View Full Version : Can't import to svn repos: Permission denied



edderd
28th September 2008, 02:22 PM
I've tried alot of stuff to resolve this problem, but I am unable to import anything to my svn repository using an external client or using an http url due to permissions denied problems.

I get the same errors when I either try to import to the repository from the command line, or an external svn client using http.

[svn import /home/ed/backup/storage/storage/workspace/common http://localhost/svn/repository/common-http/trunk -m "initial import"
svn: Can't create directory '/opt/data/subversion/SVNRepos/db/transactions/1-1.txn': Permission denied


I am able to import as root using the file url syntax:
svn import /home/ed/backup/storage/storage/workspace/common file:///opt/data/subversion/SVNRepos/common/trunk -m "initial import"


I'm running fedora 9 using the "out of box" svn installation and I created the svn repository like this:

svnadmin create /opt/data/subversion/SVNRepos

I set the repository permissions to apache:apache like this:

chown \-R apache:apache /opt/data/subversion/SVNRepos/

I set up the repository in apache by adding the <location>...</location> descriptor below:
<Location /svn/repository>
DAV svn
SVNPath /opt/data/subversion/SVNRepos
</Location>

I've tried chowning as another user, and chmod'ing to 777 but the problem is somewhere else.

Please advise...Thanks!