PDA

View Full Version : yum update



craig1985
27th September 2008, 11:52 PM
this is an error that i get when i go yum update

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
NetworkManager-glib i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 141 k
replacing NetworkManager.i386 1:0.7.0-0.6.9.svn3675.fc8

Updating:
NetworkManager-gnome i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 336 k
firefox i386 2.0.0.17-1.fc8 updates-newkey 21 M
foomatic i386 3.0.2-67.fc8 updates-newkey 18 M
gnome-python2-extras i386 2.19.1-17.fc8 updates-newkey 50 k
gnome-python2-gtkhtml2 i386 2.19.1-17.fc8 updates-newkey 17 k
gnome-python2-libegg i386 2.19.1-17.fc8 updates-newkey 56 k
postgresql i386 8.2.10-1.fc8 updates-newkey 3.0 M
postgresql-devel i386 8.2.10-1.fc8 updates-newkey 1.2 M
postgresql-libs i386 8.2.10-1.fc8 updates-newkey 198 k
postgresql-server i386 8.2.10-1.fc8 updates-newkey 4.0 M
yelp i386 2.20.0-13.fc8 updates-newkey 711 k
Installing for dependencies:
avahi-autoipd i386 0.6.21-8.fc8 updates-newkey 33 k
dnsmasq i386 2.40-1.fc8 fedora 157 k
Updating for dependencies:
NetworkManager i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 833 k

Transaction Summary
================================================== ==============================
Install 3 Package(s)
Update 12 Package(s)
Remove 0 Package(s)

Total size: 50 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /etc/avahi/avahi-autoipd.action from install of avahi-autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386
file /usr/sbin/avahi-autoipd from install of avahi-autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386

Error Summary
-------------

Demz
28th September 2008, 02:31 AM
this is an error that i get when i go yum update

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
NetworkManager-glib i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 141 k
replacing NetworkManager.i386 1:0.7.0-0.6.9.svn3675.fc8

Updating:
NetworkManager-gnome i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 336 k
firefox i386 2.0.0.17-1.fc8 updates-newkey 21 M
foomatic i386 3.0.2-67.fc8 updates-newkey 18 M
gnome-python2-extras i386 2.19.1-17.fc8 updates-newkey 50 k
gnome-python2-gtkhtml2 i386 2.19.1-17.fc8 updates-newkey 17 k
gnome-python2-libegg i386 2.19.1-17.fc8 updates-newkey 56 k
postgresql i386 8.2.10-1.fc8 updates-newkey 3.0 M
postgresql-devel i386 8.2.10-1.fc8 updates-newkey 1.2 M
postgresql-libs i386 8.2.10-1.fc8 updates-newkey 198 k
postgresql-server i386 8.2.10-1.fc8 updates-newkey 4.0 M
yelp i386 2.20.0-13.fc8 updates-newkey 711 k
Installing for dependencies:
avahi-autoipd i386 0.6.21-8.fc8 updates-newkey 33 k
dnsmasq i386 2.40-1.fc8 fedora 157 k
Updating for dependencies:
NetworkManager i386 1:0.7.0-0.11.svn4022.fc8 updates-newkey 833 k

Transaction Summary
================================================== ==============================
Install 3 Package(s)
Update 12 Package(s)
Remove 0 Package(s)

Total size: 50 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /etc/avahi/avahi-autoipd.action from install of avahi-autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386
file /usr/sbin/avahi-autoipd from install of avahi-autoipd-0.6.21-8.fc8.i386 conflicts with file from package avahi-0.6.17-1.fc7.i386

Error Summary
-------------

do this for me
rpm -qa|grep fc7

somehow you got an fc7 package there when your using F8 ..but what i'd possibly do is delete the fc7 Packages by doing a
rpm -e <packagename> an reinstall that same package but install the FC8 package

epperson
28th September 2008, 02:44 AM
do this for me
rpm -qa|grep fc7

somehow you got an fc7 package there when your using F8 ..but what i'd possibly do is delete the fc7 Packages by doing a
rpm -e <packagename> an reinstall that same package but install the FC8 package

I think rpm -q avahi will show that you have both fc7 and fc8 avahi installed.

For this one you'll need to do:
rpm -e --noscripts avahi-0.6.17-1.fc7
to get rid of it.

TheIceMan
28th September 2008, 02:17 PM
what the --noscript do exsacly ?
i looked in the man page but dident get it

dhimes
28th September 2008, 02:33 PM
i'm also having a yum-update issue. It can't find three dependencies:
avahi-autoipd (for Network Manager 0.7.0-0.11.svn4022.fc9.x86_64)
libssh2.so.1 (for libcurl-7.18.2-6.fc9.i386)
libssh2.so.1()(64 bit) (for libcurl-7.18.2-6.fc9.x86_64)

All are from updates-newkey.

Also, firefox is acting squirrelly now that I've updated it. Sometimes, a small window opens in the middle of the ff window. It's so small, I wasn't sure what it was until I expanded it and saw it was a title bar. ff locks until I close that thing. It happened, for instance, when I clicked 'go advanced' so that I could use an icon to put a list in this message.

burnie
28th September 2008, 08:35 PM
I think rpm -q avahi will show that you have both fc7 and fc8 avahi installed.

For this one you'll need to do:
rpm -e --noscripts avahi-0.6.17-1.fc7
to get rid of it.

I had a similar problem, with an fc7 and an fc9 version of avahi installed (no idea how or why, other than that my fc9 installation had been a direct upgrade from fc7).

Your instruction worked for me (but AFAICR not without the --noscripts option) -- thanks for your help.

I had tried yum remove avahi-0.6.17-1.fc7 multiple times (both before and after stopping the avahi-daemon); each time yum asserted it was successfully removed. But after each attempt, yum info avahi showed that both 0.6.17.fc7 and 0.6.22.fc9 were both installed.

Demz
29th September 2008, 12:43 AM
that would of been the problem,, by just doing the Upgrade can leave nasties behind an cause dependancy hell.. by doing a clean install an backing up your Home Dir you'll be safe to do a clean install an putting your Home Dir into the new place

tameboy
29th September 2008, 06:51 AM
had the same problem here (no doubt because I too upgraded from F7->F9 rather than do a clean install).


For this one you'll need to do:
rpm -e --noscripts avahi-0.6.17-1.fc7
to get rid of it.

The above worked a treat, thanks.


Also, firefox is acting squirrelly now that I've updated it. Sometimes, a small window opens in the middle of the ff window. It's so small, I wasn't sure what it was until I expanded it and saw it was a title bar. ff locks until I close that thing. It happened, for instance, when I clicked 'go advanced' so that I could use an icon to put a list in this message.

I also had these problems with firefox, though they seem to have stopped after a restart.

mwildam
29th September 2008, 10:10 PM
For this one you'll need to do:
rpm -e --noscripts avahi-0.6.17-1.fc7
to get rid of it.
Thanks also from me as solved also the issue for me - I also had upgraded from fc7 to fc9.


had the same problem here (no doubt because I too upgraded from F7->F9 rather than do a clean install).

The above worked a treat, thanks.

Thanks for confirming what worked!

phe
30th September 2008, 07:54 PM
Hello,

I try to apply some updates proposed via the package updater in gnome (for F8)

Updated NetworkManager-openvpn packages available
Updated NetworkManager packages available
Updated NetworkManager-vpnc packages available



Error resolving dependencies :
Unable to resolve dependencies for some packages selected for installation :

Details :

NetworkManager conflicts with NetworkManager-vpnc
Missing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 is needed by package 1:NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.i386 (installed)
NetworkManager conflicts with NetworkManager-openvpn



[phe@fc8 ~]$ rpm -qa | grep NetworkManager
NetworkManager-0.7.0-0.6.7.svn3370.fc8
NetworkManager-0.7.0-0.6.9.svn3675.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8
NetworkManager-glib-0.7.0-0.6.9.svn3675.fc8
NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8
NetworkManager-gnome-0.7.0-0.6.9.svn3675.fc8
NetworkManager-openvpn-0.7.0-10.svn3632.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8
[phe@fc8 ~]$

Is there maybe a confilct?
How to solve it ?

regards,

phe

phe
30th September 2008, 08:13 PM
Hello,

I try to apply some updates proposed via the package updater in gnome (for F8)

Updated NetworkManager-openvpn packages available
Updated NetworkManager packages available
Updated NetworkManager-vpnc packages available



Error resolving dependencies :
Unable to resolve dependencies for some packages selected for installation :

Details :

NetworkManager conflicts with NetworkManager-vpnc
Missing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 is needed by package 1:NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.i386 (installed)
NetworkManager conflicts with NetworkManager-openvpn



[phe@fc8 ~]$ rpm -qa | grep NetworkManager
NetworkManager-0.7.0-0.6.7.svn3370.fc8
NetworkManager-0.7.0-0.6.9.svn3675.fc8
NetworkManager-glib-0.7.0-0.6.7.svn3370.fc8
NetworkManager-glib-0.7.0-0.6.9.svn3675.fc8
NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8
NetworkManager-gnome-0.7.0-0.6.9.svn3675.fc8
NetworkManager-openvpn-0.7.0-10.svn3632.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8
NetworkManager-vpnc-0.7.0-0.7.7.svn3627.fc8
[phe@fc8 ~]$

Is there maybe a confilct?
How to solve it ?

I did "Yum update NetworkManager" and look what I got :



[phe@fc8 ~]$ su -c "yum update NetworkManager"
Password:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 for package: NetworkManager-gnome
--> Processing Dependency: NetworkManager >= 1:0.7.0-0.6.2.svn3109 for package: NetworkManager-vpnc
--> Processing Dependency: NetworkManager >= 1:0.7.0-0.6.6.svn3109 for package: NetworkManager-openvpn
--> Processing Dependency: NetworkManager = 1:0.7.0-0.6.9.svn3675.fc8 for package: NetworkManager-gnome
---> Package NetworkManager-glib.i386 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Running transaction check
--> Processing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 for package: NetworkManager-gnome
---> Package NetworkManager.i386 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Processing Dependency: avahi-autoipd for package: NetworkManager
---> Package NetworkManager-gnome.i386 1:0.7.0-0.11.svn4022.fc8 set to be updated
--> Running transaction check
---> Package avahi-autoipd.i386 0:0.6.21-8.fc8 set to be updated
--> Processing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 for package: NetworkManager-gnome
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0-0.10.svn4022
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0-0.10.svn4022
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0-15.svn4022
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0-15.svn4022
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package NetworkManager-openvpn.i386 1:0.7.0-15.svn4027.fc8 set to be updated
--> Processing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 for package: NetworkManager-gnome
---> Package NetworkManager-vpnc.i386 1:0.7.0-0.10.svn4024.fc8 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0-0.10.svn4022
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0-15.svn4022
--> Finished Dependency Resolution
1:NetworkManager-0.7.0-0.11.svn4022.fc8.i386 from updates-newkey has depsolving problems
--> NetworkManager conflicts with NetworkManager-openvpn
1:NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.i386 from installed has depsolving problems
--> Missing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 is needed by package 1:NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.i386 (installed)
1:NetworkManager-0.7.0-0.11.svn4022.fc8.i386 from updates-newkey has depsolving problems
--> NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-vpnc
Error: Missing Dependency: NetworkManager = 1:0.7.0-0.6.7.svn3370.fc8 is needed by package 1:NetworkManager-gnome-0.7.0-0.6.7.svn3370.fc8.i386 (installed)
Error: NetworkManager conflicts with NetworkManager-openvpn
[phe@fc8 ~]$




Do I need to remove NetworkManager-openvpn before I can continue?

And witch one ?

NetworkManager-openvpn-0.7.0-10.svn3632.fc8
NetworkManager-openvpn-0.7.0-8.svn3302.fc8

I found some help on : http://forums.fedoraforum.org/showthread.php?t=200424

regards,

phe

dwpbike
2nd October 2008, 03:12 PM
thanks for the tip. it worked with warnings. don't have to see irritating update icon anymore. i went fc6 -> fc7 -> fc8 online updates to get to this.

dhimes
2nd October 2008, 03:36 PM
for the record, mine was a clean install of f9.

IchBin
4th October 2008, 05:00 AM
This topic worked for me as well. Thank you.

kahnoie
13th November 2008, 12:57 PM
Do
rpm -qa | grep NetworkManager
and remove the older version of all the duplicate packages using
rpm -e <pkgname>
and now do
yum update

Should work fine.