View Full Version : Dual Boot using NTLDR bootloader - Grub issues (FC9) Assistance needed. THX. $$

24th September 2008, 05:51 AM
OK, I've tried to get this to work all night and thought I'd see if I can bounce this off some of you guys to see if you can help me out.

I just received my company laptop which was pre-loaded with WinXP. Typically I would just blow it all away and install Fedora, but I want to dual boot for a couple months just in case there is something I need from my Windows partition.

Anyhoo, the one requirement in all of this is I can't mess with the MBR, there is a utility of sorts installed in the MBR that requires me to log in with my password to unencrypt my windows partition. If I elect to install grub to my mbr then I won't be able to log in to decrypt my windows files, hence making the partition useless. I learned this the hard way.

So during the installation I had grub installed to the first sector of the partition and not the MBR. Here are my partitions:

sda1 - Windows
sda2 - /boot
sda3 - /
sda4 - swap

I've already done all the NTLDR legwork, ie. getting the grub image (dd /boot) and modifying the boot.ini file in windows and the entry shows fine. However, when I select to boot Fedora it brings up the splash screen and then it trys to load, but it hangs displaying the following:

Booting 'Fedora ...

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=<cut> rhgb quiet
[Linux-bzImage, setup=0x3000, size=0x1fab60]
initrd /initrd-2.6.25-14.fc9.i686.img
[Linux-initrd @ 0x37d5c000, 0x293b44 bytes]

Then it show a blinking cursor blinking over and over. I can't type anything and it is unresponsive. Why is it hanging here? :confused: If anyone has any suggestions it would be greatly appreciated. Hell, I would even paypal some $$$ for a solution. :D


24th September 2008, 08:27 AM
I'm not familiar with this method of booting Linux but I find the question interesting. Here's a link I found by searching the forum, http://www.fedoraforum.org/forum/showthread.php?t=188378&highlight=dual+boot+ntldr. Stoat is good at this dual boot stuff. My own thought is the UUID. Is it correct? I would boot the Fedora DVD in rescue mode. Once at the command prompt type blkid to get the UUID and match it against what the boot loader has. If it's different it isn't going to boot and needs to be changed.

24th September 2008, 02:36 PM
The UUID is correct. I read Stoat's guide and I've tried all 3 ways he's listed and each time I get the same result. This is killing me. Everything seems to be set up correctly so I don't understand what the hold up is here. Any other ideas?

24th September 2008, 02:51 PM
Yes. If you can post the output of /sbin/fdisk -l (tough if you can't boot Fedora) it may be helpful. Alternatively, edit Fedora's existing boot loader and change root (hd0,1) to root (hd0,2). Then try to boot Fedora. Just a shot in the dark / educated guess.

24th September 2008, 05:02 PM
Booting 'Fedora ...

root (hd0,1)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.25-14.fc9.i686 ro root=UUID=<cut> rhgb quiet
[Linux-bzImage, setup=0x3000, size=0x1fab60]
initrd /initrd-2.6.25-14.fc9.i686.img
[Linux-initrd @ 0x37d5c000, 0x293b44 bytes]Hello LinuxNewb07,

To me, those confirmations of the commands in the grub.conf mean that the dual booting aspect of this is working. In fact, it's over. Stage2 has run, presented the splash screen and/or menu, and is issuing the commands in the grub.conf to launch the kernel and initial ramdisk. For the same reason, the UUID must be okay, too. Something else is wrong.

Try booting without the "quiet" parameter in the kernel command line. Booting will then show many lines of debug spew and information about what is happening around the time of the hang. It may help, but no promises. How to do it... Reboot and choose Fedora in the XP boot menu.
Press a key during the Fedora splash screen countdown to see the menu.
With the menu highlight on a Fedora kernel, press the 'e' key.
Move the menu highlight down to the kernel command line and press the 'e' key again.
Now edit the command line with the cursor (erase "quiet"; might as well erase "rhgb" too).
Press <Enter> to return.
Press the 'b' key to boot with the changesWatch the ouput. It will be hanging either on the last thing printed or the next thing that would have been printed (not much help).

P.S.: Edits made to the grub.conf command lines at the menu like that are not permanent changes to the grub.conf file. They are only "one-shot" things for that boot.

27th September 2008, 02:25 AM
Sorry for not getting back sooner on this. Long story short, I got this to work using grub4dos. Although it didn't work at first, I started to play around with the grub command prompt via grub4dos, and, after some tinkering I got it to work with the "edd=off" option.

Now, interesting thing is, this only works using grub4dos. If I append "edd=off" using the grub boot manager from Fedora it still doesn't work.

27th September 2008, 10:39 PM
Hello LinuxNewb07,

GRUB4DOS is a perfectly acceptable method of dual booting Windows and Linux. I don't use it, but I'm glad that it exists. It comes in handy sometimes. Maybe the different behavior that you are observing is caused by the difference in GRUB4DOS running in an MS operating system environment, and GNU GRUB running in a native environment (outside of any operating system). Anyway, another parameter that people sometimes pass to the kernel when booting hangs in that part of the process is edd=skipmbr. Not suggesting anything. Just FYI.

27th September 2008, 11:00 PM
a bit late but?
it is a bit odd i have been using the win boot to start grub since fedora 4 .
with ntfs-3g working i no longer need to copy Fedora.bin to a 3.5 disk and copy it to win. XP. I just do this from the dvd in rescue mode .

chroot /mnt/sysimage
/* root login */
( my password)
mkdir /mnt/windows
mount -t ntfs-3g /dev/sda1 /mnt/windows
nano /etc/fstab
/* and add a line
/dev/sda1 /mnt/windows ntfs-3g rw,defaults,umask=0222 0 0
dd if=/dev/sd?? of=/fedora.bin bs=512 count=1
/* ?? is where the boot is */
cp /fedora.bin /mnt/windows
/* or run */
dd if=/dev/sd?? of=/mnt/windows/fedora.bin bs=512 count=1
nano /mnt/windows/boot.ini
/* and add C:\fedora.bin= " Fedora "
(ctrl+o ) and <enter> to save*/

and reboot