View Full Version : libbobobo-update

31st July 2004, 11:17 AM
Hi all,
I did a regular update with yum and it updated libonobo and libonobo-devel. Now I have problems with some applications. Evolution is missing all windows, some gnome panel buttons are gone and nautilus reports errors. I think it's about the patch in the orbit package that some of us applied to make nautilus run.
Is there a possibility to downgrade the updated packages again (didn't find one in man yum) or has anyone a better idea?

kind regards

31st July 2004, 11:19 AM
sorry about the typing error in the title... should be libbonobo, of course

31st July 2004, 12:45 PM
O.K. seems like a false alarm... I tried it the Microsoft way and after the second re-boot it seems like it is working normally again... strange...

31st July 2004, 01:51 PM
did you try hust restarting X by loging out and back in or pressing Ctrl+Alt+Backspace?

1st August 2004, 05:50 AM
Yeah, sure, 5 or 6 times, also tried to log-in into KDE. There I had no gnome problems (obviously) but evolution failed also. But now, after rebooting everything seems to work again...

3rd August 2004, 08:25 PM
I had the same problem.
I just reinstalled the old packages and everything is running fine again.
I am not gonna install those new packages until my next reboot (maybe not until FC3?). I hate rebooting :D

3rd August 2004, 08:47 PM
Well, it's still working. Just to be curious, how did you reinstall the old packages? This was part of the pestion in my first post in this thread...

kind regards

4th August 2004, 12:43 AM
first I downloaded the original libbonobo and libbonobo-devel files.
then I installed them with

# rpm -ivh --force libbonobo*

then I checked which versions are installed

# rpm -qa |grep libbonobo

it listed me all the rpm's with this name. I saw the old and new ones sitting together, so I had to uninstall the new-version ones.

# rpm -e libbonobo-<version number> libbonobo-devel-<version number>

after that for a double check I did the rpm -qa again to see if the old version is safely there. and it was

so rather then uninstalling the new version, then installing the old one, I switched the order:) I don't know of any other way of downgrading an rpm