PDA

View Full Version : Compiling kernel



rambo3543
15th September 2008, 03:40 PM
Hello, I've been using Fedora from #6 but I've never needed to compile a kernel so I'm pretty stupid on that issue. I have an Acer Aspire 4520 laptop running FC9 and I need the 4K stack disabled to get the madwifi drivers to work or to get ndiswrapper working. :mad:

uname -r
2.6.26.3-29.fc9.i686

I'm not sure if I have to build a new kernel or if I can disable it on the current one. I have been searching for hours and I haven't found a clear answer to my question. Thanks!!!! :)

brebs
15th September 2008, 04:35 PM
I need the 4K stack disabled
No, you want madwifi from subversion (http://www.fedoraforum.org/forum/showthread.php?t=195008).

rambo3543
15th September 2008, 05:22 PM
Thanks for the quick response! I installed from subversion already but to be safe I did it again. Still no luck, the driver appears to compile and install correctly and it seems to be loaded but there is still no device shown in system-config-network


lspci
07:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Windows XP recognised the device as AR5007 I have been trying for hours now to get this thing working, any advice? :confused:

rambo3543
15th September 2008, 05:43 PM
I took some advice and blacklisted ath5k but that makes the device disappear completely :eek:

I ran a

make uninstall

and

make clean

then

modprobe ath5k

and the wireless device was recognized again. Ideas?

brebs
15th September 2008, 05:52 PM
system-config-network is too high-level - check that the low-level stuff is working first, e.g.:

/sbin/iwconfig

You need to google to see *which* supports your chipset - from the sound of things, blacklist ath5k and use madwifi. "madwifi" is *not* the same as ath5k.

rambo3543
15th September 2008, 06:11 PM
/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.



ath5k needs to be blacklisted but when I do the card is gone and thats what I see in iwconfig with madwifi installed.

rambo3543
15th September 2008, 07:17 PM
Well I finally got the system to recognize the card by using the latest tarball and it created ath0 but when I run:

/sbin/iwlist ath0 scan

It doesn't pick up anything, ideas?

rambo3543
16th September 2008, 04:34 PM
Well I've decided that this wireless device is %100 not compatible, I've been trying for 2 weeks to get this piece to work but when one thing works another thing breaks, I'll just have to stick with the usb wireless stick. :mad:

rambo3543
25th September 2008, 05:18 PM
Update: I did finally ndiswrapper to compile correctly from subversion and blacklisted ath5k but it wouldn't load the driver, so I removed ndiswrapper and downloaded madwifi-hal-0.10.5.6-r3861-20080903 from here:

http://snapshots.madwifi.org/madwifi-hal-0.10.5.6/

Followed the instructions from here:

http://madwifi.org/wiki/UserDocs/FirstTimeHowTo#Removingoldmodules

Even though I tried it numerous times it wouldn't load properly, I then ran:

sudo /sbin/depmod -ae

then:

sudo /sbin/modprobe ath_pci

The driver then loaded properly, don't know what the issue was but the hot key on my Acer 4520 turns the antenna on and off but the light doesn't work, don't really care about that though. :)