PDA

View Full Version : Yum + Python syntax error



DarkMasterHalo
11th September 2008, 06:37 PM
Hi guys,

Yesterday, I did update of my package with Yum. Everything went fine. No errors nothing. However, this morning, tried to run Yumex as usual. This error came to me when lauching the command Yum

------------------------------------------------------------------------------------------------------------------------------
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 243, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 98, in main
base.getOptionsConfig(args)
File "/usr/share/yum-cli/cli.py", line 183, in getOptionsConfig
disabled_plugins=self.optparser._splitArg(opts.dis ableplugins))
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 189, in _getConfig
startupconf.pluginconfpath,disabled_plugins,enable d_plugins)
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 355, in doPluginSetup
plugin_types, confpath, disabled_plugins, enabled_plugins)
File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 152, in __init__
self._importplugins(types)
File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 195, in _importplugins
self._loadplugin(modulefile, types)
File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 251, in _loadplugin
module = imp.load_module(modname, fp, pathname, description)
File "/usr/lib/yum-plugins/filter-data.py", line 111
('committers', 'committer')]
^
SyntaxError: invalid syntax
---------------------------------------------------------------------------------------------------------------------------------------

If you can please help me with this error. I have seriously no idea of how to solve it. I tried to reinstall Yum without success. Also perhaps there was a Python update as Python is involved here. Seems to be a syntax error, but I really don<t know how to fix it and which file to edit.

Thank you very much for your help !!
Please save my little Fedora :D.

dodoedo
11th September 2008, 06:56 PM
I have got the same error !!!

Hlingler
11th September 2008, 07:06 PM
Try:
yum --noplugins [...]

I had to disable the 'skip-broken' plugin after today's new updates due to similar problems with python.

V

DarkMasterHalo
11th September 2008, 08:44 PM
HeHey, it worked. But is there a way to make it permanently. So I can start Yumex without going through the command line ?

Thanks for your answer !

If you find a solution to why we have to deactivate the plugins to get Yum working, Tell me :D

DarkMasterHalo
11th September 2008, 09:01 PM
Ok let it. I found how to deactivate the plugins permanently in the mean time there is an update.

DarkMasterHalo
11th September 2008, 09:26 PM
For whoever wants the solution. Just edit the file "/etc/yum.conf" and set plugins to 0.

Hlingler
12th September 2008, 03:50 AM
Yes, you found the global plugin switch. You can also enable/disable individual plugins by editing the corresponding line in their respective config files: /etc/yum/pluginconf.d/[plugin-name].conf

It appears that Python choked when some of the old plugins (e.g.: skip-broken), which have now been integrated with the new YUM, were "double-loaded" (so to speak).

V

DarkMasterHalo
12th September 2008, 01:42 PM
Ok Ok, will see this to enable my other plugins :D

Thanks for the reply !

DarkMasterHalo
12th September 2008, 01:52 PM
Ok in my case it was the file "/etc/yum/pluginconf.d/filter-data.conf" that was causing the problem. I just deactivate it by putting the value enable to 0. Everything works fine now. Thanks for the help !!

Hlingler
12th September 2008, 01:58 PM
Well, then, that's two different plugins that cause Python to choke. One has to wonder why they were not simply deprecated and removed/replaced if their functionality has been integrated into the new YUM. Guess I'll check bugzilla....

V

EDIT: It appears that both items have been reported multiple times in the last few days. So they're covered already.

dlm4ut
12th September 2008, 02:46 PM
The file it points to has a syntax error. I noted that compared to other similar statements, it should have a colon (:) at the end of the line it was pointing to. I added the colon and yum works back to normal.

Whether this is the correct fix, I don't know as I am not the developer.

I assume an update will be coming out soon to fix it, if one is not out already.

dlm4ut