PDA

View Full Version : Mounting USB card reader



coyote
25th February 2004, 10:40 AM
I'm having difficulty getting my USB card reader to be recognised.

I get the error:

mount: /dev/sda1 is not a valid block device

Any ideas?

Ug
25th February 2004, 10:45 AM
I've had that error before with my usb key, i just took it out and tried again.

coyote
25th February 2004, 10:55 AM
I've tried many things, including that.

:-(

halmsx
25th February 2004, 01:20 PM
'dmesg' should show the info you need when you plug in the card reader. it sumtimes changed to /dev/sdb and so on.

mhelios
26th February 2004, 01:25 PM
Cosult this bugzilla entry for posiible solution:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=115149

You may also want to try turning off the USB device, rebooting, turning it back on and then trying to mount it. Also check that the usb-storage module is loaded by issuing
`/sbin/lsmod | grep usb-storage`

Mat
13th August 2004, 09:27 AM
Also check that the usb-storage module is loaded by issuing
`/sbin/lsmod | grep usb-storage`

shouldn't that be "grep usb_storage"?

imdeemvp
13th August 2004, 09:43 AM
is this a usb flash key device? and if so here (http://www.fedoraforum.org/forum/showthread.php?t=1291&highlight=mounted+usb)

crackers
14th August 2004, 03:04 AM
Some drives may not "show up" as the #1 device. For example, my USB Zip drive (yes, I actually have one - for backups only, these days) is /dev/sb4. Try this:


dmesg | grep sdx

Where "x" is a, b, c, ... until you find it. It's a bit of a pain sometimes, but look at it as a learning experience... :D

imdeemvp
14th August 2004, 03:07 AM
by crackers: "Where "x" is a, b, c, ... until you find it. It's a bit of a pain sometimes, but look at it as a learning experience... "

sounds like gentoo :D

hosam
8th August 2005, 10:41 AM
I have Usb card reader (4 in 1), too. and I faced the same problem that you face. but when I

googled the net I found this page:
http://www.aem.umn.edu/people/faculty/shield/fc.html

and thanks god.. the cards reader work correctly (on FC3).

try the following:
add 'options scsi_mod max_luns=8' to /etc/modprobe.conf.
the "max_luns" must be equal or greater than number of your card's slots.
plug in the card reader (don't forget to plug the card in it's slot too) then reboot your

system...

run "hwbrowser" and if you find new drive under Hard Disks go and mount your desk:
Example:
mkdir /media/CompactFlash
mount -t vfat /dev/sda1 /media/CompactFlash

I hear someone say that you should update the kernel. Although I didn't updated the kernel,

the card reader worked correctly.

good luck...