View Full Version : Revisor seems to freeze installing python-urlgrabber

11th September 2008, 11:45 AM
I was trying to do a custom spin with Revisor on a Rawhide install.

I was trying to do a rawhide spin as well, with the idea of making a relatively small installation
on the Aspire One.

Everything seems fine till it gets to installing packages--then, it freezes for hours on python-urlgrabber. Googling brought me no joy. I haven't yet tried it on F9 to see if it's a revisor problem (which I doubt--see previous sentence). I have a feeling it's another of those Just Me(TM) problems, but before trying to troubleshoot further, I thought I'd ask if anyone else has come across this.

Thanks for any input.

11th September 2008, 12:16 PM
My experience with Revisor has always ended with a problem. I always thought it was an error on my part and that could very well be. I decided one day to try "livecd-creator" and was successful first try using the supplied .ks files. Then I progressed to modifying the .ks file to exclude unwanted packages and include some that were more to my liking.

Revisor seems like a nice tool but has never produced a finished product for me so it doesn't come as a surprise that it stalls for hours. Never had that problem running livecd-creator. :)

11th September 2008, 12:37 PM
Ok, thanks for the tip. I have to get to work but I'll try that tonight.

You might have saved me some frustration trying it again on F9. :)

As you say, it could be errors on our part, though neither the docs nor GUI interface indicate that, but who knows? <shrug>. Anyway, these days, I tend to take the line of least resistance, so I'll give livecd-creator a try tonight.

Thanks again.

12th September 2008, 02:45 AM
Hrrm. Well, it worked well, but I didn't realize it was creating a CD for the machine on which it was built---just too tired to think, I guess. I have an x86_64 and need it for an Acer Aspire One which requires 32 bit.

So, this is Fedora after all, and of course, the wiki had no mention of how to do this. Googling brought me to the setarch command. However, that doesn't seem to work--I get Kickstart Config None does not exist.

Googling brought me back to the forums--one fellow had the problem and DangerMouse answered him with the statement that Revisor works quite well. At that point, I just laughed and said the heck with it. Maybe another night. I imagine it's something obvious I'm missing, but tonight, I'm too tired to look and aggravated that such a common thing wouldn't be in the wiki.

If the wiki writer is on these forums (as I know some Fedora folks have been kind enough to hang out) hold out your hand and strike your knuckles with a ruler (held in the other hand.) :)

12th September 2008, 03:55 AM
I have been using 32 bit and didn't realise that it would build that way. I looked in /usr/share/livecd-tools and didn't notice any .ks file for 64 bit using F9. Looked for "livecd-tools" in F10 /usr/share but is not there so wasn't able to look at a .ks file.

I'll check some more after a good nights rest. :) Wonder if a .ks file from a 32 bit is different than a 64 bit or if there is a setting to edit to create a 32 on a 64. :confused:

12th September 2008, 04:29 AM
As I said, there is that setarch i686 or i386--however, it's giving me that error I mentioned, Kickstart File 'None' not found. (I'm not looking at it as I type, so I might have the error message slightly wrong.)

I did see a thread from a day or so ago, where someone asked was setarch no longer working--but his error was a bit different than mine as was the solution.

I believe that what happens is that it pulls the repos it uses going by the machine name. I didn't see anything to indicate x64 in the ks file itself. (There is a postinstall script that checks if it is either x86 or x86_64, giving errors if it's neither, but that's all I caught. Like you, I need a good night's sleep.

12th September 2008, 04:30 AM
I think I've neglected to say thanks to the folks who are trying to help--sorry, as I said, I need some sleep. Ryptyde, thanks for taking the effort to check your ks file, that's quite kind of you.

12th September 2008, 05:46 AM
Well, to finish the story for the moment....

Booted into F9 and revisor worked there. However, it wouldn't enable me to create a rawhide liveCD--there was an a required package (I presume on Rawhide, since it's on my rawhide install but not my F9 one, obex-data-server which needed a bluetooth library. Sigh. I had no need for bluetooth, but that's how it goes.
Ironically, I then did a spin for F9 and included fluxbox. It didn't include X server in the install though.

I assume there are logical explanations for these---there usually are when one digs deeply enough, but frankly, it's too much effort. A window manager requires X. An installation that doesn't need bluetooth shouldn't have a dependency on a bluetooth library.

However, as I said, there are often logical explanations--for example, on the testing list, someone explained a seemingly absurd one---x required z which required a which needed b---therefore, x needed b, because it wouldn't run without z which needed a which wouldn't run at all without b.

Well, I should have been asleep 2 hours ago, so this will have to wait for another time.

Anyway, thanks again to all.

15th September 2008, 03:21 AM
Ran Revisor from a F10 rawhide install and it froze at the exact same package python-urlgrabber.
So decided to try another approach and took all of the revisor yum-cache packages and created a repo in my home directory.

I used the fedora base.ks file from the livecd-tools directory in F9 and the fedora xfce desktop.ks RahulSundaram posted a while back and drew from the repo in my home directory. I was able to create a Rawhide XFCE livecd under 700MB using livecd-creator and installed it to a 1GB usb pendrive with livecd-iso-to-disk.

I didn't create a persistent overlay as the usb stick was too small. The boot up went ok until just before it came to the graphical login greeter. The animated cursor on a black screen is as far as it went. I gave it the ctrl-alt-backspace and got a login prompt. I logged in as "fedora" and tried "startx" but that didn't work so then decided to "su -" and as root entered "startx" and the Xfce desktop loaded. :)

I'm going to try creating a Gnome version on a larger usb stick soon and see what happens. Using the Rawhide Xfce to post this from an Acer laptop. :D

15th September 2008, 04:23 AM
Ah, that sounds promising.
However, at this point, I'm not sure if I'm going to continue playing with it. The original thought was to make a spin for my Aspire One which comes with this somewhat crippled Linpus Lite, apparently aimed at the Windows user.

However, trying various things on it--including the Ubuntu onelinux, which is specially designed just for this machine--hasn't really brought me joy. In the interim, I've managed to whip it into shape to the point where I can use it and leave it for someone who doesn't want to be bothered configuring it.

I'd like to create a fluxbox spin. However, at the moment, it has to go on the Things To Do One Of These Days List.

Which doesn't mitigate my thanks to you for your help. If I do get a chance to do this within the next few weeks, you've shown me how it can be done, and I greatly appreciate it.

15th September 2008, 12:10 PM
I like trying to create live cd's even though it gets frustrating at times. :confused: I might try a Fluxbox and Enlightenment spin and see if they will work from a usb stick and be installable. Will check on that Revisor hang up and see if there's a way to get a finished product. In the meantime I'll stick with livecd-creator. :)