PDA

View Full Version : No login (X or VT)



forkbomb
11th September 2008, 03:32 AM
I don't know when this happened, but my main F9 VM busted without apparent cause. I haven't run the new batch of updates yet and honestly hadn't touched the machine for the last couple weeks.

I can't log in.

When I try an X login, I can put in password and username. It looks like X is starting to load, but after displaying the loading cursor for a second or so, I'm kicked back to GDM.

However, it does not appear to be an X issue: I also couldn't log in at VTs. After giving creds, I would see a message flash for a brief instance, and I believe (it was going too fast to be sure) it said "login: no shell: Permission denied". This happened with my root account and my normal user.

So I booted into runlevel 1. I checked /bin/bash to make sure it had proper permissions (it does). So, I took a peek in /etc/passwd. Everything looked to be in order, but for good measure I ran passwd on root and my normal user account. I also changed the default shell for both those users to something else, then changed it back to /bin/bash.

Now, I'm still getting the X login issue. When I try a login at a VT, I don't believe I'm getting the "no login" hurrah anymore. However, it's still flashing some output that I can't read fast enough; I believe it shows the "last login" with timestamps and stuff that is normally shown on a VT login, and then it kicks me back to the standard login prompt.

Fedora 9 i686 installed with original media, not a respin (media passed check). The VM was up to date before the infrastructure deal and was working great. I haven't applied the most recent batch of updates since the "infrastructure issue" and I don't remember when the machine last worked (I tried reverting to a snappy but have the same issue). I didn't have the VMware tools installed, so I doubt it's a VMware issue.

Peacepunk
11th September 2008, 04:04 AM
Booting in interactive mode, selecting which services you want and which you don't may help, et least may get you to a VT that works.

sakthi_v_cse
22nd September 2008, 11:21 AM
Its quite simple,

This is due to selinux. you can disable selinux before booting your system.
in your boot loader (assuming grub) add selinux=0 at the end of kernel parameters.

--
Sakthi

forkbomb
22nd September 2008, 12:10 PM
Stop assuming stuff. selinux was disabled.

I got around this by reinstalling. :rolleyes:

Peacepunk
23rd September 2008, 05:34 AM
To be honest, that's what I had to do too last time. I hoped you'd be better... This gdm loop trying to get itself to work again and again without stopping to declare a fatal-issue-please review-your-configuration, Gentoo or Slackware Style, killed me;

So I had to re-install too.

My guess (if I may) is that something has changed in the way gdm, X and login works:

-GDM now always tries to force a restart of your X server - - That MAY be bad, lead to an infinite loop.

-Ctrl-Alt-Bckspce previously killed the X server, now it merely reboots it -- That's bad when you WANT to get out of it, and, given the Suspend-kills-VT-consoles bug of nowadays, you can't go to Ctrl-Alt-F2

-F9, sporting it's new and unfinished refresh of Gnome, has changed the way Autologin works; since it's a feature ordered by way of strings to send to gconf-something, you have very few chances to kill that if you enabled it, unless you are a gconf-thingy guru -- that's AGAIN bad, leads to one more chance of sending your machine in a loop.

tjvanwyk, did you used the Automatic Login feature??

I'd be happy to hear from other people here.

Cheers.

forkbomb
23rd September 2008, 01:41 PM
-Ctrl-Alt-Bckspce previously killed the X server, now it merely reboots it -- That's bad when you WANT to get out of it, and, given the Suspend-kills-VT-consoles bug of nowadays, you can't go to Ctrl-Alt-F2

I think that the Ctrl-Alt-Back may have something to do with either distribution or runlevel. In distros that boot into runlevel 3, I've noticed, Ctrl-Alt-Backspace is a kill of X - after pressing the combo, you drop out of X (hard) and then have to reissue startx. In Runlevel 5 distros, killing X puts you back at a graphical login.



[tjvanwyk, did you used the Automatic Login feature??

Nope, I hadn't been using autologin.

Too late now, but what I should have tried was changing the runlevel to 3 just out of curiosity. But the fact that it was happen in VTs as well suggested to me thatW it was not a problem just related to GDM.