PDA

View Full Version : rtorrent compiled, missing libraries



Firemogle
10th September 2008, 04:50 AM
So I have been fighting with this thing for weeks now and I am lost. I have build libtorrent and libxml and installed them. Built rtorrent and installed it. Now when I run it I get the error "error while loading shared libraries: libxmlrpc_server.so.3: No such file or directory"

whereis gives me its location at /usr/local/lib/libxmlrpc_server.so.3

I know my noobness is probably the problem but after finally getting it to compile I am now lost as to how to make it run. Any help would be great!

Hlingler
10th September 2008, 04:55 AM
rtorrent is probably looking for the dependent libraries is /usr/lib/..., not /usr/local/lib/...

You can hack a fix real quick by simply soft-linking:
[sudo OR su -c] ln -s /usr/local/lib/libxmlrpc_server.so.3 /usr/lib/libxmlrpc_server.so.3

Repeat as needed for other libs. Or, recompile all BUT first configure with:
./configure --prefix=/usr

V

brebs
10th September 2008, 11:01 AM
/usr/local/lib/...
Potential answer: Add /usr/local/lib to /etc/ld.so.conf

Best answer: Install using RPMs, and let the %configure line in the .spec file automatically supply "--prefix=/usr"

Firemogle
10th September 2008, 09:00 PM
I recompiled with the "--prefix=\usr" and it worked great. Will try the .spec out next time. Thanks!

brebs
10th September 2008, 09:10 PM
That's the wrong slash - should be: /usr

Windows uses \ for dirs, but not Linux.

Firemogle
10th September 2008, 09:14 PM
Thats what I meant, I did it right on the system anyway :)