PDA

View Full Version : Fedora 8 extremely slow



black_hawk97
29th August 2008, 03:39 PM
Hi guys,

I've just installed Fedora 8 and it runs extremely slow...

My config:
Acer Aspire 4310
CPU: Intel Celeron M 530 1.73GHz
Intel Graphics Media Accelerator 950
512MB RAM
80 GB HDD SATA
WiFi BCM94311MCG

I've disabled all the services i don't need, i've looked at the running services and none of them is eating CPU time. The thing is that the apps start very slow and the hdd is always crunching alot before starting an app. Even a simple terminal window opens slow. After it opens, it works more or less ok... I can't even click on Applications in Gnome without the hdd starting to load something and it takes about 3-5 seconds until the menu drops down...

Before i had Windows XP on this computer and it ran perfectly and very fast...

I want to move to Fedora but under these conditions, it's close to impossible.

Any suggestions are welcome.

All the best,
James

black_hawk97
29th August 2008, 06:50 PM
Oh come on !

Nobody ?

Please ! :(

JohnVV
29th August 2008, 06:52 PM
have you done a search on the forum for "Acer Aspire"
or
google with " Acer Aspire site:fedoraforum.org "
http://www.google.com/search?hl=en&q=Acer+Aspire+site%3Afedoraforum.org&btnG=Google+Search&aq=f&oq=
and for the services you turned off did you fallow this guide
http://www.mjmwired.net/resources/mjm-services-f8.html

black_hawk97
29th August 2008, 07:59 PM
Yes, I did... i haven't found anything that could help...

Besides that, I'm not exactly a Linux beginner... I know a thing or two about the OS so... regarding the services i turned off, i know precisely what they do, their dependencies and what happens if i turn them off.

The thing is that the system is running fine as long as it manages to run an app. But it takes a very long time to run it. For example: If I run Firefox and it takes about 40 - 60 seconds to open, just to open a terminal around 20 seconds, gedit around 30 sec., Krusader more than a minute... After that, everything's ok given that i don't use the hdd too much. If i do a yum install *something* the entire systems is unusable until yum has finished.

It seems like the R/W operations to the hdd are slow or something related to that. However, Kubuntu or XP run very well and very fast... I've downloaded a trial of RedHat Enterprise and it also runs without a glitch... Only Fedora is a nightmare... But, I like it, i have it on all my machines and i want to stick to it... So, please help !

I know there's something I've missed... but what ?

All the best,
James

Ssl
29th August 2008, 08:33 PM
Hello James,
Probably DMA is not activated/enabled. Could you post a:

/sbin/hdparm -i /dev/sdX
Also, make sure you are not running some indexers like beagle/tracker - to start with it. Also wondering,
updatedb is run in cron.daily and may make hdd very hard to access. Is it in your
ps ax | grep updatedb

black_hawk97
29th August 2008, 09:07 PM
Hello,

hdparm -i /dev/sda

/dev/sda:

Model=Hitachi HTS541680J9SA00 , FwRev=SB2OC70P, SerialNo= SB2204SGFHSLAE
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=DualPortCache, BuffSize=7516kB, MaxMultSect=16, MultSect=?16?
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156301488
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: mode=0x80 (128) WriteCache=enabled
Drive conforms to: ATA/ATAPI-7 T13 1532D revision 1: ATA/ATAPI-2,3,4,5,6,7

* signifies the current active mode

and

ps ax | grep updatedb
5339 pts/0 R+ 0:00 grep updatedb

Regards,
James