PDA

View Full Version : 1 GB secure digital card being read but i cannot delete



old noob
27th August 2008, 04:48 PM
I also cannot write to the card. my 64 MB card works fine so i know its the card. i see the files fine but when i got to delete any of the files it tells me its a ready only file system. i checked the properties on the card and its configured to ms-dos. dunno how important that is. but can someone help me out? :)

rietsit
27th August 2008, 04:51 PM
did you check the write-protection switch on the side of the card?

glennzo
27th August 2008, 04:57 PM
Don't know how much help I can be old noob but when I insert one of my SD cards and type, in a terminal, mount, here's what I see:

/dev/mmcblk0p1 on /media/disk type vfat (rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=5 00)It appears to be mounted rw (read/write). What do you see if you do the same?

old noob
27th August 2008, 05:32 PM
[Alex@localhost ~]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/Alex/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=Alex)
/dev/mmcblk3p1 on /media/disk type vfat (ro,nosuid,nodev,uhelper=hal,shortname=lower,uid=5 00)
[Alex@localhost ~]$




is all the info it gave me when i punched in that card and opened the terminal and wrote mount my brother and i tried the write protection did nothing.

glennzo
27th August 2008, 05:49 PM
The card is mounted read-only. Note the ro just inside the parenthesis. You will need to explore ways to get the card to mount rw.

old noob
27th August 2008, 06:04 PM
thats what i dont know how to do.

Seve
27th August 2008, 06:10 PM
thats what i dont know how to do.
Hello:

From a terminal, try
polkit-gnome-authorization

and look for the Storage Category and I believe you can set the permissions etc. for removable drives

If that doesn't work, post back and we all can move on to Plan B.

Seve

old noob
27th August 2008, 06:25 PM
for some reason it wont let me edit my permissions.

Seve
27th August 2008, 06:49 PM
for some reason it wont let me edit my permissions.
That kind of response is pretty vague ......

So I'll just take a guess and make a suggestion. :)

Make sure you do the following

Step 1.)
Right click on the drive and select
Unmount Volume

Step 2.)
Physically remove the drive

Step 3.)
Try polkit-gnome-authorization again

Step 4.)
Plug the card in again and see what happens

Seve

old noob
27th August 2008, 07:00 PM
ok i tried that again but when i went into the authorization the modify key acts as if i wasnt doing anyything i tried it also logged in as root. modify key was pressable but did not respond,

Seve
27th August 2008, 07:07 PM
ok i tried that again but when i went into the authorization the modify key acts as if i wasnt doing anyything i tried it also logged in as root. modify key was pressable but did not respond,
Hello:

I don't even see a modify key ?

Seve

old noob
27th August 2008, 07:33 PM
the modify key is when you click under implict autorizations. that key doesnt work for me.

Seve
27th August 2008, 07:39 PM
Hello:
Still don't see any "modify key" ?

Don't edit the Implicit Authorizations

Under Explicit Authorizations select Grant and add youruser.

Seve

old noob
27th August 2008, 07:55 PM
sigh when i tried to do the grant key it just sat there..diddnt even do anything waited 40 seconds still nothing ( i did it real quickly on root also ) the button just diddnt put any input,

Seve
27th August 2008, 08:04 PM
Hello:
There should be no need to log into root for this.

Seems like you may have some other things going wrong that is fouling up ?

Make sure you have the drive removed and then try a reboot, log in as a normal user and give polkit-gnome-authorization another whirl.

Seve

old noob
27th August 2008, 08:22 PM
still wont let me change my permission:(

Seve
27th August 2008, 08:57 PM
Hello:
Not sure what to say ?

I appears that something is broken with your installation of Fedora 9.

The only other thing I can think of to try is the following.

$ gconf-editor

/system
/storage
/default_options
/vfat

and right click on the mount_options key in the right pane
and select
Edit Key
and add
rw

close and then pop in your drive and see if changes the mount options to rw from ro

Seve

old noob
27th August 2008, 09:12 PM
the card i was using was bad. the whole permission thing im not sure about ....... il have to play with it later i got an even better card to work thanks to an old formatt trick what i did is i stuck a 2 GB card into a camera and formatted that way diddnt work for the 1 GB card though. but i have a card to work with now thanks for your help.