PDA

View Full Version : Ethernet Card Stopped Working.



dejai
25th August 2008, 09:43 AM
When I installed Fedora 9 on my box I connected an Ethernet cat 5 cable to it and it worked fine for that night, without rebooting the next day it had switched to using my wireless card and it no longer recognises my Ethernet card.

Running ifconfig recognised wlan0 but not eth0 whereas wlan0 was not recognised yesterday and eth0 was. Any help would be much appreciated.

glennzo
25th August 2008, 10:38 AM
Just a thought. Nothing necessarily authoritative. Have you tried turning on NetworkManager?

dejai
25th August 2008, 12:14 PM
Yes the NetworkManager Applet 0.7.0 has been on the whole time :P

glennzo
25th August 2008, 12:22 PM
What about System > Administration > Network? Activate device when computer starts

dejai
25th August 2008, 01:43 PM
Yes when I said that the device was not recognised I mean by both that and by the command "ifconfig eth0". The device seems to just no longer be recognised.

glennzo
25th August 2008, 01:46 PM
What does lspci or lspci | grep -i ethernet show?

Also, bring up a terminal and type sudo tail -f /var/log/messages. See if there is any additional output when you plug the lan cable in.

dejai
14th September 2008, 05:03 AM
It doesn't seem to be able to recognize it at all. The ethernet card is part of the mother board.

glennzo
14th September 2008, 09:53 AM
Please post the output of lspci.