PDA

View Full Version : How to prevent automount of Windows partitions?



Satya Deep
23rd August 2008, 04:42 PM
I have Fedora8 x86_64 installed on my laptop with a dual boot option of Windows Vistsa. Whenever I boot in Fedora, the Windows partitions get automounted and appear on the desktop. Though not a problem but still annoying. I want to disable them from getting automounted. Here is my /etc/fstab

LABEL=/ / ext3 defaults 1 1
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/home /home ext3 defaults 1 2
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
LABEL=SWAP-sda13 swap swap defaults 0 0

As I see above, I do not see any mention of the window's partitions. Here the output of
$ mount
/dev/sda8 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda12 on /usr type ext3 (rw)
/dev/sda11 on /var type ext3 (rw)
/dev/sda10 on /tmp type ext3 (rw)
/dev/sda9 on /home type ext3 (rw)
/dev/sda7 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sda5 on /media/DATAPART1 type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)

The last one is the automounted windows partition. How do I disable it from getting mounted?

ValHolla
23rd August 2008, 05:58 PM
I am not sure how to disable it, but you can turn off the icons in gconf-editor

$ gconf-editor
navigate to:

apps->nautilus->desktop->volumes-visible set to false. (uncheck it).

You enable/disable appearance of computer,home,trash also.
This will disable "ALL" volumes from being shown on your desktop, including USB thumb drives. but they do show up in nautilus browser mode. to force always use browser mode for nautilus
$ gconf-editor
navigate to:

apps->nautilus->preferences->always_use_browser set to true ( checked )

vallimar
23rd August 2008, 08:22 PM
Umm, hiding the problem isn't a solution...

Nautilus is probably auto-mounting it, I don't use it for volume management personally, there is also a gnome-volume-manager (which is disk volumes, not audio volume). You can turn that off in your sessions config, but I think if you right-click->dismount the volume in nautilus, it won't automount anymore? Not 100% certain.. you can also try removing it from your nautilus bookmarks.

glennzo
23rd August 2008, 09:09 PM
The solution may be found in this thread, http://www.fedoraforum.org/forum/showthread.php?t=194945&highlight=automount, although I haven't tried it personally. Seve is generally right on the money with his answers.

ValHolla
23rd August 2008, 09:18 PM
I agree that hiding the problem is not a solution, but if you read the thread glennzo posted. it is all or nothing. I personally like gnome automounting my CD/DVD and thumb drives. for me tuning off automount all together is not a good option.