PDA

View Full Version : Big problem when trying to login



Wingy
27th July 2004, 05:01 AM
So I should let you know, I am a total noob, and I did a very very bad thing (so I am told).

I run a developmen server of Fedora Core 1 for testing php and mysql stuff. I wrote myself a shell script the otherday, as I needed to edit multiple files in the same way. My shell script made use of sed to replace text.

Anyway, not thinking, I ran the script with the incorrect parameters (Stupid me didn't put in error checking to the script) and also ran the script as root. I guess I didn't understand how great of an effect something that seems so small could do.

Either way, i think my script is bringing Fedora to it's knees. When i log in, I now see:

(none) login: where before it was dev login: (dev is the name of the server)

I've logged in using linux rescue, and thankfully, my data is still there. And I also have a pretty good backup scheme. To be honest though, I've gotten alot of help from a more experienced user in setting all this up, so I really dunno if I know how to restore and all that stuff.

Would anybody have any advice on what I should do? If I should reinstall, can I reinstall fedora sorta like windows, basically a fresh install, but all the data remains (reinstall without reformatting i guess)?

Any help is appreciated. Thanks!

crackers
27th July 2004, 06:17 PM
Option 1: Sounds like one of the things you modified was either the $HOME/.bashrc or ( :eek: ) /etc/bashrc. The environment variable that you probably hosed is PS1.

Option 2: You really trashed your HOSTNAME - pain in the posterior.

With either of these hints, you and your friend might be able to dig a bit deeper and either fix it or supply more information.