PDA

View Full Version : Fedora 9 using xcfe - switchdesk doesn't work - can't get out of GNOME



dann
20th August 2008, 05:05 PM
I've been at this for a while, and it's pretty frustrating. I wanted to try xcfe

yum groupinstall xcfe
swtichdesk XFCE

These all worked fine - but xcfe won't start. I keep getting back to GNOME.

I've added "exec xfce4-session" to the .xinitrc
the .Xclients-default has WM="startxfce4"


I've rebooted, restarted X, etc.

I don't know if gdm is overriding everything, but there's also no good way I can find to configure gdm. The gconf-editor (looks like regedit) doesn't help much configuring the greeter screen. I remember there used to be a "Sessions" option on gdm, but it's gone now in F9.

If I missed anything, please let me know.

Thanks

dann
20th August 2008, 05:29 PM
I got it - the gdm login screen has the session option after you select the user. All is well - albeit a confusing way to get there.

Hlingler
20th August 2008, 05:36 PM
Pshaw, that is nothing! If you want confusion, try reading: 'man xorg.conf'. It will drive you insane. :D

V

RonPolley
20th August 2008, 05:37 PM
That one little option has slipped by many of us in F9. I don't think any of us are used to it being at the bottom and then only after selecting a user.

vallimar
20th August 2008, 05:47 PM
I've added "exec xfce4-session" to the .xinitrc
the .Xclients-default has WM="startxfce4"Those are only used by xinit which is normally invoked by running startx from runlevel 3. Switchdesk is completely useless if you only use runlevel 5, you can uninstall it.

dann
26th August 2008, 07:20 PM
Thanks All. Hopefully, when the gdm configuration tool is rewritten, things will be a little easier. The differences between startx at run level 3 and run level 5 are very confusing. When you use an NFS mounted home directory with the various .xinitrc, .Xsession-clients, etc with different distros, it's quite a mess.

It's like a bid game of rock-paper-scissors with what DE you get :)

It's still not as bad a mess as XP and roaming profiles.

Thanks