View Full Version : Multiple devices on your system are labeled 07D8-0810. / boot partition corrupt

19th August 2008, 04:21 PM

When I booted my system, it directly went to Grub command prompt.
I tried to rescue it with the Fedora9 DVD. At the point where the system image is mounted, I get an error; "Multiple devices on your system are labeled 07D8-0810. Labels across devices must be unique for your system to function properly. Please fix this problem and restart the installation process."

Here are some details:

[System Configuration]
The system is a Dell Vostro 1500
Processor: Intel Core2Duo 2Ghz
HDD: 250GB
GC: nVidia GeForce 8600
Others: wi-fi 1395, Ethernet - Broadcom, Modem, blah blah.

[Partitioning scheme]
The system is a multi-boot with Windows XP.
/dev/sda1 (less than 10MB) - this is taken by a Dell Application Media Direct
/dev/sda2 (20GB) - Windows ntfs - C:/
/dev/sda3 (around 210GB) - Windows Extended
/dev/sda4 (128MB) - /boot
/dev/sda5 (15GB) - Linux PV
/dev/sda6 (20GB) - /opt
/dev/sda7 (40GB) - Windows ntfs volume
/dev/sda8 (2GB)- this is also taken by Media Direct

/dev/sda5 contains LVs as below
root - 2GB
home - 2GB
usr - 5GB
tmp - 1GB
var - 1GB
swap - 1.5 GB

More Details
I had installed various softwares on it before the issue occured.
1. vlc - using yum (livna package)
2. some graphical enhancements using lvina
3. Tried to install drivers for the nVidia card - Unsuccessful however some dependencies were installed.
4. Installed wi-fi drivers for the 1395 card. I some have a feeling that this cause the issue. I used steps similar to ones' mentioned in the below link. I am not able to get the exact link, but the steps were same.


Details that may interest you
1. The issue was that the system was not booting because the kernel could not be loaded.
2. The cause was "the boot partition itself had corrupted." as it was not listed in the partition list and also e2label on the device showed problem in the partition.
{Steps tried}
3. I tried to reformat just the boot partition, however when I selected the /dev/sda4 and chose the mount point as /boot and clicked on ok, the mount point did not show up in the GUI.
4. I tried the above step again and there was a prompt that there was already a /boot created. Strange!
5. Now I clicked on next and there was a prompt that my boot partition was less than 75MB. ??????
6. I still tried to proceed and there was an error indicating a serious problem and that I needed to exit the installer.
7. Now I created a new MBR with Windows rescue CD.
8. With the windows device manager, I deleted the /dev/sda4 and formatted it with ntfs.
9. Now again I rebooted with the Fedora CD and tried to format /dev/sda4 back to boot partition, after some initial formatting of the partition I got another error, I don't know if I can actually do this (format just the boot partition).

Now I am not quite sure as to what to do. I can reinstall, but then I am sure there must be a workaround.