PDA

View Full Version : Computer Crashed, rebooted, now no keyboard



Shadowofthesun
18th August 2008, 06:51 AM
***NOTE*** The problem has appeared to fix itself. I have no idea why it happened or if it will happen again, which is why I am interested in all your thoughts. The problem, though, has resolved itself.

Hi all,

I'm typing this message from within the Windows partition of my dual-boot computer. Now, before you all decide to burn me at the stake, let me explain my situation.

My computer was functioning fine for the past few days. I don't recall any significant updates or system changes I might have made before today. Randomly, today, in the middle of typing a paper in Openoffice.org, the computer froze. The Caps Lock and Scroll Lock lights flashed incessantly, and the sound hung and began to loop.

When I restarted, everything seemed fine. I proceeded through boot, logged back into my account, and started to work again. However, the computer soon crashed again with the exact same symptoms, this time while typing within Pidgin.

I should note that during this second reboot, I checked through the system log to see if there was anything alarming. The only thing I could find that took place right where I assume my crash happened was a read error on device "sr1", which I assumed to be my flash drive because it occurred directly after I mounted it. Again, although I have a working knowledge of Linux sufficient to do basic troubleshooting and day-to-day upkeep, I don't really have experiences with something like this.

This time, when I rebooted, the computer proceeded through the boot, but when I reached the login screen, the keyboard would not respond. My external mouse still worked, but my touchpad no longer did. Note that the keyboard was fully functional at the BIOS level, as I was able to enter and navigate through the menus, and at GRUB.

I've tried rebooting multiple times, resetting BIOS (this made Linux not boot at all due to mounting issues, I figure it was probably the ACHI setting because resetting this allowed the computer to boot again) to no avail. Attempting a rescue had the same results; I was able to navigate to "rescue an existing installation", but once the rescue process began, the keyboard stopped responding. Interestingly, it responded once when I was mashing the caps lock key (and watching the light) through the entire process, but it seems to be a fluke because I attempted the same thing twice more and neither time it worked.

I'm completely at a loss. I'm considering trying to salvage my home partition and doing a complete reinstall, but before I do, any ideas?

I could probably go out and buy a USB keyboard, as all signs point to my external USB devices still working. Do you guys think its worth it?

Hardware:
Fedora 9 x86_64
Core 2 Duo T7100
3GB RAM
250 GB SATA HDD
8600M GT
in a Sager NP2090 laptop shell

Summary:


Computer crashed catastrophically twice, with flashing Caps and Num Lock keys the only indicator
Reboot, but keyboard and internal mouse won't respond
Keyboard works in BIOS, GRUB, and intial selection screen of install DVD


Thanks in advance!

PS. I can't seem to find any software that will read my Linux volumes from Windows, Linux Reader just reports "Unknown File System". I would love to salvage my work, and perhaps prepare for a reinstall- any ideas?

Shadowofthesun
18th August 2008, 11:09 PM
As an update, the system crashed again. This time I was able to reboot successfully on my third try by changing the BIOS setting for legacy USB support (I'm almost positive changing any BIOS setting works as long as it resets the BIOS with my USB devices disconnected).

I was able to grab the system log lines that are identical to the ones I saw before.


Aug 18 14:35:32 localhost kernel: end_request: I/O error, dev sr1, sector 131064
Aug 18 14:35:32 localhost kernel: sr 5:0:0:1: [sr1] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Aug 18 14:35:32 localhost kernel: sr 5:0:0:1: [sr1] Sense Key : No Sense [current]
Aug 18 14:35:32 localhost kernel: sr 5:0:0:1: [sr1] Add. Sense: No additional sense information
Aug 18 14:35:32 localhost kernel: end_request: I/O error, dev sr1, sector 131064

These blocks repeat, referring at times to the same sector, and at times to different ones, but nothing else shows up in my log for as long as the computer seems to be hanging.

Any ideas?

PatMcLJr
19th August 2008, 01:14 AM
OK, now I read. Sorry.

xorg.conf borked?

Try a LiveCD and see if that will work, then you might be able to prune the parts for your KB out of it?

Hey, you said ANY ideas!

Best of Luck,
Pat Jr.

Shadowofthesun
19th August 2008, 01:17 AM
Haha, that I did. I'll look into that if the computer crashes again, which I'm fairly sure it will eventually.

In the meantime, I'm working on moving critical files to an external drive so if necessary, I can wipe and reinstall without too much issue.

marcrblevins
19th August 2008, 08:49 AM
Were you using KDE? Mine locked up from time to time. I pressed Control Alt Backspace and move on.

Move over to Gnome for the time being. KDE 4 is new in Fedora 9. Others says to open up Fedora Testing and install the latest KDE 4.1 from there.

Shadowofthesun
19th August 2008, 09:00 PM
Nah, no KDE. Gnome here.

When I say the computer crashed, I mean no response whatsoever- no cursor movement, no ctrl-alt-backspace, no ctrl-alt-(f1-f6), nothing. The system also never recovers, and I have to hold the power button to forcibly shut down.

w5set
20th August 2008, 02:24 AM
********
and the sound hung and began to loop
***********

remove Pulse audio?