PDA

View Full Version : Suspend kills text consoles?



twilightomni
18th August 2008, 12:26 AM
Greetings again. Fedora 9, kernel 2.6.24.14-108, latest updates. When using Suspend from the GNOME Menu/Shut Down option, my laptop goes into standby successfully. On resume everything seems fine; X and sound all come back correctly.

However, when I then press CTRL-ALT-F1 to access a console...the console is not there. Only a blank screen. In fact, ALL text consoles, 1 through 6, are gone. Not even any blinking cursor. There is just a black screen.

I tried googling (combinations of "fedora", "suspend", "console", "terminal", and "ctrl-alt-f1") but nothing remarkable turned up. Has anyone else had this problem?

Peacepunk
21st August 2008, 10:16 AM
I had the same with F8 and still now with F9.

ASUS F9E.

I don't think it's Laptop-related, but we Laptop-nixers ought to notice it sooner; it's neither compiz or compizfusion related, since I do not use it (battery life!) and had the opportunity to try with and without.

Cheers

twilightomni
21st August 2008, 02:18 PM
Well then, who in the world do you file this bug for?

Kernel? X? A simple google for "suspend text console OR terminal" turns up the following distribution posts:

http://lists.opensuse.org/radeonhd/2007-12/msg00194.html
http://ubuntuforums.org/showthread.php?t=750886
http://osdir.com/ml/linux.ports.mactel.user/2007-10/msg00044.html

But I couldn't find any upstream bug reports.

Peacepunk
21st August 2008, 05:56 PM
Weeeeell, i dutifully tried to research bugzilla.kernel.org, found nothing, tried to create an account in order to be able to submit a bug and the confirmation email never came.

I am dropping the ball on reporting this bug; I won't fight with dysfunctional reporting websites. Sometimes FOSS sucks just as well as any other system.

Cheers

Jean-Philippe