PDA

View Full Version : mozplugger and gecko-mediaplayer problem



Deb
17th August 2008, 09:43 PM
I am facing a problem for which you guys might have an answer:-


$ uname -a
Linux deb 2.6.25.14-108.fc9.i686 #1 SMP Mon Aug 4 14:08:11 EDT 2008 i686 i686 i386 GNU/Linux


$yum info mozplugger gecko-mediaplayer
Installed Packages
Name : gecko-mediaplayer
Arch : i386
Version : 0.6.3
Release : 1.lvn9
Size : 434 k
Repo : installed
Summary : Gnome MPlayer browser plugin
URL : http://code.google.com/p/gecko-mediaplayer/
License : GPLv2+
Description: Gecko Media Player is a browser plugin that uses GNOME MPlayer to
: play media in a browser. It should work with all browsers on Unix-
: ish systems(Linux, BSD, Solaris) and use the NS4 API (Mozilla,
: Firefox, Opera, etc.).

Name : mozplugger
Arch : i386
Version : 1.10.1
Release : 1
Size : 89 k
Repo : installed
Summary : A generic mozilla plug-in
URL : http://mozplugger.mozdev.org/
License : GPL
Description: MozPlugger is a generic Mozilla plug-in that allows the use of
: standard Linux programs as plug-ins for media types on the
: Internet.


Now the problem:-
1. When I have both the plugins, .mov files will not play in firefox giving only sound output.
2. When I have only gecko-mediaplayer and uninstalled mozplugger completely, .mov files plays in the browser like a charm. (Note: i have to remove mozplugger completely if I disable it in firefox it does not work!)
3. I hate adobe's acroread plugin "npddf.so". evince plugin does the job elegantly. But here is the catch evince plugin comes with mozplugger.

so in a nutshell, I can either watch quicktime movie trailers or i can read pdf files using evince, in firefox . I don't think these two should be mutually exclusive!!

any ideas, suggestions, links....?

Wayne
18th August 2008, 12:57 AM
In FF3 you could try going to Tools > Add-ons > Plugins and disabling any conflicting plugins...

Wayne

Deb
18th August 2008, 01:41 PM
thanks wayne for your reply.
i have already tried that. disabling mozplugger then restarting firefox does not allow me to watch quicktime movies- i have to remove the package. it seems as if firefox senses the presence of mozplugger and never tries g-m to open quicktime.
I have also tried to comment out the video portion of /etc/mozplugerrc, to no avail.