PDA

View Full Version : Desktop Effects on Laptop using Fedora 9



apostolos_v
16th August 2008, 06:35 PM
Hello guys....Lets see....When I enable my Desktop Effects the menu bars over and under the window become with lines....i cant see the menus and everything is dissappeared on them end reappear for a second when i click on a menu.....The thing is that with ubuntu i didnt have a problem with the desktop effects which they are enabled by default I think....Any suggestions?I am using gnome...


these are the packages shown using the command rpm -qa |grep -i compiz
compiz-fusion-gnome-0.7.6-1.fc9.i386
compiz-fusion-extras-0.7.6-1.fc9.i386
compiz-0.7.6-2.fc9.i386
compiz-fusion-extras-gnome-0.7.6-1.fc9.i386
compiz-fusion-0.7.6-1.fc9.i386
compiz-gnome-0.7.6-2.fc9.i386

the xorg.conf file

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics Touchpad"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,gr"
Option "XkbOptions" "grp:shifts_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"

Option "SHMConfig" "true"

EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

PauGNU
16th August 2008, 07:40 PM
Maybe you have to add the composite section in your xorg.conf:


Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Just try... ;)

apostolos_v
17th August 2008, 12:39 AM
No Nothing changed still the same problem....Thank you for the answer though

ozjd
17th August 2008, 03:31 AM
Leigh is the resident Compiz guru. Have a look at his how to at http://forums.fedoraforum.org/forum/showthread.php?t=173317

Use his repos for the Compiz packages.

av1611
19th August 2008, 04:42 PM
run glxgears and tell us if that works.

then do glxinfo and see if OpenGL/direct rendering is enabled.

I assume you did yum install kmod-fglrx?

apostolos_v
19th August 2008, 07:03 PM
glxgears works.....
glxinfo shows that direct rendering is enabled

No i didnt install kmod-fglrx should i?And what is it if i may ask?

My graphics card is ATI IGP345(laptop)

tranquilpenguin
20th August 2008, 02:16 AM
glxgears works.....
glxinfo shows that direct rendering is enabled

No i didnt install kmod-fglrx should i?And what is it if i may ask?

My graphics card is ATI IGP345(laptop)

I am not an expert on ATI I am diehard nVidia... but kmod-fglrx is a
Kernel Module that integrates the ati drivers for your card into your os.

Unless you've already installed ATI drivers some other way, you need to go to rpm.livna.org, click on the rpm to add the repository, then go to a terminal and "su -" so you are root, then type
yum install kmod-fglrx (The ATI Driver Kernel Module)

Then restart your pc. now when you enable compiz it should work. if it doesn't try removing compiz (yum remove compiz) and reinstall it along with csm etc...

Post back so we know how it's going for you.

ozjd
20th August 2008, 04:56 AM
did you look at the "ati & compiz how to" thread? http://forums.fedoraforum.org/showthread.php?t=155503

apostolos_v
20th August 2008, 11:10 PM
Identifier "Videocard0"
Driver "radeon"

This is from my xorg.conf....I have this question are these the open source or the ati ones...my card is old

My card was automatically recognised and is also shown in the System--->Administrator----->Monitor( i think i have the greek ver)

ozjd
20th August 2008, 11:23 PM
Identifier "Videocard0"
Driver "radeon"

This is from my xorg.conf....I have this question are these the open source or the ati ones...my card is old

My card was automatically recognised and is also shown in the System--->Administrator----->Monitor( i think i have the greek ver)

radeon is the open source driver for early ati cards. I use it for my 9250 and compiz works fine with it.

PauGNU
21st August 2008, 07:04 AM
What is the resolution? (System > Preferences > Hardware > Screen Resolution)

You said you have a "laptop", but in your xorg.conf there is a parameter like:

ModelName "LCD Panel 1024x768"

I know that the model name doesn't have influence, but maybe the problem is that Fedora didn't configure your screen well.

apostolos_v
24th August 2008, 03:30 PM
well i think i changed it because i have a laptop and an LCD screen not a crt generic...the default was crt generic..stil no desktop effects....Will there be a conflict if i install the kmod-fglrx with the opensource drivers?I also googled some and find out that fglrx is not supported for my graphics card...


I changed my xorg.conf to this


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics Touchpad"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,gr"
Option "XkbOptions" "grp:shifts_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"

Option "SHMConfig" "true"

EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

but still the same...when i activate the desktop effects the menus come out with lines....disorted(i think sorry for my english)fonts dissappear reapear when i click on them and nice "effects" like that

ozjd
24th August 2008, 11:29 PM
where did you get the compiz packages?

apostolos_v
25th August 2008, 09:58 AM
package manager....PackageEdit.some where preinstalled some i installed them later...Even with the preinstalled packages nothing happened had the same problem

ozjd
25th August 2008, 02:25 PM
package manager....PackageEdit.some where preinstalled some i installed them later...Even with the preinstalled packages nothing happened had the same problem

Try the packages from Leigh's repos. They fix the problems in the standard package. Follow the instructions onthe thread particularly to remove the standard packages first. see http://forums.fedoraforum.org/forum...ad.php?t=173317

apostolos_v
25th August 2008, 02:30 PM
i get a 404 error from the link....post it again if you plz

ozjd
25th August 2008, 02:37 PM
i get a 404 error from the link....post it again if you plz

Sorry about that, don't know what happened, try this.
http://forums.fedoraforum.org/showthread.php?t=173317