PDA

View Full Version : post install issue (f9 64 bit), monitor error message



steveready
16th August 2008, 01:16 AM
Hey all, I've been a longtime Linux user, but never really mastered things. I need some help, if anyone is willing to offer advice. I'm sure this has been addressed elsewhere (and I'm confident what the nature of the problem is), but I could use some advice.

I just recently installed Fedora 9 (64 bit) onto my Pavilion a6500f, onto a secondary partition with Vista as the primary OS. After Anaconda runs its course and I reboot and load Fedora to continue post-install, I get the monitor error message of "analog" "out of range". Afterwards, I'm unable to do anything. Ctrl-Alt-F1 through F6 only randomly gets me to a boot prompt and I end up having to power off and power on again.

I'm certain it's an Xorg issue, since PartedMagic also didn't want to play nice (had to use Xvesa). Ubuntu loaded just fine, however. My monitor (LG L1733TR, 17") gives me an output under it of something similar to (92.6 khz/58 Hz), which is well out of the range of the monitor max sync rates (83 Khz, 60-75 Hz, I believe. No manual came with the monitor, oddly enough). I can't really monkey with the monitor when it gets to this stage. Video card is an Nvidia GeForce 7100/Nvidia nForce 630i.

I tried Ubuntu's live CD to mount the Fedora installation (dev/sda5) in order to edit Xorg, but Ubuntu seemingly didn't want to mount it (perhaps because of the LVM? I honestly don't know). Again, I can only occasionally pound Ctrl-Alt-f6 and get a response. Any help here would be greatly appreciated. Thanks ahead of time.

Skunk Worx
16th August 2008, 03:34 AM
Hi,

I would get to one of those login prompts you mentioned, log in as root, and change the horizontal and vertical frequency limits in the /etc/X11/xorg.conf file.

If you don't have one, run 'telinit 3', login again as root, and run 'system-config-display'. There should be some useful choices there.

Then "telinit 3" (if necessary) and back to 5 using "telinit 5"

Once you do that, the video card won't send signals outside the range you specify.

Post back if this makes sense or not... :D

---
John

steveready
16th August 2008, 04:36 AM
Thanks John for the reply. I think it might be easiest for me to just mount a sysimage using the Live CD and go from there. Ctrl-Alt-f6 only occasionally works. Here's my xorg.conf file, please let me know if you see anything awry. I was expecting to a see a "monitor" section, but to no avail.


#Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
#keyboard added by rphx1
Identifier "keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Demz
16th August 2008, 06:51 AM
just wondered. have you tried overclocking your Videocard?

Skunk Worx
16th August 2008, 08:13 AM
Try adding a monitor section :



Section "Monitor"
Identifier "Monitor0"
Option "DPMS"
HorizSync 30-58
VertRefresh 50-85
EndSection


...and reference the monitor in your screen :



Section "Screen"
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
...
EndSection


This info is a little stale but might give you some additional hints :

Older Xf86Config file for 17" displays (http://www.fredshack.com/docs/XFree86Config.html)

steveready
16th August 2008, 05:16 PM
Thanks John, you are the balls. I took your advice and got it working with the rescue CD. Now it's at the base 800x600 resolution, but it's working. Do you all have any ideas about how to go from here? Should installing the Nvidia drivers through Livna do the trick? Thanks again.

Skunk Worx
16th August 2008, 08:31 PM
Great news Steve...thanks for the kind words.

I suggest you back up your partially working xorg.conf somewhere and use the menu option System->Administration->Display, aka the 'system-config-display' command, and poke around in that.

For example, check the dropdown resolution choices, and also the hardware tab, to alter the monitor definition. The hardware tab has a checkbox to to "show all available monitors"...perhaps another LG model, with a number similar to yours, like the 1732, will get you closer.

Also review the specs :

lG L1733 (http://review.zdnet.com/lcd-monitors/lg-l1733tr-sf-flat/4507-3174_16-32492526.html?tag=ut)

Then you could adjust the H & V specs by hand to get things finalized, for example examine the available Modelines in your /var/log/Xorg.0.log file as you sneak up on the allowable H&V settings in the xorg.conf.

Switching to the nvidia driver is a possibility. See the HOWTOs section on this site for all the comments and suggestions regarding NVIDIA drivers.

It has the command 'nvidia-settings' to help work through configuration issues.

Have fun! :D

---
John