PDA

View Full Version : cant update...dependency problem...HELP!!



creeping death
15th August 2008, 04:18 PM
This has never happened before....but whenever i m clicking on update...a message pops up



Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 is needed by package kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 (livna)

the same message when i type a "yum update" into the terminal...



su
yum update
.....
....
.....
--> Running transaction check
---> Package mesa-dri-drivers.i386 0:7.1-0.37.fc9 set to be updated
---> Package kdevelop.i386 9:3.5.2-2.fc9 set to be updated
---> Package unique.i386 0:0.9.4-5.fc9 set to be updated
---> Package html2ps.noarch 0:1.0-0.1.b5.fc9 set to be updated
--> Processing Dependency: perl(Image::Magick) for package: html2ps
--> Processing Dependency: libpaper for package: html2ps
---> Package selinux-policy-devel.noarch 0:3.3.1-84.fc9 set to be updated
---> Package ntp.i386 0:4.2.4p4-7.fc9 set to be updated
--> Processing Dependency: ntpdate = 4.2.4p4-7.fc9 for package: ntp
---> Package fribidi.i386 0:0.19.1-2.fc9 set to be updated
---> Package wine-desktop.i386 0:1.0-1.fc9 set to be updated
---> Package gstreamer-plugins-flumpegdemux.i386 0:0.10.15-2.fc9 set to be updated
---> Package kmod-nvidia-2.6.25.11-97.fc9.i686.i686 0:173.14.12-2.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 for package: kmod-nvidia-2.6.25.11-97.fc9.i686
--> Running transaction check
---> Package ntpdate.i386 0:4.2.4p4-7.fc9 set to be updated
---> Package ImageMagick-perl.i386 0:6.3.8.1-4.fc9 set to be updated
---> Package libpaper.i386 0:1.1.23-2.fc9 set to be updated
---> Package kmod-nvidia-2.6.25.11-97.fc9.i686.i686 0:173.14.12-2.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 for package: kmod-nvidia-2.6.25.11-97.fc9.i686
--> Finished Dependency Resolution
kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 from livna has depsolving problems
--> Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 is needed by package kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 (livna)
--> Running transaction check
---> Package kernel.i686 0:2.6.25.3-18.fc9 set to be erased
--> Processing Dependency: kernel-uname-r = 2.6.25.3-18.fc9.i686 for package: kmod-nvidia-2.6.25.3-18.fc9.i686
---> Package kmod-nvidia-2.6.25.11-97.fc9.i686.i686 0:173.14.12-2.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 for package: kmod-nvidia-2.6.25.11-97.fc9.i686
--> Running transaction check
---> Package kmod-nvidia-2.6.25.3-18.fc9.i686.i686 0:173.14.05-2.lvn9 set to be erased
---> Package kmod-nvidia-2.6.25.11-97.fc9.i686.i686 0:173.14.12-2.lvn9 set to be updated
--> Processing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 for package: kmod-nvidia-2.6.25.11-97.fc9.i686
--> Finished Dependency Resolution
kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 from livna has depsolving problems
--> Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 is needed by package kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 (livna)
Error: Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 is needed by package kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.12-2.lvn9.i686 (livna)



what do i do now? :confused:

aleph
15th August 2008, 04:25 PM
I guess this is because the Livna repository is a little behind the Fedora update repo. You have a new kernel in the Fedora repo, but the kernel module from Livna must match an old kernel version, and the new module fails to install.

You can skip the conflicting part by "yum --skip-broken update" and install the rest. Wait a few days and check the Livna repository again.

marko
15th August 2008, 04:44 PM
Take a look at this too, it's pretty slick at reducing the problem of livna taking a while
to update nvidia:

http://fedorasolved.org/Members/zcat/akmods

creeping death
15th August 2008, 04:46 PM
I guess this is because the Livna repository is a little behind the Fedora update repo. You have a new kernel in the Fedora repo, but the kernel module from Livna must match an old kernel version, and the new module fails to install.

You can skip the conflicting part by "yum --skip-broken update" and install the rest. Wait a few days and check the Livna repository again.


i did what you said and this is the message got...



xml-common noarch 0.6.3-24.fc9 updates 6.9 k
xorg-x11-drv-evdev i386 2.0.2-1.fc9 updates 14 k
xorg-x11-drv-geode i386 2.10.0-1.fc9 updates 133 k
xorg-x11-drv-glint i386 1.2.1-1.fc9 updates 105 k
xorg-x11-drv-i810 i386 2.3.2-2.fc9 updates 409 k
xorg-x11-drv-mga i386 1.4.9-1.fc9 updates 91 k
xorg-x11-drv-nv i386 2.1.10-1.fc9 updates 97 k
xorg-x11-drv-nvidia i386 173.14.12-1.lvn9 livna 2.7 M
xorg-x11-drv-nvidia-libs i386 173.14.12-1.lvn9 livna 5.5 M
xorg-x11-drv-vesa i386 2.0.0-1.fc9 updates 19 k
xorg-x11-server-Xorg i386 1.4.99.905-2.20080702.fc9 updates 1.5 M
xorg-x11-server-common i386 1.4.99.905-2.20080702.fc9 updates 70 k
xorg-x11-server-utils i386 7.4-1.fc9 updates 183 k
xorg-x11-utils i386 7.4-1.fc9 updates 119 k
xorg-x11-xinit i386 1.0.9-1.fc9 updates 41 k
xorg-x11-xtrans-devel i386 1.2.1-1.fc9 updates 74 k
xterm i386 236-1.fc9 updates 358 k
ypbind i386 3:1.20.4-6.fc9 updates 41 k
yum noarch 3.2.17-2.fc9 updates 718 k
yum-packagekit i386 0.2.4-4.fc9 updates 10 k
yum-utils noarch 1.1.14-4.fc9 updates 59 k
zsh i386 4.3.4-8.fc9 updates 1.9 M
Removing:
kernel i686 2.6.25.3-18.fc9 installed 49 M
Installing for dependencies:
ImageMagick-perl i386 6.3.8.1-4.fc9 fedora 204 k
akmod-nvidia i686 173.14.12-2.lvn9 livna 4.8 M
akmods noarch 0.3.1-1.lvn9 livna 14 k
fribidi i386 0.19.1-2.fc9 fedora 53 k
gstreamer-plugins-flumpegdemux i386 0.10.15-2.fc9 updates 63 k
html2ps noarch 1.0-0.1.b5.fc9 updates 92 k
kernel-devel i686 2.6.25.14-108.fc9 updates 5.2 M
kmodtool noarch 1-12.lvn9 livna 11 k
libpaper i386 1.1.23-2.fc9 fedora 34 k
mesa-dri-drivers i386 7.1-0.37.fc9 updates 2.1 M
ntpdate i386 4.2.4p4-7.fc9 updates 55 k
selinux-policy-devel noarch 3.3.1-84.fc9 updates 556 k
unique i386 0.9.4-5.fc9 updates 32 k
wine-desktop i386 1.0-1.fc9 updates 25 k
Removing for dependencies:
kmod-nvidia-2.6.25.3-18.fc9.i686 i686 173.14.05-2.lvn9 installed 7.5 M

Transaction Summary
================================================== ===========================
Install 18 Package(s)
Update 459 Package(s)
Remove 2 Package(s)

Total size: 929 M
Total download size: 766 M
Is this ok [y/N]:


why does it want to remove the kernel and graphic card driver...will the OS run if kernel is removed...???(although my kernel =2.6.25.4-30.fc9.i686 i wish i did not remove the older kernel...) :p

should i go for it? i pressed no for time being...wanting confirmation... :confused:

@Marko...as you can see...akmod - nvidia is present in the update list...should i do it? i m scared...i dont want to screw up my PC there's way too much data on my HDD that I have yet to back up... :confused:

aleph
15th August 2008, 04:56 PM
by default there are two kernels installed on a Fedora system with the older one as back-up. Yum should be removing the older kernel and installing a newer one (check the info produced by yum!). However, since the graphic module for the new kernel is not ready, you may have display problems. I guess the safe way is installing everything else *without* the new kernel. This is done by "yum --skip-broken -x <name of the kernel> update".

Just a suggestion, since I don't use the nvidia packages... however I guess excluding the kernel should be safe

Viton69
3rd February 2009, 01:19 AM
I m also having some problems with resolving dependencies. When i tried do update mi Fc9 i gotta this messages:

Packages skipped because of dependency problems:
ffmpeg-libs-0.4.9-0.58.20090131.fc11.i386 from rpmfusion-free-rawhide
gpac-libs-0.4.5-3.fc11.i386 from rpmfusion-free-rawhide
libv4l-0.5.7-1.fc9.i386 from updates-newkey
openjpeg-libs-1.3-2.fc9.i386 from fedora
rpmfusion-free-release-10.90-1.noarch from rpmfusion-free-rawhide
vcdimager-0.7.23-9.fc11.i386 from rpmfusion-free-rawhide
vcdimager-libs-0.7.23-9.fc11.i386 from rpmfusion-free-rawhide
vlc-core-0.9.8a-3.fc11.i386 from rpmfusion-free-rawhide
x264-libs-0.0.0-0.22.20081213git9089d21.fc11.i386 from rpmfusion-free-rawhide

Wath can i do to resolve this

Thanks in advanced

leigh123linux
3rd February 2009, 01:34 AM
I m also having some problems with resolving dependencies. When i tried do update mi Fc9 i gotta this messages:

Packages skipped because of dependency problems:
ffmpeg-libs-0.4.9-0.58.20090131.fc11.i386 from rpmfusion-free-rawhide
gpac-libs-0.4.5-3.fc11.i386 from rpmfusion-free-rawhide
libv4l-0.5.7-1.fc9.i386 from updates-newkey
openjpeg-libs-1.3-2.fc9.i386 from fedora
rpmfusion-free-release-10.90-1.noarch from rpmfusion-free-rawhide
vcdimager-0.7.23-9.fc11.i386 from rpmfusion-free-rawhide
vcdimager-libs-0.7.23-9.fc11.i386 from rpmfusion-free-rawhide
vlc-core-0.9.8a-3.fc11.i386 from rpmfusion-free-rawhide
x264-libs-0.0.0-0.22.20081213git9089d21.fc11.i386 from rpmfusion-free-rawhide

Wath can i do to resolve this

Thanks in advanced

Why are you trying to install F11 packages ?


post



rpm -qa |grep release


and


rpm -qa |grep fc11