PDA

View Full Version : volume multimedia keys not working (others are fine)



jleonardo
15th August 2008, 07:13 AM
Today I noticed the volume multimedia keys on my laptop are not working as they should. The volume pop-up shows up in compiz and metacity when I press them, but this does not actually increase/decrease/mute the volume. here is a screencap illustrating this, note the discrepancy in the volume levels between the volume control and the pop-up: http://img329.imageshack.us/img329/6664/volumepr1.png .
The other multimedia keys appear to be working fine (tested with totem and gnome-mplayer)

here are some of my computer specs in case it helps:
dell vostro 1500,
kernel: 2.6.25.14-108.fc9.x86_64
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller

any help would be greatly appreciated, thanks.

jleonardo
19th August 2008, 12:37 AM
does anybody have any idea why this is happening or how I can fix it? I would really like to get the volume keys working.

PILOTfungi
18th January 2009, 10:34 PM
I have this exact same problem. this began happening when I change the default audio to PulseAudio I think maybe the Gnome enviroment is not sending the commands to PulseAudio but don't know how to solve it.

MarkRL
19th January 2009, 10:44 AM
Right if you've got compiz-fusion there is a small workaround that got my headphones working. I use aumix mixer so I'm going to use that here but I'd say any mixer would work. If you dont have aumix just


sudo yum install aumix

then in preferences->key board shortcuts (like in your pic) disable the volume up and volume down shortcuts.

Go into compiz settings and in general settings there shoud be a key bindings tab, where you can make your own keyboard shortcuts. Here type in the command

aumix -v +5
and set it to your front panel XF86AudioRaiseVolume
and

aumix -v -5 to lower volume.
Worked for me fine. "5" above can be set for a larger number to have a larger increase or lower if you want smoother transition