PDA

View Full Version : Google Earth installs ok but wheres the item in GUI



majdi
15th August 2008, 02:45 AM
I installed the following package googleearth-4.3.7204.836-1.fc9.i386.rpm;

[root@localhost majdi]# find / -name googleearth -print
find: /home/majdi/.gvfs: Permission denied
/var/googleearth
/usr/lib/googleearth

I got an install successful message but I cant find the icon in gnome/menus. Any idea?

Wayne
15th August 2008, 02:52 AM
If you'd used the the tarball from the Google download page, it contains an install script, which is a no brainer to use. It would have installed to /opt and would have created an entry under 'Applications > Internet'

It looks like you'll have to do it manually. So much for the (in)convenience of an RPM, eh? The command in my menu is something like:

/path to binary/googleearth %f

Wayne

majdi
15th August 2008, 03:41 AM
thanks wayne

manually? do you mean adding the google earth item to the menu? if so, can you post some notes on how.

Wayne
15th August 2008, 03:44 AM
Right-click on the Gnome Panel menu and select "Edit Menus" it's quite straightforward from there.

Wayne

majdi
15th August 2008, 07:24 PM
I finally got it installed and this is what I did;

I checked the package details and found a note on running the command (download-googleearth)


[majdi@localhost ~]$ rpm -qi googleearth
Name : googleearth Relocations: (not relocatable)
Version : 4.3.7204.836 Vendor: (none)
Release : 1.fc9 Build Date: Mon 07 Jul 2008 12:15:11 AM AST
Install Date: Tue 12 Aug 2008 04:43:44 AM AST Build Host: localhost.leigh123.homelinux.com
Group : Networking/Other Source RPM: googleearth-4.3.7204.836-1.fc9.src.rpm
Size : 3854 License: Proprietary
Signature : (none)
URL : http://earth.google.com/
Summary : Google Earth - Explore, Search and Discover
Description :
The idea is simple. It's a globe that sits inside your PC. You point
and zoom to anyplace on the planet that you want to explore.
Satellite images and local facts zoom into view. Tap into Google
search to show local points of interest and facts. Zoom to a
specific address to check out an apartment or hotel. View driving
directions and even fly along your route. We invite you to try it
now.

NOTE: This package does not contain the Google Eearth itself. The
software will be automatically downloaded from Google during package
installation. Alternatively you can use the command
"download-googleearth" manually.

This package is in PLF because it installs software with non-free
license.
[majdi@localhost ~]$

The install was successful but google earth seems to have problems and my system hangs when starting it, it is a beta version and Im thinking of installing 4.2 instead. Before I do that I want to make sure the current version is completely uninstalled.

I know how to uninstall the rpm, but Im not sure what GoogleEarthLinux.bin had installed on my system. Would you know how to successfully uninstall it?

I checked the about page in my google earth GUI and this is what I got;


Google Earth 4.3.7284.3916 (beta)
Build Date Jul 8 2008
Build Time 18:49:58
Renderer OpenGL
Operating System Linux (2.6.25.11)
Video Driver Tungsten Graphics, Inc
Max Texture Size 2048x2048
Server kh.google.com


Which version are you using?

leigh123linux
15th August 2008, 07:32 PM
Try



su
rpm -Uvh http://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm

majdi
15th August 2008, 07:45 PM
thanks leigh,

Tried that and I got this error;


[root@localhost ~]# rpm -Uvh https://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm
Retrieving https://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm
error: skipping https://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm - transfer failed - Unknown or unexpected error
[root@localhost ~]#

leigh123linux
15th August 2008, 07:59 PM
thanks leigh,

Tried that and I got this error;


Try



su
wget http://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm
rpm -Uvh googleearth-4.3.7284.3916-1.fc9.i386.rpm


Or try downloading it and double clicking the rpm


http://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm

leigh123linux
15th August 2008, 08:05 PM
thanks leigh,

Tried that and I got this error;


Try again ( I gave the secure server instead of the http server )

majdi
15th August 2008, 09:07 PM
So I did


su
rpm -Uvh http://leigh123.homelinux.com/Dangermouse/googleearth-4.3.7284.3916-1.fc9.i386.rpm


The install was successful but I get the same problems I had before, google earth runs but it has problems, like the images in the earth window are not showing up right and after some time my system hangs, I have to do a hard restart to get it back to normal.

This only started happening after I installed google earth. Do you have it running OK?

Is there any way I can find out what is causing the system hang? And is there any way I can get google earth to work with my version of Fedora. I see a lot of posts with users running it just fine without this problem.

leigh123linux
15th August 2008, 10:58 PM
Google Earth works fine here ( I am running F9 x86_64 with the same rpm that you are using )!

What graphics card are you using ?

also start google earth from a terminal and post any errors .


googleearth

majdi
16th August 2008, 07:38 AM
I got no errors showing up when running googleearth in the CLI, and my system still hanged when googleearth ran. It runs for a minute or two and then freezes. It might be my graphics card because the earth shows up funny looking in the google earth window.


[root@localhost ~]# lspci -k | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
Kernel modules: i915

majdi
16th August 2008, 08:03 AM
I tried logging into the GUI as root and running google earth and it worked just fine. I did get a message saying running such applications as root is not recommended. I logged out and logged back in as a user and I got the same problem I had before (google earth graphics showing up funny, then a system hang follows).

This is very strange and cant seem to find out what is causing it.

Hlingler
16th August 2008, 08:15 AM
Try adding the following section to /etc/X11/xorg.conf:
Section "DRI"
Mode 0666
EndSectionThen re-start X-server/GUI. See if that helps.

V

majdi
16th August 2008, 10:53 AM
Thanks Hlingler,

I want to try this, before I do though, can you please explain what this dose.

Hlingler
16th August 2008, 09:19 PM
Thanks Hlingler,

I want to try this, before I do can you please explain what this dose.This section ensures that all users have permission to use 3D/DRI.

Since you reported that Google-Earth worked for root user, but not for normal user, it seems like a reasonable thing to try.

V

majdi
29th August 2008, 04:48 PM
Hi Hlingler,

I tried this with a restart and I still have the same problem, ok in root, not so good for user.

Any Idea?

Hlingler
29th August 2008, 04:59 PM
Post results (as normal user):
glxinfo|grep render

Attach copy of /etc/X11/xorg.conf.

V

majdi
29th August 2008, 06:29 PM
Hi Hlingler,

Here are the results;


[majdi@localhost ~]$ cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1280x800"
HorizSync 31.5 - 50.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
[majdi@localhost ~]$



[majdi@localhost ~]$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 965GM 20061102 x86/MMX/SSE2
[majdi@localhost ~]$

Hlingler
29th August 2008, 06:41 PM
Looks good to me. :confused:

About the only thing left to do is: try to start Google-Earth from command line, and watch for errors/warnings in the output.

<Shrug>

V

majdi
29th August 2008, 08:34 PM
I did that and no errors, maybe I have two different versions running one for the user and one for root?

majdi
2nd September 2008, 11:54 AM
Could it be that I have two different display configurations, one for root and one for the user?

Im still having the same problem, it works fine in root but it shows up funny in the user account.

Hlingler
2nd September 2008, 11:58 AM
Well, what's the difference between the two configurations?

V

majdi
2nd September 2008, 12:43 PM
I cant see a difference, and dont know of any, but can this be a possibility, I cant think of anything else that could be causing this.