PDA

View Full Version : ppp0 refuses to close gracefully



OberonKenObi
25th July 2004, 02:01 PM
Hi all,
FC2 installed by a Linux Guru mate, so I know it was installed correctly and did in fact work fine for months. External Modem.

Activating modem is not a problem, it works fine. The problem comes when I try to deactivate it. I use the Network Device Control in Gnome. I've changed nothing between last good operation of the deactivation (yes it has worked on many previous occasions) and the current problem.

Problem. Open modem --- works fine ---
press deactivate --- processor uses between 96% and 100% resources.
--- allows me to open some applications but not a terminal or the shut down menu.
--- Now please excuse my N00bness,
--- pressing all the combinations of Ctrl + Alt + Backspace, Ctrl + Alt + F2, Ctrl + Alt + F7 have so far not been succesful at allowing me a gracefull shut down.

Error generated on the blank black screen (when I can make it to there.)
--- ppp0 unregister netdevice: waiting for ppp0 to become free. Usage count = 1 ad infinitum ---

Even unplugging the modem from the wall didnt stop this message.
One solution I have tried was to open a Terminal and use the ps aux command, see the [pid] and use kill -9 to end it till i found a better solution, this worked maybe 10 times then began doing the same Error.

Update --- the kill -9 works 50 % of the time, randomly it seems.

23 July, RH update agent listed an update to ppp (and one other that was a dependancy) so I installed that, 1st time i used the network device control to deactivate modem it worked fine, but subsequent uses have yielded the same Error message. Arghhh.

Please help me, I have not just run straght to the boards for a solution, but this is beyond the scope of my knowledge.

Cheers
Lon

Princess Leah says "Help us OberonKenObi, your our only hope"
OberonKenObi says " No!! visit http://fedoraforum.org/forum, thats where REAL salvation lies"

superbnerd
25th July 2004, 07:31 PM
no solution to your prob, but to some of your newbiesness. Ctrl + Alt + Backspace (F1, etc.) don't shutdown the system. Ctrl + Alt + Backspace does, however, shutdown the X windows system (your gui). using the F# option hust switched you to a text mode shell. Except F7 which returns you to graphical mode, if X is running.

OberonKenObi
26th July 2004, 12:55 AM
Superbnerd, thanks for the answer mate but maybe I was not so clear. So here is clarification.

These are all I am lead to believe correct key combinations. The reason I said n00byness was in case i was wrong.

When modem did its little thing I used Ctrl + Alt + Backspace to Unfreeze Unix.
Then used Ctrl + Alt + F2 to try to get a login prompt. Where the message
--- ppp0 unregister netdevice: waiting for ppp0 to become free. Usage count = 1 --- ad infinitum
was once more encountered.
Then the use of Ctrl + Alt + F7 was just to try to regain use of the gui once more.
Every now and again when I get to the gui login screen I --- sometimes --- get the shutdown OR reboot option to work for me.
Hope that clears up some more of my problem.

Lon