PDA

View Full Version : TV Tuner V4L autodetect wrong card



James1956
14th August 2008, 03:12 AM
Hi,

I'm not sure how to change the card on TV Tuner from dmesg as a UPMOST PURPLE TV [card=36... to a Yuan 900 card 66. How do change cards?

dmesg

saa7133[0]: found at 0000:05:06.0, rev: 240, irq: 16, latency: 32, mmio: 0xd3000000
saa7133[0]: subsystem: 12ab:0800, board: UPMOST PURPLE TV [card=36,autodetected]
saa7133[0]: board init: gpio is 0
input: Purple TV as /devices/virtual/input/input7
ir-kbd-i2c: Purple TV detected at i2c-2/2-007a/ir0 [saa7133[0]]
saa7133[0]: i2c eeprom 00: ab 12 00 08 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 10: ff ff ff ff 15 00 05 01 13 c2 db ff ff ff ff ff
saa7133[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
tuner' 2-004b: chip found @ 0x96 (saa7133[0])
tuner-simple 2-004b: type set to 43 (Philips NTSC MK3 (FM1236MK3 or FM1236/F))
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0

lspci

05:06.0 0480: 1131:7133 (rev f0)
Subsystem: 12ab:0800
Flags: bus master, medium devsel, latency 32, IRQ 16
Memory at d3000000 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>
Kernel driver in use: saa7134
Kernel modules: saa7134

cat /proc/version

Linux version 2.6.25.11-97.fc9.x86_64 (mockbuild@) (gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) ) #1 SMP Mon Jul 21 01:09:10 EDT 2008


Thanks

James1956
15th August 2008, 01:56 AM
I'm sorry, soon as I put this on the forum; I figure it out. Just use modprobe to change it. I just have not figure out how to turn off the auto detect off. I got the sound working too.

SuperNu
15th August 2008, 04:17 AM
I am not sure what kernel module your card uses, but for my Hauppauge pvr-350, I have the following lines in /etc/modprobe.conf

alias char-major-81-0 ivtv
alias char-major-81-1 ivtv
options ivtv cardtype=2,2 tuner=47,47

You will probably have to add an option line to /etc/modprobe.conf for your tuner module and set the proper card type. I would check out LinuxTV.org (http://www.linuxtv.org/) for more help.

--SN

James1956
17th August 2008, 06:06 AM
I got a avermedia tvexpert 350 which actually a Yuan 900. I us modprobe to change the card to 66 and it works. I don't know how to make it permanent.