PDA

View Full Version : nvidia.ko error after 2.6.25.14.108 kernel update F9



crainey69
14th August 2008, 12:40 AM
Hi,

I've been watching the forum all day thinking someone else may have this problem but, haven't seen anything and did a couple of searches and found nothing.

Last night, I updated via yum and got a new kernel and kmod-nvidia packages along with a bunch of other stuff. Now, x will not start with Nvidia drviver.

It reports that it can't find nvidia.ko for kernel 2.6.25.14.108

Anyone? Leigh?

Thanks

Cory

ValHolla
14th August 2008, 01:06 AM
I have the same issue. I am have a HP dv9000 series laptop with a Geforce 6150 Go video card.
I reverted back to the .97 kernel until I find the drivers.

marko
14th August 2008, 01:07 AM
The matching nvidia package for 2.6.25.14.108 isn't on livna yet,
it does seem to be a bit longer than it usually takes...

crainey69
14th August 2008, 01:11 AM
Thanks guys!

I'll be patient. I'm back on the previous kernel myself for now. I was just surprised that no one else had posted anything about it on the forums today. Thought it was just me

Cory

PatMcLJr
14th August 2008, 02:19 AM
me too on f8
the duel head loses a monitor when this happens.
it has been getting better though

Pat Jr

Hlingler
14th August 2008, 02:39 AM
Hello:

You should be able to avoid these problems and delays by installing the matching akmod-nvidia package for your driver version & architecture (e.g., akmod-nvidia-173.14.12-2.lvn9.i686.rpm), which will build the kmod for you. You will also need the kernel-devel and kernel-headers packages to match the new kernel, in order for akmod to build the kmod. May require a manual command to start the build - not sure on that part:
akmods --kernels <kernel-version-and-release-number>

Not available for F8. :(

V

ValHolla
14th August 2008, 02:58 AM
Hlingler:

Thank you for the reminder about akmod, I was running x64 on my laptop, but got fed up with the incompatibility issues... I re-installed i386 and didn't install akmod. installing akmod-nvidia worked beautifully

Hlingler
14th August 2008, 03:21 AM
@ PatMcLJr:

I have evaded this problem on F8 by downloading and re-building the FreshRPMs SRPM of the F9 driver package: nvidia-x11-drv using 'rpmbuild'. That SRPM package (and RPMs built from it) appears to be missing library(ies) libwfb.so*, but that lib seems "optional" (??). In any case, the driver performs acceptably here. Nor does FreshRPMs have the latest driver version, but a quick read of the changelog reveals no impact on my chipset.

Requires all of the usual build/development tools, plus dkms, kernel-devel, kernel-headers, rpmbuild, etc., etc., etc. YMMV.

V

brebs
14th August 2008, 03:40 AM
appears to be missing library(ies) libwfb.so*, but that lib seems "optional" (??).
Depends which nvidia video card (http://bugs.gentoo.org/show_bug.cgi?id=202978) is being used.

crainey69
14th August 2008, 04:51 AM
Hello:

You should be able to avoid these problems and delays by installing the matching akmod-nvidia package for your driver version & architecture (e.g., akmod-nvidia-173.14.12-2.lvn9.i686.rpm), which will build the kmod for you. You will also need the kernel-devel and kernel-headers packages to match the new kernel, in order for akmod to build the kmod. May require a manual command to start the build - not sure on that part:
akmods --kernels <kernel-version-and-release-number>

Not available for F8. :(

V

Thank you, that fixed it! Only concern I have now. Will everything update automatically in the future as it has in the past?

Only other issue I have right now is that I have to rebuild vmware with every kernel update. Actually another thread in itself but if anyone has any suggestions they would be appreciated. Currently running Windows Xp (from an actual previous install), CentoOS5.2, Ubuntu (latest whatever), and F10 Alpha (after a lot of effort) as virtual machines.

Cory

Edit: More info: just used yum to install akmod-nvidia and had to go through a rebuild process at reboot. but it did it all on its own. Told me what I needed to do, and I followed prompts.

Hlingler
14th August 2008, 05:00 AM
Thank you, that fixed it! Only concern I have now. Will everything update automatically in the future as it has in the past?Yes, of course - assuming that you have the Livna repo enabled and automatic updates on (or, do the updates manually often enough).

I personally know nothing about VMWare/VBox/virtualization etc.

Glad that worked for you.

V

P.S. I see that you don't have to build the kmod manually - if one isn't found laying around at boot time, then one is built on-the-spot....

marcosaluzzo
14th August 2008, 07:09 AM
Hi all,

I am experiencing the exact problems described here. I yum updated the kernel version to 2.6.25.14-108 and on the next boot I had problems with the nvidia.ko driver, just like when I first installed F9 x86_64 - blank screen or automatically reboots. Luckily I had been there before so I took me a matter of minutes to sort out the problem.

However I want to add that it doesn't always crash with kernel version. I find 50% of the time I log in through the GUI mode with no problem.

ASUS Nvidia EN8800GT 512mb
Intel S.775 Asus P5K SE/EPU

ValHolla
14th August 2008, 03:43 PM
The only thing I have found using akmod, is it takes me "2" reboots after upgrading the kernel module.

the first reboot, fails to load the nvidia.ko module, then a short time later in the boot sequence it "builds" the module. after the build it fails to load. upon second reboot, the newly built module loads without issue.

null_pointer_us
14th August 2008, 09:05 PM
Yep, same here.

Shouldn't the akmods check be earlier in the boot process than the nvidia.ko load script?

brebs
14th August 2008, 09:16 PM
It is xorg that uses the nvidia kernel module, and modprobes it if nvidia is set in xorg.conf

Sounds like the nvidia recompilation is occurring after xorg is started, which is of course in the wrong order ;)

I use this little script in rc.local (http://www.fedoraforum.org/forum/showthread.php?p=1047697#post1047697), which has the advantage that people can see what's going on :)

mcbridz
14th August 2008, 09:24 PM
This is the first time I've ran into a problem like this (identical, I updated F9 and after reboot... no more nvidia). How exactly do I revert my kernel to a previous version? I know it has to do with yumex, but I'm stuck. Every time I try to install a previous kmod it just errors out on me.

ValHolla
14th August 2008, 09:32 PM
The easiest way to get you back into GUI is just select the old revision in GRUB

By default GRUB will keep the last kernel you had in its list, just select it at boot time.
then you can go into the grub.conf file and make it "default" or you can bring up yumex and remove the "new kernel"

erroneus
14th August 2008, 11:14 PM
I installed the akmod packages (for nvidia and also for the gspca) through yum. I did not bother to uninstall any older modules... figured I could do that if I needed to. Then, I installed the kernel updates. I had held off on the kernel updates because ordinarily, I wait to see the kernel modules also available before I do that.

So the installs went perfectly. Then I closed my apps and rebooted.

The system started its boot process and then I was greeted with the "nvidia" logo that comes up when the proprietary driver is initialized. I was a bit surprised given that I expected to have the same problems everyone else did. So I suspected that I simply hadn't booted the new kernel for some reason.

I checked the kernel version. It's the new kernel. The nvidia kernel module seems to have installed properly since I have full acceleration. Did something change or get fixed in the Livna packages or did everyone else just have a glitch that I did not?

During the boot process, it did tell me that the kernel module was already loaded... I'm pleased with the results, but confused as to why I didn't have the same troubles as everyone else?

ValHolla
14th August 2008, 11:46 PM
erroneus:

the akmod package from livna builds the module for you at first boot. I wonder why yours loaded on the first reboot though? :confused: but here nor there.

erroneus
15th August 2008, 12:52 AM
That's what I wonder. But perhaps it had something to do with the fact that I first loaded the akmod packages, then loaded the new kernel in a second yum session? It worked nicely anyway.

Guess I'll see what happens during the next kernel update...

Hlingler
15th August 2008, 01:01 AM
Those of you who have had problems with the kmod loading, may have forgotten to turn the nvidia service daemon on at system start:
checkconfig --level 5 nvidia on

There may be other things happening during system start that automatically cause the nvidia service and/or akmod to build the kmod, but by then, it's probably too late - Xorg has forged ahead, found no kmod, and so chokes. The next boot finds the just-built kmod, so all is well from that point on.

Just a guess....

V

ValHolla
15th August 2008, 02:16 AM
I am not sure, here is my check config for nvidia it looks OK, although I am not sure why it starts in init 2,3, or 4 :confused:


$ chkconfig --list nvidia
nvidia 0:off 1:off 2:on 3:on 4:on 5:on 6:off

null_pointer_us
15th August 2008, 02:29 AM
My guess is that the nvidia service starts at init 2 due to the rhgb.

Mine is configured identically, and I certainly didn't change it from the F9/livna defaults.


Note that having desktop effects enabled may compound this problem. If you leave desktop effects enabled while rebooting into a new kernel without a corresponding kmod-nvidia, X may crash. On my PC, I was presented with a white screen. This happened even after the livna-config-display had auto-disable the nvidia driver by modifying the xorg.conf for me.


It looks like the overall problem of kernel/kmod mismatch (with third party repos.) is also being discussed by the developers (http://fedoraproject.org/wiki/FWN/Issue138#Solving_the_Unsynchronized_Release_of_Pac kage_Dependencies). :)

ValHolla
15th August 2008, 02:57 AM
I am just happy we have a good work around, whether or not it boots correctly the first time after upgrade or the second. Until Nvidia, ATI and Intel release the source code ( I am not holding my breath) we have to rely on them to update their drivers. Luckily we have the folks at Livna and others :cool: that keep the drivers as up to date as possible. :D

I have my server here running f9 with an ATI card, I can't enable the desktop effects due to fglx drivers support, ati allinwonder 2006 I don't really want to downgrade my X to get it working... I don't use the 3d on that system anyway, it is there for my kids to play their games online ( cartoon network, yahoo kids, nick-jr, pbskids ) and serves as my nfs server for my 30k music files and amarok DB My kids are 18mo, 5 and 7 and they use Linux with no problem.

before anyone asks:
I have xover office to make the shockwave work, and it works as good as it did on winxp using firefox.

sandaili
15th August 2008, 04:01 AM
I have the same problem. Restarted today, got this error. I have to choose the previous kernel at startup in order to boot in. Almost makes me want to install ubuntu....*snickers*

null_pointer_us
15th August 2008, 04:07 AM
Clearly, if the 18 mo can't downgrade X on her own, Linux isn't ready for the desktop.

/joke


Seriously, I think it's great you've got your kids using Linux. Everyone should do that. Open source software is the future, and the more people are using it now, the sooner that future will come to pass. IMO the coolest thing about FLOSS is that there's no one agenda or mentality; nearly anyone who can do the work can jump in and help.

When Linux is targetted by many commercial game developers, that'll be the year of the Linux desktop IMO.

If Linux supported my games -- I did check -- I'd dump Vista, even though I have Vista working fine now. Linux is simply a much better OS from a technical standpoint, and it's arguably easier to use (still some rough spots, though). If Microsoft scrapped NT and made Windows 7 a well-tuned Linux / XFCE distribution, I'd be so happy. Either the third-party Windows developers would start embracing Linux, or there'd be a ton of money thrown into ReactOS -- nice outcome either way! Pipe dream, however. Pure fantasy.

Anyway, one really amusing thing is that I got an old Windows game to run better on Linux. The most trouble I had with Lords of the Realm 2 was that I had to manually copy some files off the disc. Other than that, it seems to work and plays very well. Even the FMVs play. No stutters or unexplained crashes, either.


To get back on topic: fixes like seamless kernel/kmod updates will be required before any (sane) commercial developer would even think of targetting Linux for serious revenue. So the discussion noted in the FWN Issue #138 indicates some very good progress.

crainey69
16th August 2008, 12:37 AM
Off topic for the thread but... wait a minute this started as my thread. Of my 3 kids, I can get 1 to use Fedora pretty much exclusively and only use Windows in a Virtual machine. The other 2 sit down and automatically reboot into XP straight. Some program locked up on Trinity the other day (in Fedora 9) and my oldest daughter was very quick to say "See Linux crashes"!. She doesn't understand the whole cutting edge and that the applications are crashing or maybe even X but not linux.

ValHolla
16th August 2008, 12:54 AM
I must say I cheated a bit. I removed the XP choice from Grub and limited their account not to be able to run the windows VM. once they got used to it, they don't even ask to load windows any more.

the only complaint they have at this point is some of the OpenGL games they can't run because of the ATI card and fglrx problems.

crainey69
16th August 2008, 07:50 AM
Tried the grub thing and my 15 year old daughter almost cried. Couldn't help myself "daddy" put it back.. I can only get vmware to run right as root right now (working on that). I can usually get away with starting XP and making it full screen and walking away.

I guess I should kill XP for them all together and say if you want computer and internet, then use Fedora. I have Centos5, Ubuntu Hardy, Fedora 10 Alpha, and XP as VM's from F9 but, only have F9, F10, and XP as boot options in grub.

Just noticed ValHolla, you're pretty close to me.. What's up in St. Louis? Ok so much for the original importance of this thread!

If someone that needs help is reading all of this, it was solved for me way back with the akmod solution but didn't apperar to fix everyone.

ValHolla
16th August 2008, 02:37 PM
*** sorry about hijacking the thread I didn't mean to start something ***
I started a new thread HERE (http://forums.fedoraforum.org/showthread.php?p=1064577#post1064577)
if we could get someone to move the relevant posts :D

What are they running on windows? is there an equivalent for Linux? can you get it to run under wine? or crossover? crossover is cool it sorta lives in the background and really "integrates" into the system so the window apps are "seamless".

I found it while trying to get visio to run under Linux at work. visio and the office sweet don't play nice with wine, at least not 0.9, haven't tried under 1.0 yet....
in case you don't know wine is to crossover as CentOS is to RedHat...

I use ProCon Latte plugin for firefox and have it setup to block "ALL" sites, then whitelist the sites I want them to get to. yahoo-kids, nick-jr, pbskids, playhouse disney cartoon network. etc... this also stops them from click through from site to site.

MWcline
16th August 2008, 03:00 PM
Hello:

You should be able to avoid these problems and delays by installing the matching akmod-nvidia package for your driver version & architecture (e.g., akmod-nvidia-173.14.12-2.lvn9.i686.rpm), which will build the kmod for you. You will also need the kernel-devel and kernel-headers packages to match the new kernel, in order for akmod to build the kmod. May require a manual command to start the build - not sure on that part:
akmods --kernels <kernel-version-and-release-number>

Not available for F8. :(

V

Hey, newbie here. I had the same problem with a fresh install.
All I did was :
yum install akmod-nvidia
Rebooted and received some error messages followed by some messages indicating that the driver was being installed, but no nividia driver after the boot completed.
Rebooted again and all is well.
Well, except that some of the resolutions are missing. There's a gap between 1024X768 and 1400X900.

Thanks
Mike

testguyct
16th September 2008, 07:29 PM
Hey, newbie here. I had the same problem with a fresh install.
All I did was :
yum install akmod-nvidia
Rebooted and received some error messages followed by some messages indicating that the driver was being installed, but no nividia driver after the boot completed.
Rebooted again and all is well.
Well, except that some of the resolutions are missing. There's a gap between 1024X768 and 1400X900.

Thanks
Mike

Mike,

Thanks for posting this. It just saved me a lot of trouble. I had done a yum update yesterday (I'm running Fedora 9 x64), and after rebooting, KDE would never start. I would get the text login prompt, and some screen flickering.

I just did the yum install akmod-nvidia and rebooted a couple of times, and I'm back in business !

-testguyct