PDA

View Full Version : Problem with multiple USB audio modules



mspratt
12th August 2008, 09:46 PM
Hi All,

I am writing an app using multiple USB audio modules, Icecast 2 and Ices 2. Using C-Media USB I was able to indepently control 10 channels. We are streaming this to a local Intranet installation of Icecast/Ices. Then I went out and got the cheap solution, Ebay purchase of 25 USB audio cards (no-name). I had 25 cards show up in aplay -l but apparently the USB audio is sharing the driver module. I can get one to input audio but as soon as I add a second USB they both fail. Is there a way to force Fedora 9 to load individual drivers?

I am including the output of aplay -l:

card 0: default [USB AUDIO ], device 0: USB Audio [USB Audio]
card 1: default_1 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 2: default_2 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 3: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
card 3: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
card 4: default_3 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 5: default_4 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 6: default_5 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 7: default_6 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 8: default_7 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 9: default_8 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 10: default_9 [USB AUDIO ], device 0: USB Audio [USB Audio]
card 11: default_A [USB AUDIO ], device 0: USB Audio [USB Audio]
card 12: default_B [USB AUDIO ], device 0: USB Audio [USB Audio]
card 13: default_C [USB AUDIO ], device 0: USB Audio [USB Audio]
card 14: default_D [USB AUDIO ], device 0: USB Audio [USB Audio]
card 15: default_E [USB AUDIO ], device 0: USB Audio [USB Audio]
card 16: default_F [USB AUDIO ], device 0: USB Audio [USB Audio]
card 17: default_G [USB AUDIO ], device 0: USB Audio [USB Audio]
card 18: default_H [USB AUDIO ], device 0: USB Audio [USB Audio]
card 19: default_I [USB AUDIO ], device 0: USB Audio [USB Audio]
card 20: default_J [USB AUDIO ], device 0: USB Audio [USB Audio]
card 21: default_K [USB AUDIO ], device 0: USB Audio [USB Audio]
card 22: default_L [USB AUDIO ], device 0: USB Audio [USB Audio]
card 23: default_M [USB AUDIO ], device 0: USB Audio [USB Audio]
card 24: default_N [USB AUDIO ], device 0: USB Audio [USB Audio]

I turned off the motherboard audio in the BIOS but Fedora finds it anyway. :(

I would appreciate any point in the right direction as I am relatively new to Linux.

Thanks,

Mike

mspratt
15th August 2008, 04:26 PM
No problem.

Although the system recognizes all 25 channels, apparently ALSA chokes on more than 8.

I'll check to see if there is an ALSA newsgroup.

Regards,

Mike