PDA

View Full Version : 82801I (ICH9 Family) HD Audio not working



LuHe
11th August 2008, 06:03 PM
Hello,

My notebook is a HP Pavilion dv7-1018eg and I am using Fedora 9

I have a problem with the following audio device:

[root@localhost ~]# lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)



[root@localhost ~]# lspci -s 00:1b.0 -vn
00:1b.0 0403: 8086:293e (rev 03)
Subsystem: 103c:30f4
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at df300000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel <?>
Capabilities: [130] Root Complex Link <?>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel





[root@localhost ~]# cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD71B7X
Codec: Generic 10de ID 6


I am using kernel 2.6.25.11-97.fc9.x86_64 and get no sound output

I tried to upgrade the kernel to the current rawhide version ( 2.6.27-0.244.rc2.git1.fc10.x86_64 ) and there I got some output, but the sound was always hanging for some seconds.

Thanks for any help!

EDIT: I have the "hanging sound" problem also with Fedora 10 Alpha and the latetst Kubuntu release.

EDIT 2: It seems to work if I play an audio file with mplayer and kill pulseaudio on Kubuntu 8.10 Alpha 3. Is there any chance to get it working on Fedora 9?

EDIT 3: my alsa-info.txt is here: http://pastey.net/93682

LuHe
13th August 2008, 12:03 PM
Any Ideas what I sould try?

BustEz
17th August 2008, 07:10 PM
hey dude, i just got a laptop with the same audio hardware. just like to tell you that we're in the same boat coz my audio isn't working either :D

LuHe
17th August 2008, 07:41 PM
Hello
wow great to see that somebody has the same hardware ;)
yeah.. i found a solution:

The first thing you have to do is to update your ALSA library:
# su -
# yum --enablerepo=rawhide update alsa*

Then update the ALSA driver (the soundcard is only recognized with alsa >= 1.0.17, fedora 9 has 1.0.16):
# wget "ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2"
# tar -xf alsa-driver-1.0.17.tar.bz2
# cd alsa-driver-1.0.17
# ./configure
# make
# make install

Then it works really great ;)

BustEz
18th August 2008, 08:05 AM
you legend, wooohooo! Thanx man, does work really great :D
p.s. we got similar laptops, mines a dv5-1009tx, first thing i did when when i got the machine was to nuke the harddisk and install f9 which sounds like what you did too. They make us forcibly pay for vista lol ugg :mad:

Have fun with your new machine!

p.s.s. (you'll have a great time sorting out the "ICH9M/M-E SATA AHCI Controller" issue, you'll know what i mean if you try running a vmware image off an external e-sata drive ;) )

AutoStatic
27th August 2008, 11:06 PM
Got a DV7-1070 here with exactly the same audio device. But even after installing the rawhide ALSA packages and compiling and installing the 1.0.17 ALSA drivers sound is still hanging. Am I missing something here? Do I also need the 2.6.27 kernel? Thanks!

Jeremy

LuHe
28th August 2008, 01:48 AM
Do you use pulseaudio?
It was hanging if I used alsa directly, but with pulseaudio it was working fine.

P.S.: I updated pulseaudio to rawhide, don't know if it makes any difference

AutoStatic
28th August 2008, 12:25 PM
Probably will, I'll try. Thanks for the prompt reply :) Tried both Alsa and PulseAudio.

AutoStatic
28th August 2008, 06:55 PM
Updated pulseaudio. Got sound but with Alsa I get a nasty kind of echo so it´s still not useable. With pulseaudio I only get distortion.

BustEz
28th August 2008, 07:18 PM
not sure if this helps, but these are the packages i got installed pertaining to pulse & alsa, probably don't need half of them lol.

bluez-utils-alsa-3.32-1.fc9.x86_64
alsa-utils-1.0.17-1.fc10.x86_64
alsa-lib-devel-1.0.17-2.fc10.x86_64
alsa-lib-1.0.17-2.fc10.x86_64
alsa-plugins-pulseaudio-1.0.17-1.fc10.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
pulseaudio-module-gconf-0.9.10-1.fc9.x86_64
pulseaudio-libs-0.9.10-1.fc9.x86_64
pulseaudio-utils-0.9.10-1.fc9.x86_64
pulseaudio-0.9.10-1.fc9.x86_64
pulseaudio-libs-0.9.10-1.fc9.i386
pulseaudio-libs-glib2-0.9.10-1.fc9.x86_64
pulseaudio-module-x11-0.9.10-1.fc9.x86_64
pulseaudio-core-libs-0.9.10-1.fc9.x86_64
pulseaudio-esound-compat-0.9.10-1.fc9.x86_64

$uname -r
2.6.25.14-108.fc9.x86_64

AutoStatic
28th August 2008, 08:02 PM
Thanks BustEz! Big difference already is that I don't have a 64bit system. But Juliana Hatfield is ringing in my ears right now. It has got something to do with ACPI. When I disable it then sound works fine.
This is what I got installed right now:
alsa-plugins-pulseaudio.i386 1.0.17-1.fc10 installed
pulseaudio.i386 0.9.11-1.fc10 installed
pulseaudio-core-libs.i386 0.9.11-1.fc10 installed
pulseaudio-esound-compat.i386 0.9.11-1.fc10 installed
pulseaudio-libs.i386 0.9.11-1.fc10 installed
pulseaudio-libs-glib2.i386 0.9.11-1.fc10 installed
pulseaudio-module-gconf.i386 0.9.11-1.fc10 installed
pulseaudio-module-lirc.i386 0.9.11-1.fc10 installed
pulseaudio-module-x11.i386 0.9.11-1.fc10 installed
pulseaudio-utils.i386 0.9.11-1.fc10 installed
alsa-lib.i386 1.0.17-2.fc10 installed
alsa-utils.i386 1.0.17-1.fc10 installed
bluez-utils-alsa.i386 3.32-1.fc9 installed

And I compiled and installed the 1.0.17 alsa drivers. Aren't those packaged too? Isn't that the alsa-firmware package?
And wow, even the touchpad works, nice :)

Ow, cheered too early (forgive me the Dutch expression), sound still hangs every now and then, it's probably some app getting in the way somehow.

LuHe
5th September 2008, 04:32 PM
Hello,

what do you mean with "hangs every now and then"?
I also have the same problem and havn't figured out what caused it:

When I watch a movie or play a music file for more then around 15 minutes and
neither move my mouse nor press any key the sound "hangs" (the movie hangs
too). If I move my mouse everything works again for a few seconds, but then my
sound hangs again.

I use kde powersaver and have set the schema to "Akustik", but it doesn't
change anything.

The problem occurs also if I plug in the power supply.

I don't see any useful information in /var/log/messages, dmesg or pulseaudio -
vvvv

Seems like the soundcard is in idle state?

LuHe
5th September 2008, 04:37 PM
And I compiled and installed the 1.0.17 alsa drivers. Aren't those packaged too? Isn't that the alsa-firmware package?
And wow, even the touchpad works, nice :)


AFAIK you also need the kernel modules (snd-hda-intel.ko), which is only provided by the kernel itself.

[lukas@erde ~]$ rpm -qf /lib/modules/2.6.25.11-97.fc9.x86_64/kernel/sound/pci/hda/snd-hda-intel.ko
kernel-2.6.25.11-97.fc9.x86_64

AutoStatic
5th September 2008, 07:15 PM
Solved this issue. I added pci=noacpi as a kernel option. So maybe it's an IRQ assignment problem? I also added options snd-hda-intel single_cmd=1 to /etc/modprobe.conf and updated to the latest alsa drivers (1.0.17) that specifically support this soundcard. I have no problems anymore whatsoever. I need to admit though that I switched to Ubuntu on this laptop since either the power management implementation or the nvidia driver on F9 freezes my notebook.
And the kernelmodule you mention gets built and installed when you compile the alsa-drivers:
cp snd-hda-intel.ko /lib/modules/2.6.24-19-generic/kernel/sound/pci/hda

LuHe
8th September 2008, 11:14 AM
Solved this issue. I added pci=noacpi as a kernel option. So maybe it's an IRQ assignment problem? I also added options snd-hda-intel single_cmd=1 to /etc/modprobe.conf and updated to the latest alsa drivers (1.0.17) that specifically support this soundcard. I have no problems anymore whatsoever.

Thanks for this tip. ;)
My audio works great, but watching movies still "hangs".



And the kernelmodule you mention gets built and installed when you compile the alsa-drivers:
Yes, but these aren't in any seperate package (except in the kernel package itself)

AutoStatic
8th September 2008, 12:44 PM
When I'm watching movies sound lags every now and then too. But I generally watch streams from my homeserver so I would say it's a cache issue.
And concerning the kernelmodule, HHIS ;)

joolly
8th September 2008, 09:57 PM
Hello
wow great to see that somebody has the same hardware ;)
yeah.. i found a solution:

The first thing you have to do is to update your ALSA library:
# su -
# yum --enablerepo=rawhide update alsa*

Then update the ALSA driver (the soundcard is only recognized with alsa >= 1.0.17, fedora 9 has 1.0.16):
# wget "ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.17.tar.bz2"
# tar -xf alsa-driver-1.0.17.tar.bz2
# cd alsa-driver-1.0.17
# ./configure
# make
# make install

Then it works really great ;)

I tried your suggestions. It works.

Now I have updated to 1.0.17. :)
But still there is no sound :(

Any ideas what I could try else?

Tanks for any help!

:confused: :(

LuHe
8th September 2008, 10:35 PM
Any ideas what I could try else?

Tanks for any help!

:confused: :(

Have you muted the device in kmix or alsamixergui?
Can you post the output of alsa-info ?

joolly
8th September 2008, 10:46 PM
Have you muted the device in kmix or alsamixergui?
Can you post the output of alsa-info ?

alsa-info? how do I proceed?

Mute: don't think so. In the lower right corner there is this speaker. I click there on Mixer. => Kmix. All channels are on.

joolly
8th September 2008, 10:55 PM
ah, there it is. but it would not fit into the reply. The beginning is enough?

!!################################
!!ALSA Information Script v 0.4.41
!!################################

!!Script ran on: Mon Sep 8 23:49:16 CEST 2008


!!Linux Distribution
!!------------------

Fedora release 8 (Werewolf) Fedora release 8 (Werewolf) Fedora release 8 (Werewolf) Fedora release 8 (Werewolf)


!!Kernel Information
!!------------------

Kernel release: 2.6.25.14-69.fc8
Operating System: GNU/Linux
Architecture: i686
Processor: i686
SMP Enabled: Yes


!!ALSA Version
!!------------

Driver version: 1.0.17
Library version: 1.0.16
Utilities version: 1.0.16


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Soundcards recognised by ALSA
!!-----------------------------

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfa200000 irq 22


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)


!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:284b (rev 03)
Subsystem: 17c0:4085


!!Modprobe options (Sound related)
!!--------------------------------

snd-card-0: index=0
snd-hda-intel: index=0
snd-hda-intel: model=medion


!!Loaded sound module options
!!--------------------------

!!Module: snd_hda_intel
bdl_pos_adj : 1,-1,-1,-1,-1,-1,-1,-1
enable : Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : 0
id : <NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
index : 0,-1,-1,-1,-1,-1,-1,-1
model : medion,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>,<NULL>
position_fix : 0,0,0,0,0,0,0,0
power_save : 0
power_save_controller : Y
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1
single_cmd : N


!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Realtek ALC888
Address: 0
Vendor Id: 0x10ec0888
Subsystem Id: 0x17c02026
Revision Id: 0x100001
No Modem Function Group found
Default PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
GPIO: io=3, o=0, i=0, unsolicited=1, wake=0
IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0
IO[1]: enable=0, dir=0, wake=0, sticky=0, data=0
IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0
Node 0x02 [Audio Output] wcaps 0x11: Stereo
Converter: stream=5, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x03 [Audio Output] wcaps 0x11: Stereo
Converter: stream=5, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x04 [Audio Output] wcaps 0x11: Stereo
Converter: stream=5, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x05 [Audio Output] wcaps 0x11: Stereo
Converter: stream=5, channel=0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
Converter: stream=0, channel=0
Digital:
Digital category: 0x0
PCM:
rates [0x5e0]: 44100 48000 88200 96000 192000
bits [0x1e]: 16 20 24 32
formats [0x1]: PCM
Node 0x07 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x08 [Audio Input] wcaps 0x10011b: Stereo Amp-In
Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x16 0x16]
Converter: stream=0, channel=0
SDI-Select: 0
PCM:
rates [0x160]: 44100 48000 96000
bits [0x6]: 16 20
formats [0x1]: PCM
Connection: 1
0x23
Node 0x09 [Audio Input] wcaps 0x10011b: Stereo Amp-In
Amp-In caps: ofs=0x0b, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x80 0x80]
Converter: stream=0, channel=0
SDI-Select: 0
PCM:
rates [0x160]: 44100 48000 96000
bits [0x6]: 16 20
formats [0x1]: PCM
Connection: 1
0x22
Node 0x0a [Audio Input] wcaps 0x100391: Stereo Digital
Converter: stream=0, channel=0
SDI-Select: 0
Digital:
Digital category: 0x0
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0x1e]: 16 20 24 32
formats [0x1]: PCM
Unsolicited: tag=00, enabled=0
Connection: 1
0x1f
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x18 0x18] [0x80 0x80] [0x18 0x18] [0x80 0x80] [0x15 0x15] [0x15 0x15] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Connection: 10
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17
Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x80 0x80] [0x80 0x80]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x02 0x0b
Node 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x80 0x80] [0x80 0x80]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x03 0x0b
Node 0x0e [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x80 0x80] [0x80 0x80]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x04 0x0b
Node 0x0f [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x80 0x80] [0x80 0x80]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x05 0x0b
Node 0x10 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x12 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x14 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]

Balinus
17th September 2008, 05:46 PM
Solved this issue. I added pci=noacpi as a kernel option. So maybe it's an IRQ assignment problem? I also added options snd-hda-intel single_cmd=1 to /etc/modprobe.conf and updated to the latest alsa drivers (1.0.17) that specifically support this soundcard. I have no problems anymore whatsoever. I need to admit though that I switched to Ubuntu on this laptop since either the power management implementation or the nvidia driver on F9 freezes my notebook.
And the kernelmodule you mention gets built and installed when you compile the alsa-drivers:
cp snd-hda-intel.ko /lib/modules/2.6.24-19-generic/kernel/sound/pci/hda

I tried LuHe set of commands and I still have no sound with the same sound card. Everything seemed to works perfectly in the installation process.

I have :

[p@localhost ~]$ uname -r
2.6.26.3-29.fc9.x86_64

So, maybe it's time I try to pass "pci=noacpi as a kernel option", but how do you do that? :confused:

Here's my alsa-info : http://www.alsa-project.org/db/?f=477d4097585c4cfbc2b7b222fc1de4f24d58c4a8

Thanks for the help :)

AutoStatic
17th September 2008, 06:06 PM
Hello Balinus, you can add the extra option in /boot/grub/menu.lst at the end of the line that begins with "kernel".

Balinus
17th September 2008, 07:57 PM
Hello Balinus, you can add the extra option in /boot/grub/menu.lst at the end of the line that begins with "kernel".

Thanks!

So, I now have this line :


kernel /boot/vmlinuz-2.6.26.3-29.fc9.x86_64 ro root=UUID=96cd9a9c-cc4f-4d3e-962a-e546cad82ec2 rhgb quiet pci=noacpi

And I also added "options snd-hda-intel single_cmd=1" to /etc/modprobe.conf (which was empty)

But.... no sound! :/

--------------------
Alsa-info output : http://www.alsa-project.org/db/?f=477d4097585c4cfbc2b7b222fc1de4f24d58c4a8
---------------------

ALSA library is empty (?)


!!Kernel Information
!!------------------

Kernel release: 2.6.26.3-29.fc9.x86_64
Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes


!!ALSA Version
!!------------

Driver version: 1.0.17
Library version:
Utilities version: 1.0.18rc3


!!Loaded ALSA modules
!!-------------------

snd_hda_intel


!!Soundcards recognised by ALSA
!!-----------------------------

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf9ff8000 irq 22


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

And :


[proy@localhost ~]$ sudo yum list alsa*
Modules complémentaires chargés*: refresh-packagekit
Paquetages installés
alsa-lib.x86_64 1.0.18-6.rc3.fc10 installed
alsa-plugins-pulseaudio.x86_64 1.0.18-1.rc3.fc10 installed
alsa-utils.x86_64 1.0.18-1.rc3.fc10 installed
alsamixergui.x86_64 0.9.0-0.4.rc1.fc9.2 installed

AutoStatic
17th September 2008, 08:37 PM
Hello Balinus,

Alors, paquetages installés, je n'y comprend rien? Ça doit marcher!
Just fooling around. Just make sure you have ALSA selected in every field in gnome-sound-properties. Pulseaudio still chokes on this IDT soundcard thingy apparently.

Balinus
17th September 2008, 08:56 PM
hehehe :)

Well, in gnome-sound-properties, I selected ALSA - Advanced Linux Sound Architecture.

No sound.

I rebooted but it goes back to "automatically detect".

I just wonder if the library version "alsa-lib.x86_64 1.0.18-6.rc3.fc10" is adequate for Fedora 9 ?

And in alsa-info, there's no library version listed :


!!ALSA Version
!!------------

Driver version: 1.0.17
Library version:
Utilities version: 1.0.18rc3


?

joolly
17th September 2008, 10:33 PM
Hello Balinus,

Alors, paquetages installés, je n'y comprend rien? Ça doit marcher!


Just fooling around. Just make sure you have ALSA selected in every field in gnome-sound-properties. Pulseaudio still chokes on this IDT soundcard thingy apparently.

Oui, ca doit. Mais ca ne mache pas quand meme!

I also have tried. No success. :-( Recently I tried an external usb sound device. So this thingy works at first try. But with the internal one.... No chance so far.

LordMorgul
19th September 2008, 06:29 PM
Just fooling around. Just make sure you have ALSA selected in every field in gnome-sound-properties. Pulseaudio still chokes on this IDT soundcard thingy apparently.
One thing to help avoid hangs, do not change users (fast user switching) or change to virtual terminals (tty, ctrl-alt-f2, etc) while playing audio through pulseaudio, or gstreamer apps may hang. Its caused by code that is supposed to release your 'active session' access to the soundcard hardware, and let another user take access to it while you're not 'active'. It fails miserably in F8/F9 and just hangs instead. Using an app that does not require the gstreamer backend may help if you are seeing those hangs (like run mplayer instead of totem, banshee instead of rhythmbox).

apollo_gdd
30th November 2008, 12:05 PM
i have the same problem,and i havd done as the above ,i still can't hear sound and i never hear sound in fedora 9.0,but it work very well in vista OS,
[root@localhost ~]# lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
[root@localhost ~]# lsmod | grep snd_hda
snd_hda_intel 376440 4
snd_pcm 63108 3 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11656 2 snd_hda_intel,snd_pcm
snd_hwdep 10500 1 snd_hda_intel
snd 47032 17 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,sn d_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer,snd_hwdep
[root@localhost ~]# cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD71B7X
Codec: Generic 10de ID 3
[root@localhost ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
[root@localhost ~]# cat phone_1.wav > /dev/audio
bash: /dev/audio: 设备或资源忙(device or resource is busy)
thanks very much

AutoStatic
30th November 2008, 12:39 PM
This issue has been resolved. Just add options snd-hda-intel enable_msi=1 to /etc/modprobe.conf and sound should work flawless. Make sure you have at least alsa 1.0.17 and delete the extra kernel option mentioned in this thread. Also delete the options snd-hda-intel single_cmd=1 line in /etc/modprobe.conf in case you added that line.

apollo_gdd
4th December 2008, 01:56 PM
i add the line "options snd-hda-intel enable_msi=1;but i still can't hear sound,if need any information ,please tell me ,thanks very much

jerboyd
3rd January 2009, 12:00 AM
hey everyone. i also have an hp pavilion dv7 with the 82801I ich9 intel hda audio card. i'm using F10 and so far the only problems i get are with system sounds (they skip) and my microphone input and the onboard digital mic don't work. i can get the mic input to work by choosing the 'analog loopback' option in the alsa mixer but none of my audio programs work (audacity, ardour, or the fedora sound recorder program)/ has anyone else tested their microphone input and/or got it working?

joolly
3rd January 2009, 10:47 AM
hey everyone. i also have an hp pavilion dv7 with the 82801I ich9 intel hda audio card. i'm using F10 and so far the only problems i get are with system sounds (they skip) and my microphone input and the onboard digital mic don't work. i can get the mic input to work by choosing the 'analog loopback' option in the alsa mixer but none of my audio programs work (audacity, ardour, or the fedora sound recorder program)/ has anyone else tested their microphone input and/or got it working?

Well the system sound server sometimes blocks audacity. I set it to turn off automatically after 1 sec. So Audacity can take it. Or you turn off the sound server completely. Having it on for a while I don' t like it anyway. It' s sort of too much notification of things you know and see anyway. The internal mic does not work so far. But the jack works. I regard it as an advantage since I have no use for the internal mic. anyway. I also can not turn off the speakers while using the headphone. Some analog switches are not set correctly I suppose. I have a medion and I use a configuration of acer that works somehow. You needed the complete hardware schematic of the sound part to tell what goes wrong. Then it would be easy to define a new configuration in the alsa soft that handles all the switches in the right way. The sound module by itself is always the same but there are different ways of connecting the inputs and make use of it. Every manufacturer may think of some different wiring.

Try some configurations. Maybe one of them might work with all your needs. Get the alsa sources and there is some 'ALSA-Configuration.txt' where you can see the possibilities. These are to be used in 'modprobe.conf' which is in /etc . (-;

jerboyd
4th January 2009, 05:15 AM
thanks for the advice but configuring the sound card in modprobe is a little above my skill level. i'm not even sure what the sound server is or what it does so i'm not sure how to turn it off etc. any info on these subjects would be appreciated.

thanks again.

slippere
4th January 2009, 07:55 AM
Well, like the rest of you with ICH9 Family Intel HDA audio cards (mine is in a dv7 notebook), I lost my sound with the last kernel upgrade. I'm currently at 2.6.27.9-159.fc10.x86_64. I just got all of my audio working including headphones, and recording via microphone. The following is what I did to get it to work, I hope it can help some others.

FYI....I had pulse audio installed as well and I have not bee able to get it to play nice. If someone can figure it out after the update of the ALSA drivers, fell free to let us all know. :)

Everything was done as root...so no 'su' commands. I'm just going to give commands and you should all know what privileges you need.

1. Get rid of pulseaudio...

yum remove pulseaudio

2. Download the most recent stable package of ALSA drivers. The alsa-project.org site only lists 1.0.18.a as the most recent, but if we dig a little deeper on their site we can find daily tarball snapshots of stable code. I happened to download the 20090104 version...I wanted to stay away from the unstable tarballs at the bottom.if I could. Download and extract.
http://ftp.kernel.org/pub/linux/kernel/people/tiwai/alsa/alsa-driver/

3. Change the header file adriver.h in the "include" directory found where you extracted everything. One line needs to be commented out (or deleted). Search for fmode_t and comment out that line.


/* other missing types */
#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 28)
//typedef unsigned int fmode_t;
#endif
4. Go back to the main directory and issue the following commands:


./configure --with-cards=hda-intel
make
make install
Reboot and you should be able to configure everything in System>Preferences>Hardware>Sound. I just placed everything on AutoDetect, and then ALSA for Sound Capture.

Good luck. I hope it works for everyone else. Knowing my luck they'll put out a kernel and/or alsa update package in an hour and this post will be meaningless.

slip

Juventinoc10
4th January 2009, 08:48 PM
thanks slippere it worked for me also cheers

eliashickman
6th January 2009, 03:10 PM
@ slippere
Thank you so much. I followed your post to the letter and I finally got sound working after many many tries at uninstalling and reinstalling pulseaudio.
The only thing that remains is that I still hear sound out of the left speaker louder than the right. Any clue?

erroneus
6th January 2009, 07:48 PM
This is a good working solution I am sure, but an unfortunate one.

Every user-oriented Linux distribution should strive to keep users functional through updates rather than through procedures. I have been waiting on an update that will address the problem that was caused by the last update. And as far as I can see, all they really need to do us "undo" whatever it was they did. Moving away from the decided-upon sound services of pulseaudio is not generally a good idea either as future updates may act to cause more problems for those who have implemented this fix.

Once a user deviates from "the system" of fixes and updates, it will forever complicate the potential for smooth upgrades and fixes in the future. Using package management systems like RPM is rather like that as well -- deviate from using RPM to install packages, and you have effectively complicated RPM's capacity to stay regulated and stable. Not using yum could also result in some problems on some systems as well.

These manual fix solutions are a great place to start when engineering a fix that can later be implemented in an RPM and pushed out through yum, but not as a long term solution.

The best fix is through the decided-upon methods.