PDA

View Full Version : Anaconda installer from livecd



kalabharath
11th August 2008, 06:46 AM
hi friends
i have made a custom live cd using live cd tools and gave different look with generic logos , but when i tried to install to hard drive with the option "install to hard disk"- the anaconda gives me a error saying "An error occurred when attempting to load an installer interface component.

className = AccountWindow"

i am including a screen shot -kindly help , i need this option to be enabled as i am distributing it among friends
]

Fenris
17th August 2008, 02:38 AM
Hi kalabharath.

I just experienced the same problem with my custom install cd, and i managed to solve it. Just make shure to add the package @admin-tools to your .ks file, and it will work.

kalabharath
17th August 2008, 07:22 AM
thanks a lot , this will solve my greatest problem

kalabharath
25th September 2008, 04:59 PM
the @admin-tools is already enabled in my ks file , but i have gone to /tem/anaconda.log file and i am posting the log, please kindly help me in this regard

19:54:23 INFO : using only installclass _Fedora
19:54:23 INFO : anaconda called with cmdline = ['/usr/sbin/anaconda', '--method=livecd:///dev/mapper/live-osimg-min', '--lang', 'en_US.UTF-8', '--noselinux']

19:54:23 INFO : Display mode = g
19:54:23 INFO : Method = livecd:///dev/mapper/live-osimg-min
19:54:28 INFO : Starting graphical installation...
19:54:28 INFO : Detected 1024M of memory
19:54:28 INFO : Swap attempt of 1000M to 2000M

19:54:28 WARNING : step installtype does not exist
19:54:28 WARNING : step confirminstall does not exist
19:54:28 WARNING : step complete does not exist
19:54:28 INFO : moving (1) to step welcome
19:54:30 INFO : moving (1) to step keyboard

19:54:31 INFO : moving (1) to step networkdevicecheck
19:54:31 INFO : moving (1) to step network
19:54:33 INFO : moving (1) to step timezone
19:54:35 INFO : moving (1) to step accounts

carlmk
10th October 2008, 01:03 PM
I hit the same problem; installing cracklib-python solved it.

You don't have to rebuild the live cd, just "yum install cracklib-python" and
restart /usr/bin/liveinst

kalabharath
10th October 2008, 01:41 PM
thanks carlmk but i have already solved the problem by some other means