PDA

View Full Version : Fedora Core 9 Atheros Wireless Card Problem



bxche
10th August 2008, 08:39 PM
I have an HP Presario which has a atheros 242x wireless card. After installing Fedore Core 9 and gettiing the updates the network cards appeared. The NIC works but wlan0 will not pick up any access points. I also tried updating the os with madwifi but that caused my system to crash. You can click on the link below to see screenshots of the commands entered as well as the results. I am fairly new to Linux so please provide details if you know what my problem is. Thanks Che'

http://www.screenshotcomputertutorials.com/FC9_Wireless_Problem.swf

scottro
10th August 2008, 09:09 PM
Ok, I didn't look at your screenshots, because I generally avoid flash files. If I might make a suggestion in Linux and Unix forums, I would avoid flash, some people dislike it on principle. I know I do anyway, and I'm the self-styled expert on this card. :)

However, I have a page about this very card at http://home.nyc.rr.com/computertaijutsu/rhwireless.html#5007

In short--you can probably get it working with the MadWifi drivers from livna-testing. If not, you can follow the other instructions on the page, which are, I believe, pretty newcomer friendly.

Please give it a shot and let me know how it works for you.

bxche
10th August 2008, 09:17 PM
I tried installing the madwifi driver 2-3 times. It caused my system to crash/not boot correctly. I had to re-install the OS each time.

You can view a .doc version of it at www.weborphan.com/FC9_Wireless_Problem.doc.

The wlan0 shows up but it will not pick up any access points.

scottro
10th August 2008, 09:44 PM
Please be a little more specific.
Firstly, if it's saying wlan0, it's not going to work unless you're running rawhide. The wlan0 means you're trying to use the ath5k driver.

When you say you tried to install MadWifi and it crashed your system, what happened exactly? Did you follow the instructions on my page about getting rid of any MadWifi or ndiswrapper cruft. Did you try livna-testing as opposed to plain livna?

Did you install gcc and the other things I mention?

In other words, did you follow my page or another tutorial? If you followed my page, did you follow the steps in order?

Also, as far as providing screen shots, there are better ways to do it. If you're using the default Gnome Desktop,

http://library.gnome.org/users/user-guide/latest/tools-screenshot.html

This way you have something that makes it easier for others to just view your screenshots.

This card should almost certainly work in F9, and installing MadWifi shouldn't crash the system if you follow my instructions.
(I realize that sounds immodest, but unfortunately, many Linux oriented howtos leave out essential steps--I pride myself on writing howtos that don't leave out such steps.) :)

bxche
10th August 2008, 11:23 PM
I just completed all the steps from the link you provided. Everything installed with no problems and the computer booted back up (that was a good thing). I noticed a new interface wifi0. However, it is still not picking up my access point and it is inches from it.

scottro
10th August 2008, 11:59 PM
Ok, we're getting there. (And thanks for using the suggestion for screen shots, it makes it much easier.)
Now, you have definitely blacklisted ath5k. Did you use the snapshot or the livna-testing version?

(I know, when you're starting, it's difficult to be sure of what information to provide.)

Either way, would you please try, as root

/sbin/depmod -a
/sbin/modprobe ath_pci
lsmod |grep ath

Then post the results? If you get results as mentioned on my page, please try with
iwlist ath0 scan
and see how it goes.

bxche
11th August 2008, 08:57 PM
I did blacklist ath5k. I used snapshot instead of the livna-tesing version.

[root@localhost ~]# /sbin/iwlist ath0 scan
ath0 Interface doesn't support scanning.

scottro
11th August 2008, 10:08 PM
Please do
ifconfig ath0 up
Then run iwlist ath0 scan again.

bxche
11th August 2008, 10:12 PM
When I enter that command I get the following:

ath0: unknown interface: No such device
You have new mail in /var/spool/mail/root

scottro
11th August 2008, 10:23 PM
Hrrm, that's not good at all.

Ok, please do
modprobe ath_pci
again and then try the
ifconfig ath0 up

again.

bxche
11th August 2008, 10:32 PM
Still the same results for ifconfig ath0 up. However, I got new results for iwlist wlan0 scan. See attachment. Not on the Internet yet though.

bxche
11th August 2008, 10:43 PM
wlan0is picking up 3 access points but when I try to connect to my AP it fails and it never prompts me for the key. I am using WPA2 PSK.

Aside from the above thanks alot as progress has been made.

bxche
11th August 2008, 10:47 PM
I was able to connect to another AP in my neighborhood :). Is there known issue with connecting to WPA2 enable networks. Again thanks for your help.

scottro
11th August 2008, 10:49 PM
Something is still peculiar here, you should be getting ath0 rather than wlan0.

There shouldn't be an issue with WPA2. The only one I know of was when people would use ndiswrapper.

bxche
11th August 2008, 10:50 PM
I'm not sure what the problem issue but I cannot connect to my network. It connects to unsecure networks.

scottro
12th August 2008, 01:29 AM
Honestly, at this point, I'm a bit confused. It should be showing the ath0 card, not wlan0, and shouldn't have trouble connecting to encrypted networks.

About the only suggestion I can make is to try perhaps uninstalling, and using livna testing and seeing if you have better luck.
To do that, after doing the uninstall, which is outlined on my page, you would do
yum --enablerepo=livna-testing install madwifi

However, after that, I'm pretty much out of ideas.

bxche
12th August 2008, 09:58 PM
I un-installed then re-installed madwifi........... and still no luck connecting to a secure network. When I tried installing from livna-test I got the "No package madwifi available" and "Nothing to do" messages. I think I'll just purchase a wirless USB card from the Kismet approved list. Thanks

scottro
13th August 2008, 01:30 AM
It's very strange, and I'm sorry it's not working for you. The method on my page seems to work for everyone now. (Not that my method is so great, just that the drivers have improved since last year.)

If it were the 5006 card, it would have worked out of the box with the ath5k module. (I was thinking that perhaps I was wrong, as 242x can refer to a few different cards, but assumed it was the 5007 because it didn't work.)

I'm sorry that it didn't work, and thank you for your patience in continuing to try.

bxche
13th August 2008, 11:11 AM
Actually, before I decided to buy a new card I took my laptop over a friends house and connected to his secured WPA network. He mentioned that he recall that same issue and that I needed to reboot my wirless router. It sounds strange but I plan to try it later this evening. With that beind said, thanks for all your help as the card does work.

scottro
13th August 2008, 11:55 AM
My pleasure, and keep us posted. I do know that on occasion, I've had to reboot my router (although in that case, I didn't first check to see if unencrypted would work. )