PDA

View Full Version : Desktop icons disappeared



NewLinuxAddict
10th August 2008, 04:05 AM
I can't seen my desktop icons anymore. When I first login I see them for a second and then they disappear. Then when I move my mouse over them, they appear again and disappear almost instantly. The problem started after I installed gconf-editor and Gnome-Art-NG. I never changed anything in either program though. I've uninstalled both programs and the problem is still going, even after a reboot.

hellork
10th August 2008, 07:30 AM
Use your root account to create a new user. In Terminal:

su
system-config-users

Log out.

Log in as new user.

Presto!

Now you can copy or move important files in /home to your new user using cp. Nobody is going to encourage you to run nautilus or mc as root but people do that all the time too.

NewLinuxAddict
10th August 2008, 09:05 AM
Is that the only way of doing it? Is there any other methods that work, even if they're difficult or time consuming? Do you know what causes the problem and how to prevent it? Sorry for asking so many questions, I'm just trying to learn all I can and Goggle didn't help me much :(

hellork
12th August 2008, 08:54 AM
This isn't a fix. It's something to try to narrow things down. If new users are also affected, it means there is nothing wrong with your account and youu don't have to change anything in your home folder. This would narrow things down a bit, wouldn't you say?

The way we find out what's wrong is we cut the system in half. Then we see which half is misbehaving, then we cut that section in half and rule out more stuff. Finally we arrive at the exact thing that's wrong and we fix it. So are you going to start looking or do you want to wait until somebody else does all the work for you?

I'm sorry I can't be of much help. I don't use gnome anymore since xfce is so much faster! :)

NewLinuxAddict
12th August 2008, 11:59 AM
I created the other account and the icons were just fine.

Sorry about my post before, I thought making a new account and re-doing all my settings again was the only thing to do.

Do you think it's possible that gconf-editor caused it somehow?

hellork
12th August 2008, 09:21 PM
Yes, there are some tools, such as diff that can spot the changes between the two users configuration files if you are curious about the exact cause. I haven't experienced this problem but I'm sure somebody else might find the information handy if they experience the same issue later.

In the past, I've used the root account to rename my original /home/user folder, deleted everything in /tmp for that user, removed the old user completely and re-created it, making sure to give the same UID (500) and GID (500) as the original. Then I logged into the fresh new account and back out (to update the folders) and then I started copying the hidden folders back one at a time until it broke again. Then I knew exactly which folder was the problem. (Yeah probably .gconf) then it was a matter of running diff on the configuration files in the offending folder.

NewLinuxAddict
13th August 2008, 01:28 AM
I was going to re-create my original user like you said and when I tried to log in to the second user I got a window saying "The GNOME session manager was unable to read the file: '/home/my_user_name/.ICEauthority'. If this file exists it must be readable by you for GNOME to work properly. Try logging in with the failsafe session and removing this file." I don't get the message for my original account though. I also noticed that only have one workspace on my original account, I think that pretty much narrows it down to something in my .gconf

Edit: When I launched Compiz-Fusion my workspaces appeared, but still no icons.

juanfgs
13th August 2008, 01:58 AM
Does Nautilus run?, if not, you can try removing your user's /tmp files and your gconfd saved state (~/.gconfd),
If after that it still doesn't work, delete your nautilus entries on .gconf (and repeat the previous step again.)

NewLinuxAddict
13th August 2008, 08:50 AM
I believe it's something with nautilus. I typed in...


su -
nautilus

...to my terminal and my icons appeared. However, everything was reset (icons back to default image, wallpaper back to default) After I closed the terminal window the icons dissappered again.

Update: I noticed that my new user account didn't have a folder named "desktop" in it's nautilus folder so I deleted the folder from my main account and everything seems to be just fine now. I will post back if I find anything else.

Update 2: After rebooting I'm faced with the same problem, except this time typing nautilus in terminal isn't fixing anything.

leigh123linux
13th August 2008, 09:12 AM
Try



su
yum install gtweakui


Then as non root ( or use the menu launcher ! )


gtweakui-nautilus


and uncheck the " use nautilus to draw desktop " box then re-check it to restart it ! ( or you could kill the nautilus process in gnome-system-monitor , it will restart automatically )

NewLinuxAddict
13th August 2008, 09:37 AM
Using gTweakUI - Nautilus worked. It made Conky disappear, but my icons are back.

I went in terminal and typed in conky to make it appear again, my icons once again disappeared.

leigh123linux
13th August 2008, 09:58 AM
Using gTweakUI - Nautilus worked. It made Conky disappear, but my icons are back.

I went in terminal and typed in conky to make it appear again, my icons once again disappeared.


Conky will make the icons disappear , I believe there in a conky config file option that will make them reappear .

I think this is the option !


# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

NewLinuxAddict
13th August 2008, 10:49 AM
I have the double buffer option set to yes, and have actually had it to yes since I got conky. I don't see any other options that might fix it. =/

Everything was fine with my system until I installed Gnome Art NG and Gconf-Editor. I never changed anything in gconf-editor though. Never did anything with Gnome Art either. I had Compiz-Fusion, Screenlets, and Conky running perfectly together.

NewLinuxAddict
14th August 2008, 09:55 AM
I checked Conky's website and seen all the different variables, I didn't find one for icons :(

I decided to remove Conky from the list of start up programs and my icons remained invisible until I used gTweakUI. Is there any way to remove nautilus and reinstall it? Or is there something else I should try?

chepioq
15th August 2008, 05:58 AM
to see your icons with conky you must have your conky in own window:
In my conkyrc I have:
background no
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Try this...

NewLinuxAddict
15th August 2008, 11:10 AM
to see your icons with conky you must have your conky in own window:
In my conkyrc I have:
background no
own_window yes
own_window_type normal
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

Try this...
THANK YOU!!!!!!!!!!!!!!!!!!!!!!! I had actually just changed "own_window to no just to see if maybe that would help. When it didn't, I disabled Conky completely. Everything is back to working normally. Thanks everyone.