PDA

View Full Version : Sound suddenly stopped working



plutus
9th August 2008, 12:52 AM
I'm running Fedora 8 x86_64 (2.6.25.11-60.fc8) with onboard sound Audio Chipset ADI AD1988B, Audio Channels 8 with Logitech X-540 70W 5.1 Surround Sound Speakers.

I hooked them up a few days ago with no problems. Everything is working fine. Then today a game (Assault Cube) froze and I rebooted then the sound stopped working.

If I go to System->Administration->Soundcard Detection and test the sound using AD198x Analog as the PCM device I can hear music. If I change it to AD198x Digital I hear nothing. XMMS doesn't play sound unless I switch it to OSS Driver.

PulseAudio, g-streamer and ALSA is all installed. Like I said everything has been working perfectly until the game froze.

Any thoughts?

plutus
9th August 2008, 02:38 AM
I've tried a few things for other posts I've seen and its still not working. This is pretty odd.

joe.pelayo
9th August 2008, 03:19 AM
I've tried a few things for other posts I've seen and its still not working. This is pretty odd.
How long do you have with that kernel? Did you install it about the same time the game?

Just today I had to switch over to F8 x86 because in F8 x86_64 that very kernel gave me some problems. Try booting in the other kernel (previous) to see if your problem persists.

Thanks.
Joe.

plutus
9th August 2008, 03:26 AM
I've had this kernel for awhile now without any problems and the game for the last three kernels. The sound is dead on everything not just the game.

Also I had this kernel when I setup everything so its been working. Its probably not related to the game thats just what happened at the time.

Same problem with the previous kernel and under different users, tested earlier today.

Demz
9th August 2008, 03:39 AM
so have you tried disabling Pulseaudio? an just using Alsa only?

plutus
9th August 2008, 03:47 AM
so have you tried disabling Pulseaudio? an just using Alsa only?

How do you go about that? I'm still pretty wet behind the ears here

plutus
10th August 2008, 01:26 AM
Here's some more information...

# cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfe020000 irq 20


# aplay -L
default:CARD=NVidia
HDA NVidia, AD198x Digital
Default Audio Device
front:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
Front speakers
surround40:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
HDA NVidia, AD198x Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
HDA NVidia, AD198x Digital
IEC958 (S/PDIF) Digital Audio Output
null
Discard all samples (playback) or generate zero samples (capture)


# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.16rc2 (Thu Jan 31 16:40:16 2008 UTC).


# cat /etc/asound.conf
#Generated by system-config-soundcard
#If you edit this file, don't run system-config-soundcard,
#all your changes here could be lost.
#SWCONF
#DEV 1
defaults.pcm.card 0
defaults.pcm.device 1
defaults.ctl.card 0


# lsmod |grep snd
snd_usb_audio 97345 0
snd_usb_lib 24129 1 snd_usb_audio
snd_rawmidi 29249 1 snd_usb_lib
snd_hda_intel 429177 4
snd_seq_dummy 11589 0
snd_seq_oss 38081 0
snd_seq_midi_event 15297 1 snd_seq_oss
snd_seq 58273 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 15189 4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 46657 0
snd_mixer_oss 22977 2 snd_pcm_oss
snd_pcm 79561 3 snd_usb_audio,snd_hda_intel,snd_pcm_oss
snd_timer 28625 2 snd_seq,snd_pcm
snd_page_alloc 16593 2 snd_hda_intel,snd_pcm
snd_hwdep 16329 2 snd_usb_audio,snd_hda_intel
snd 62217 17 snd_usb_audio,snd_rawmidi,snd_hda_intel,snd_seq_os s,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss ,snd_pcm,snd_timer,snd_hwdep
soundcore 15073 2 snd

Demz
10th August 2008, 02:57 AM
How do you go about that? I'm still pretty wet behind the ears here
Have you looked in, by going to

System > Administration > Hardware > i think

Sessions > Startup Tab

plutus
10th August 2008, 07:27 AM
Well, I uninstalled PulseAudio along with a few other things and that didn't seem to make a difference. I also made some changes to a few config files. With out any differences.

HOWEVER, System->Preferences->Sound I changed all playback to OSS driver and now I have sound for everything.

Demz
10th August 2008, 07:33 AM
http://www.informit.com/guides/content.aspx?g=linux&seqNum=184 ... i dont know if modprobing your soundcard again would help