View Full Version : Fedora 10 Alpha i686 Live CD, initial thoughts (with pics)

6th August 2008, 11:17 PM
Tried Fedora-10-Alpha-i686-Live.iso on 5 different PCs. It's got the expected teething problems but results were mostly good. I also ran it through qemu-kvm and it works almost flawlessly.

sudo qemu-kvm -m 512 -cdrom /mnt/data/ISOs/Fedora-10-Alpha-i686-Live.iso &

The first thing nearly everyone will notice is the graphical boot not working, you'll probably see something like this:


Pressing escape will give you the usual text boot, with a nice new blue colour scheme (Fedora is a very "blue themed" distro after all) EDIT oops, sorry, the blue text was just a quirk of the vesa mode I selected.


To see the proper graphical boot screen, press tab to change the boot options and add 'vga=ask' as a parameter, then select a suitable VESA mode, it looks like this


The login screen now looks like this, it has a mysteriously redundant Keyboard selector (there is nothing to select!)


And annoyingly, like F9, the system-config-keyboard applet is no longer in the Sytem->Admistration menu, so you have to launch it from a terminal. For UK keyboard users this will become a pain doing it every time you boot up the LiveCD. Changing the keyboard still generates an selinux message in setroubleshoot, as it did in F9 (and F8 iirc), but the change does get applied.

On the subject of selinux on the LiveCD, why is it there? If you start 'top' and press G 3, you'll see /usr/bin/sealert is one of the big memory hogs at initial login. Is it really needed in a lIve environment? Selinux also causes glxgears to fail to run even when direct rendering is enabled.

The content of the LiveCD hasn't changed much from F9. Gnumeric has been removed, and the Cheese webcam app has been added, which is neat for taking pics of yourself.

A rather handy thesaurus has been added to accompany the dictionary (although the dictionary still requires internet access to work, which is a little disappointing:


The LiveCD boots up fine (from a usb stick) on a Toshiba Equium A100 laptop, Asus Eeepc 701 and Dell Inspiron 1520. It fails to boot on an Asus A8V based desktop PC with ATI Radeon 800 Pro graphics. On the Toshiba, everything works as expected, incl direct rendering compiz, audio and the internal wifi, which is pretty impressive for an alpha release. EDIT forgot the 5th PC, a VIA KT3 Ultra 2 based desktop with Radeon 9600 graphics - this boots ok, although a kernel error is displayed, but everything seems to work ok (incl direct rendering), this is the only machine that runs glxgears without selinux error, which is a bit weird. Unfortunately the usb interface is 1.1 so it's pretty damn slow!

Just a couple of gripes to finish with

1. Touchpad tapping doesn't work again (as in F9), and there's no default /etc/X11/xorg.conf to edit to enable it, so you have to create a default one either using system-config-display or just have a copy on the free space on the usb disk, then restart the xserver with ctrl-alt-backspace. I really think this must be "fixed" in the LIveCD at least.

2. No Gparted in System Tools, but there is a rather useless 'Disk Management' app which throws the same authorisation error it did in F9

6th August 2008, 11:27 PM

Good review. Make sure issues are reported in http://bugzilla.redhat.com. There is a large number of users using the live cd as a installation method so the environment including SELinux is kept the same as the regular installation images for consistency.

6th August 2008, 11:36 PM

Good review. Make sure issues are reported in http://bugzilla.redhat.com. There is a large number of users using the live cd as a installation method so the environment including SELinux is kept the same as the regular installation images for consistency.

Cheers, I will try to post to bugzilla.

re selinux, I understand the packages need to be there in case of an install to hardisk, but does selinux need to be enforcing by default while in a Live session, I would have thought permissive mode would be a more suitable default.

6th August 2008, 11:46 PM

The live cd is a demonstration of the experience of Fedora and it is good to have the same consistent environment whether you have installed it or not. Also, in the alpha/beta releases, the live cd's are a quick way to test something without necessarily installing it anywhere and if there are SELinux issues, developers would want to hear about that. More exposure helps.

6th August 2008, 11:54 PM
Ok cool, I recall Jeremy Katz saying this had been discussed so I guess there isn't much point bringing up the issue again, but system-config-selinux does seem to take ages to start in this release (to disable it), hopefully that will improve. I'll try to post a specific bugzilla relating to the glxgears segfault and selinux error, and the system-config-keyboard selinux message.

7th August 2008, 03:11 AM
Y'know the funny thing--as I hadn't seen mention about that blue bar (sideways' initial picture) on the testing mailing list, I thought it was by design, an attempt to emulate Ubuntu's boot screen. I didn't realize it was simply a minor bug, that is apparently not that common (since, as mentioned, I haven't seen anyone else talk about it on fedora-testing.)

7th August 2008, 03:21 AM
i dont like the Newer GDM, its getting worse not better

7th August 2008, 08:35 PM

If you have specific complaints, you should file a bug report at http://bugzilla.redhat.com. I am not sure simply stating a preference that you dont like something helps.

8th August 2008, 03:17 AM
As far as the blue scrolling bar,

I've made the change from the first post and can't seem to get any of the VESA options to make any difference in how it boots.

8th August 2008, 04:15 AM

Worked just fine for me but YMMV.