PDA

View Full Version : DVD drive read Fedora 9



marcosaluzzo
4th August 2008, 10:13 AM
Hi there,

I may be missing something obvious, but when I load a CD or DVD in to the DVD drive how can I read the information on the disk. I've checked in the media folder and there is nothing. I have tried with music CDs, data CDs and DVDs. Every time nothing. What I am doing wrong?

The DVD drive works from the BIOS because I installed Fedora 9 x64 from the installation DVD.

Thanks, Marco
--
p.s. I found an identical question on the forum but there weren't any replies. :(

LDC
4th August 2008, 07:32 PM
did you try to manually mount the device?

marcosaluzzo
5th August 2008, 07:33 AM
Thanks LDC for your reply. I'm a Linux newbie so coming from windows I assumed that it would automatically pick up the cd-rom drive.

I found a command to mount the drive on another forum

su -c 'mount /media/cdrom0/ -o unhide'

I got the following message:

mount: can't find /media/cdrom0/ in /etc/fstab or /etc/mtab

This is my fstab file:


/dev/main_group/root / ext3 defaults 1 1
/dev/main_group/music /music ext3 defaults 1 2
/dev/main_group/various /var ext3 defaults 1 2
/dev/mapper/luks-main_group-private /private ext3 defaults 1 2
/dev/main_group/temp /tmp ext3 defaults 1 2
/dev/main_group/LogVol00 /home ext3 defaults 1 2
/dev/main_group/work /work ext3 defaults 1 2
/dev/main_group/user /user ext3 defaults 1 2
/dev/main_group/user_local /user/local ext3 defaults 1 2
UUID=5f8cfb96-1c77-45ed-8f55-9704183297b3 /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=2985b9b4-d1f2-4e4e-9ad4-6c81a08eebe3 swap swap defaults 0 0


This is my mtab file:


/dev/mapper/main_group-root / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/mapper/main_group-music /music ext3 rw 0 0
/dev/mapper/main_group-various /var ext3 rw 0 0
/dev/mapper/luks-main_group-private /private ext3 rw 0 0
/dev/mapper/main_group-temp /tmp ext3 rw 0 0
/dev/mapper/main_group-LogVol00 /home ext3 rw 0 0
/dev/mapper/main_group-work /work ext3 rw 0 0
/dev/mapper/main_group-user /user ext3 rw 0 0
/dev/mapper/main_group-user_local /user/local ext3 rw 0 0
/dev/sda1 /boot ext3 rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
gvfs-fuse-daemon /home/james/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=james 0 0
/dev/sdb1 /media/VERBATIM vfat rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=50 0 0 0
/dev/sdc1 /media/PHILIPS vfat rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=50 0 0 0


I presume there should be an entry for the cd/dvd-rom? Any help to rectify this would be most appreciated. thanks

Wayne
5th August 2008, 07:54 AM
Music CDs don't contain data in the normal sense, so they cannot be browsed. What should happen though, is your preferred music player should start, if you have that option enabled in Media preferences. CD/DVD drives do not have an entry in fstab as they are normally automounted when inserted. I think your CD/DVD drive is /dev/sr0 (mine is)

Check your media preferences by opening Nautilus, then opening 'Preferences' and going to the 'Media' tab..

PS. Before you can mount a drive from a Terminal, you must first create the mount point under /media or /mnt with mkdir

Wayne

LDC
5th August 2008, 11:18 AM
I presume there should be an entry for the cd/dvd-rom? Any help to rectify this would be most appreciated. thanks
I think Wayne is right, your optical disk player should be device sr0, but you can do better than guessing, just ask linux:


dmesg |grep cdda

the first value on the left will be the location of your device. For example, if I do that this is the result:


[ldc@solomon ~]$ dmesg |grep cdda
sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray

as you can see, mine too is sr0 :)

just as side note, you can also verify that the symbolic link is correct by looking into /dev/ and finding the link "cdrom", then watching its properties:

(under /dev/)


[root@solomon dev]# ls -l cdrom
lrwxrwxrwx 1 root root 3 2008-08-05 11:33 cdrom -> sr0


you will see two colors: "cdrom" in green (which means it is a symbolic link), and "sr0" in yellow (a device).

then, you have to create a mount point for your device into /media (but for cdrom/dvdrom, commonly, is not needed....in your case maybe can help solve your issue).

as root:

mkdir cdrom

then insert the disc and manually mount it:


mount /dev/sr0 /media/cdrom

it should work.

then: man man, man mount, man umount. man mkdir, and so on :)

marcosaluzzo
5th August 2008, 11:40 AM
Cheers for your replies

Ok i tried the suggestion:

[james@fedoraserver ~]$ dmesg |grep cdda
[james@fedoraserver ~]$

as you can see there is no print out like yours

i also tried

[root@fedoraserver ~]# ls -l cdrom
ls: cannot access cdrom: No such file or directory

what does this mean? thanks

LDC
5th August 2008, 11:52 AM
mh.. try


dmesg |grep tray

and btw you MUST be in the /dev/ directory (as stated before) when trying


ls -l cdrom

an important question: was it a fresh install or you "upgraded" from something else?

oneofmany
5th August 2008, 12:14 PM
mh.. try


dmesg |grep tray

and btw you MUST be in the /dev/ directory (as stated before) when trying


ls -l cdrom

an important question: was it a fresh install or you "upgraded" from something else?

i think you need to be logged on as root too.

try..



su -


if you have linked the device to /dev/cdrom you can also mount more simply just with..



mount /dev/cdrom


remember, the mount may fail if the device is already auto-mounted by gnome, kde, etc :)

LDC
5th August 2008, 12:52 PM
both "ls -l" and "dmesg" works fine as just user :)

oneofmany
5th August 2008, 12:56 PM
agreed with the ls -l; i was referring to dmesg. i have had a number of system where that returns nothing unless i have root permissions, via su :)

LDC
5th August 2008, 12:58 PM
agreed with the ls -l; i was referring to dmesg. i have had a number of system where that returns nothing unless i have root permissions, via su :)
well, trying costs nothing :) on my linbox it works fine as user, but maybe other distros put some restriction...

marcosaluzzo
5th August 2008, 01:47 PM
Thanks for all the commnets.

I have tried 'dmesg |grep tray' and 'dmesg |grep cdda' and both give the same result:

[root@fedoraserver ~]# dmesg |grep tray
[root@fedoraserver ~]#

also

[root@fedoraserver dev]# ls -l cdrom ls: cannot access cdrom: No such file or directory

FYI I've clean installed Fedora 9 x64 on a new box with the following specs:
M/B: Intel S.775 -1600Mhz Asus P5K SE/EPU Chipset Intel P35
Processor: Intel Core 2 Q6600 Quad Core 64bit 2.4Ghz
Video: Nvidia EN 8800 GT 512MB
DVD: LG LightScribe GSA-H55L Dual Layer DVD writer Secur Disk
HD: Maxtor 1 TeraByte SATA2

oneofmany
5th August 2008, 02:06 PM
if i recall correctly, /dev/cdrom is a link so it might not be there, though i forget which device it links to exactly.

i seem to recall that dmesg never shows my dvd drive unless i have a dvd in the drive and i have seen some systems, though not fedora, where the dvd was treated as /dev/hd?

LDC
5th August 2008, 04:39 PM
mh, then try a dry "dmesg" and post all the report...

btw: it is VERY weird, I think something is wrong. Why you don't try the i386 version and see if get the same issues?

marcosaluzzo
5th August 2008, 05:10 PM
I get a huge print out for dmesg. Too long for the forum; more than 26000 characters!! I can only post 10000. Do you want me to break it up or is there something specific I should look for.

LDC
5th August 2008, 05:14 PM
you can just zip it and attach here...

marcosaluzzo
5th August 2008, 08:19 PM
Okay dmesg attached. Cheers

LDC
5th August 2008, 09:17 PM
there is no trace at all of any media optical device.... also, I found some weird thing that I don't know such as

atl1 0000:02:00.0: hw csum wrong, pkt_flag:1600, err_flag:80

ata*: SATA link down (SStatus 0 SControl 300)

btw, no wonder your dvd drive doesn't work: it is not under the hardware detected.....

try formatting and using i386 instead of x64bit

oneofmany
5th August 2008, 09:36 PM
there is no trace at all of any media optical device.... also, I found some weird thing that I don't know such as

atl1 0000:02:00.0: hw csum wrong, pkt_flag:1600, err_flag:80

ata*: SATA link down (SStatus 0 SControl 300)

btw, no wonder your dvd drive doesn't work: it is not under the hardware detected.....

try formatting and using i386 instead of x64bit

my dvd drives to not appear in dmesg unless i insert a dvd or cd

marcosaluzzo
6th August 2008, 07:19 AM
When I ran the dmesg command there was a DVD disk in the driver.

I really don't want to reformat my OS. I have spent so much time getting my computer configured I think I would cry if I had to restart over again.

Does any one have bright ideas for trying to recover the current situation? Thanks

LDC
6th August 2008, 11:00 AM
that make me smile :) come on, have you a slight idea of how many times I did format my fedora box in order to learn/have it working??? :D
don't give up, that is the special flavour of fedora: if you don't like to tinker, maybe fedora is not the right distro for you (and since you says you are starting with linux, maybe a tour with Linux Mint can be enlightening...).

jcliburn
7th August 2008, 02:11 AM
atl1 0000:02:00.0: hw csum wrong, pkt_flag:1600, err_flag:80

This message is from your ethernet device driver. The Attansic L1 NIC hardware has a bug that incorrectly flags IP fragments as errors. The hw csum message you see in your logs is generally harmless, but the condition can slow things down a bit if you're getting a lot of IP fragmentation.

You can usually get rid of IP fragmentation altogether by adjusting your MTU size from 1500 down to some lower value, like 1472, but that number varies according to the device that connects you to the internet. Google "change MTU size" for instructions on how to to precisely determine the MTU size you need. Once you figure out the correct number, you can modify your network settings to permanently set the MTU size to the new number.

A patch has been submitted to the kernel to handle the L1 hardware bug, so you shouldn't see the annoying hw csum message in future kernels.

Cheers,
Jay

De Baimbo
8th August 2008, 11:51 AM
Marcosaluzzo, just try this: put an AUDIO CD in and tell us what happens.

marcosaluzzo
11th August 2008, 08:34 AM
Thanks everyone for there replies. I have no problems tinkering to get my Fedora package working correctly. In fact I have tinkered already a lot to get it working, so I don't want to reformat now.

I followed De Bimbo suggesting and inserted and Audio CD. You can here the drive whirring but nothing shows up on Fedora. I checked the media folder and desktop.

I have attached the dmesg file after I have inserted my CD disc.

marcosaluzzo
11th August 2008, 09:20 PM
I've just been looking on other forums. In the folder 'mnt' there are no other directories. Should I create one manually such as 'cdrom' or 'dvdrom'?

marcosaluzzo
12th August 2008, 02:08 PM
After reading some other forum I've manually created two directories /mnt/cdrom and mnt/dvdrom. I tried adding /dev/hdc /mnt/dvdrom udf,iso9660 noauto,users,dev,ro 0 0
/dev/hdd /mnt/cdrom udf,iso9660 noauto,users,dev,ro 0 0

to the static part of the fstab file. I have tried adding a DVD disk and CD disk and mounting the drive, but the drive is still not showing in the /dev folder. In another forum they suggested editing the udev rules file. I'm currently experimenting and will let you know how I get on.

marcosaluzzo
14th August 2008, 08:51 AM
For any of you that are have problems detecting your DVD or hard drive in Fedora then I found the solution in http://fedoraforum.org/forum/showthread.php?t=192425

wt6g
9th September 2008, 06:09 AM
There is something really broken with Fedora 9 and CD/DVD devices. I just put two DVD drives into my system on the IDE interface to replace the single sata drive that was in there. Suddenly no optical drives are visible.

I boot Windows XP and everything works and looks like it should. I've got two IDE optical drives, I can use them both and I've got a single SATA drive. CMOS seems to list the drives just fine at boot.

Reboot, attempting to load Fedora and no more optical drives.

/Len
WT6G

wt6g
9th September 2008, 02:17 PM
Just did a fresh install of FC9, in case the drive changes made a difference. Fedora still does not show the DVD drives (even though it just installed from one of them) and Windows XP continues to dual boot on the same hardware and uses the drives without issue, complaint, or failure.

I've read the forums for hours and this problem seems to be well identified but no solutions appear to be forthcoming. About the only thing that seems to be common is:

If you have SATA Hard Drives on your system and IDE CD/DVD Drives, it is very likely that you will be unable to use your DVD Drives with FC9 once you install it. If you have SATA DVD Drives they will work with FC9, but there may be some issues with multiple optical drives that are SATA (ie more than 1 not 3 or 4).

A lot of the hardware shipping these days is set up for IDE/SATA and most of the early high performance Vista systems were configured this way.

I've seen some discussion that changing the kernel driver load order has helped some users, but it appears to apply only to some users.

/Len
WT6G

PS I also tried running 2 ide DVD drives with Windows XP and 2 SATA optical drives at the same time and this failed.

wt6g
10th September 2008, 01:55 PM
There is a problem with initrd in fedora 9. If your hard drives are sata and your cd drives are pata or ide drives then fedora 9 will load the sata driver first and this obliterates its ability to see the ide drives. This problem seems to come and go with fedora distributions for some reason.

There is a post somewhere on how to solve it, but it's pretty obscure. I'm working on the problem today myself and hope to make a specific positing when I get it to work.

Apparently if you load the driver for the ide drives first the problem is solved. Of course fixing the driver once and for all would be the ultimate solution, but that's currently beyond my level of expertise with linux.

/Len
WT6G