PDA

View Full Version : FC9 install, ? Mainboard & Graphics Card Driver problem



zmdmw52
3rd August 2008, 06:51 AM
I have Windows XP & FC9 Linux on separate partitions, with option to choose which OS to boot through the BIOS, by pressing the F12 key during boot).

The FC9 install (done with a boot FC9 DVD) itself went smoothly. After re-booting, I got the Fedora OS selector screen and booted into that, but then there was a display problem (use a 17" LG Flatron L177WSB Monitor) and the screen went blank with Error Message (provided by LCD firmware) stating: 'Refresh rate out of range" with a Vertical Refresh Rate displayed of 77.5 MHz). So, I re-booted, went into BIOS and chose the on-board VGA as the graphics display.
But got the same Error Message ("Out of range" or something similar) with the on-board display selected. (Can boot into Windows XP successfully).

(System Hardware Specs are at the end of this post).

What could be wrong? I think Fedora 9 would not have got the drivers on-board/during install for the Graphics Card or the Motherboard/On-board VGA. How can one troubleshoot this?
In this case: how to install the mainboard drivers (if required ? for this chipset 610i) OR/AND graphics card (GeForce 8400GS) drivers? I don't have a Net connection, so pl let me know in some detail how to boot into command prompt & install the drives from command prompt using CD.

===
Hardware details:
CPU: Pent 4 640 (3.20 GHz) (Socket 775LGA)

Mainboard: Gigabyte GA-73VM-S2 Mainboard (http://www.gigabyte.com.tw/Products/Motherboard/Products_Spec.aspx?ClassValue=Motherboard&ProductID=2714&ProductName=GA-73VM-S2) (nForce 610i chipset)

PCI-E Graphics Card: XFX GeForce 8400GS (http://www.xfxforce.com/en-gb/products/graphiccards/8series/8400GS.aspx#2) (512 MB)

On-board Graphics: GeForce 7050 (specs as in Mainboard link above)

RAM (Memory): 2 GB DDR2 at 667 MHz

OS (on 250 GB IDE (Master) HDD): Win XP Prof SP3
===

Guidance greatly appreciated.

Edit:
Could boot into a working desktop at a lower res of 1024 X 768 with the FC8 Live CD (default res of 17" LCD monitor is 1440 X 900). But did not install FC8, instead installed openSUSE 11.0 successfully (booted into gnome desktop).

Skunk Worx
3rd August 2008, 07:11 AM
Sometimes you can find the frequency limits for your display on the web, or in the display manual, then create a default /etc/X11/xorg.conf file, and set the limits there :

For example :

Section "Monitor"
Identifier "MyMonitor"
HorizSync XX-XX
VertRefresh YY-YY
EndSection

...where the XX-XX and YY-YY are the manufacturer's limits for your monitor.

I think X is exceeding your display limits. I see this on KVMs once in awhile and do as I suggested above.

If you don't have a /etc/X11/xorg.conf file you might need to generate one from the command line with the "system-config-display" command.

Do you know how to boot into single user mode and change the default runlevel? When the grub menu comes up, stop it there and add the "single" option to the kernel boot line. Then boot, and change your /etc/inittab file to runlevel 3 (the default is 5). Then 'exit'.

If you do this you won't need a CD and can log in from the CLI.

From the command line you can start X (for testing) using the 'startx' command and then the key sequence 'ctrl-alt-backspace' to kill X (if the freq. is still out of range).

After you get X working change /etc/inittab back to 5 to switch back to graphical logins.