PDA

View Full Version : Problems starting httpd FC2



desipher
23rd July 2004, 11:15 AM
Having problems getting httpd to start. Error message I'm getting is "Starting httpd: (98)Address already in use: make_sock: could not bind to address 10.0.0.2:80
no listening sockets available, shutting down
Unable to open logs". Checked there are no applications running on port 80. Any suggestions?

fjleal
23rd July 2004, 11:52 AM
Did you try "nmap localhost" to check your ports? It really looks like your port 80 isn't free...

desipher
23rd July 2004, 12:18 PM
I tried tethereal and nothing listening on port 80.

crackers
23rd July 2004, 04:26 PM
Are you running the startup script, or are you trying to manually start "httpd?" If the latter, accessing ports below 1024 requires root privileges, which is why that port may appear to be blocked. I'd suggest using the startup script (/etc/rc.d/init.d/httpd) as root to start/stop the server.

desipher
23rd July 2004, 04:55 PM
Yeah I manuel start up the server and still fails. Whenever I lookup the error message online it most general says because you have 2 servers running on 1 machine but in my case I can't get I server up. I'm at lose right now.

crackers
23rd July 2004, 05:40 PM
You have to start the server as root - "normal" users cannot access port 80. This can appear to be a "port already in use." And starting it manually isn't that good an idea: the system init script has run/stop/restart (and some other) options to control the server easier.

desipher
24th July 2004, 03:27 AM
Yeah I'm starting it as root and I starting the server from init.d dir. I double checked the config and I ran port scanners on that machine and nothing is open on port 80. I can't even telent as localhost on port 80. So I'm thinking there is something blocking port 80 and I did turn off iptable filters.

desipher
24th July 2004, 10:10 AM
I fixed it. In my httpd.conf file there option listen and Servername. I had both of them filled out so when I ran the script it tried to run the server twice. I committed out the listen server and port and lefter servername and port.


-d