PDA

View Full Version : GCC_4.2.0 not found



brekehan
1st August 2008, 09:24 AM
I went through the very long process of intalling Maya 6 on my fresh Fedora 9 and attempting to get it to work.

I am stuck at
/usr/aw/maya6.0/lib/libgcc_s.so.1: version 'GCC_4.2.0' not found (reuqired by /usr/lib/libstdc++.so.6)

I try yum install gcc
and it says already installed

I tryed yum install libgcc_s.so.1
and it says latest version installed

How can I satisy this error?

Be gentle, I am a linux newbie.

pete_1967
1st August 2008, 09:45 AM
gcc -v
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-cpu=generic --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC)


If it requires v4.2.0 you need to install older version of gcc that comes with F9.

Check their support first.

RobertoVanto
1st August 2008, 09:45 AM
Have you tried with yum install libgcc-4.3.0-8?

brekehan
1st August 2008, 09:55 AM
Now I just get a segmentation fault.
Its been 6 hours, perhaps this will be a fruitless endeavor. :(

virus
1st August 2008, 10:47 PM
Have you tried with yum install libgcc-4.3.0-8?
if the application requires gcc 4.2 , the gcc 4.2 must be installed.
:)

marko
2nd August 2008, 03:38 AM
That's an expensive commercial product, why don't they (autodesk) help?
Are you trying the free "Personal Learning" edition?

RobertoVanto
2nd August 2008, 04:22 AM
I am stuck at
/usr/aw/maya6.0/lib/libgcc_s.so.1: version 'GCC_4.2.0' not found (reuqired by /usr/lib/libstdc++.so.6)

mv /usr/aw/maya6.0/lib/libgcc_s.so.1{,.bak}
cp /lib/libgcc_s.so.1 /usr/aw/maya6.0/lib/libgcc_s.so.1

briantan
2nd August 2008, 04:44 AM
brekehan, are you still trying to compile the libraries, or you've installed all libraries via yum? (following thread below)

http://forums.fedoraforum.org/forum/showthread.php?p=1056383

Please feedback.