PDA

View Full Version : external hdd problem



ronan.l.n
31st July 2008, 03:19 AM
Hi,
I am using an external hard drive disk on my laptop (Fedora 8) to keep a clean system in case of emergency. I tried to install Mandrake 2008 from the live cd on this disk, but I think the installation crashed at the partitioning step.
Since then, when I insert the drive in both Windows and Fedora, it is impossible to see its content.
A new device /dev/sdc appears (I only have one disk on my system, why is sdb still present ?), but it is not mounted.
Also, gparted live cd doesnt show the device and parted and hexdump don't give any output.
fdisk /dev/sdc returns "unable to read /dev/sdc"

Has anyone got any idea on how I can recover the disk ?
Thanks,

Ronan

oneofmany
31st July 2008, 09:13 AM
at a guess i'd say the partitions were created but not formatted so there's nothing to mount

ronan.l.n
31st July 2008, 10:56 AM
How can I format the disk again then, I can't access it and it is not offered in th list of available disks during the installation.

oneofmany
31st July 2008, 10:58 AM
if the new device appears as sdc you should try fdisk and mkfs on it.

ronan.l.n
2nd August 2008, 12:34 PM
Here are the two outputs I get :

fdisk /dev/sdc

Unable to read /dev/sdc
----------------------------------------
mkfs /dev/sdc
mke2fs 1.40.4 (31-Dec-2007)
/dev/sdc is entire device, not just one partition!
Proceed anyway? (y,n) y
mkfs.ext2: Device size reported to be zero. Invalid partition specified, or
partition table wasn't reread after running fdisk, due to
a modified partition being busy and in use. You may need to reboot
to re-read your partition table.

Can it be helped ?

oneofmany
3rd August 2008, 09:39 PM
hmmm, i suspect your only other option here is a low level format of the disk and start again or try using something like partition magic or partition dr in order to attempt to restore the previous partition

ronan.l.n
4th August 2008, 02:05 AM
I tried using Gparted, but the disk doesn't appear in the device list. And how can I format at low level ?
Thanks for your help

ryptyde
4th August 2008, 03:39 AM
If you have "disk tools" that may have came with your hard drive you can probably use them to
recover your disk. Another option would be to download "Dariks Boot and Nuke" DBAN to wipe the drive and then reformat it.

If you don't have the manufacturers disc for the drive you can get it from their site and also those tools are included on liveCDs like INSERT or other recovery cd's out there. :)

EDIT: System Rescue CD has tools on it too!

ronan.l.n
5th August 2008, 05:18 PM
On one of my computers, the usb disk is not recognised by DBAN and on another one I'm told that DBAN has finished without fatal error, even before being offered the choice of which disk to wipe.
I have SystemRescueCD, but not sure how to wipe the disk with it, can you help, what are the useful commands ?