PDA

View Full Version : Fedora8, iwl4965 & wireless issues after latest kernel and iwl firmware



psweitzer
30th July 2008, 05:26 PM
I am hoping someone else has seen this issue in the last little while...

I installed some YUM updates yesterday morning and since then I cannot connect to my wireless network @ work which uses LEAP auth. I am still able to connect to my home network which uses WEP.

I have had a rough time with NetworkManager, LEAP, and hidden SSIDs over the past year... It has only been in the last few months that there has been some relief and things started working *normally*. Before that I would have to manually run some iwconfig commands during the NetworkManager init to get it to associate properly... :cool:

Yesterday I was able to boot into my old kernel and use wireless for a little while but that seems to have stopped working as well. I also tried manually copying an older version of the iwl4965 firmware into /lib/firmware but this too had no effect.

From what I can tell all modules are loading properly and iwlist shows me 8 different cells from my desk...

Any help/suggestions would be greatly appreciated as I HATE having to constantly plug in as I travel around my building... :(

Pertinent lines from my YUM log :


Jul 29 08:46:47 Installed: kernel-devel - 2.6.25.11-60.fc8.i686
Jul 29 08:46:51 Updated: kernel-headers - 2.6.25.11-60.fc8.i386
Jul 29 08:46:53 Updated: iwl4965-firmware - 228.57.2.21-1.noarch



Output from messages while trying to connect :


Jul 30 10:50:22 SHAD0W NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jul 30 10:50:22 SHAD0W NetworkManager: <info> (wlan0): device state change: 4 -> 5
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Activation (wlan0/wireless): connection 'Auto IBM' has security, and secrets exist. No new secrets needed.
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'ssid' value 'mySSID'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'scan_ssid' value '1'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'key_mgmt' value 'WPA-EAP'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'proto' value 'WPA RSN WPA RSN'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'pairwise' value 'TKIP CCMP TKIP CCMP'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'group' value 'WEP40 WEP104 TKIP CCMP WEP40 WEP104 TKIP CCMP'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'password' value '<omitted>'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'eap' value 'LEAP'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'fragment_size' value '1300'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: added 'identity' value 'psweitzer'
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jul 30 10:50:22 SHAD0W NetworkManager: <info> Config: set interface ap_scan to 1
Jul 30 10:50:22 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 0 -> 2
Jul 30 10:50:25 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 3
Jul 30 10:50:25 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 3 -> 4
Jul 30 10:50:25 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 4 -> 0
Jul 30 10:50:25 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 0 -> 2
Jul 30 10:50:35 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 0
Jul 30 10:50:35 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 0 -> 2
Jul 30 10:50:38 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 3
Jul 30 10:50:38 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 3 -> 4
Jul 30 10:50:38 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 4 -> 0
Jul 30 10:50:38 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 0 -> 2
Jul 30 10:50:47 SHAD0W NetworkManager: <info> Activation (wlan0/wireless): association took too long.
Jul 30 10:50:47 SHAD0W NetworkManager: <info> (wlan0): device state change: 5 -> 6
Jul 30 10:50:47 SHAD0W NetworkManager: <info> Activation (wlan0/wireless): asking for new secrets
Jul 30 10:50:47 SHAD0W NetworkManager: <info> (wlan0): supplicant connection state change: 2 -> 0



iwconfig output :


wlan0 IEEE 802.11abgn ESSID:"mySSID"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power=14 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality=100/100 Signal level:-53 dBm Noise level=-127 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

psweitzer
31st July 2008, 08:09 PM
46 views and nothing?

No one else out there running F8, LEAP and have the latest updates applied?

Someone? Anyone? :D